5Ghz wifi no longer gives Internet access, 2.4 GHz is slow.

5Ghz wifi no longer gives Internet access, 2.4 GHz is slow.
5Ghz wifi no longer gives Internet access, 2.4 GHz is slow.
2020-05-31 00:07:00
Hardware Version: V1
Firmware Version: 1.0.3 Build 20171016 Rel.54581

A few days ago, after several months of great service, the 5GHz wifi on my TL-WPA7510 stopped providing Internet access and the 2.4 GHz wifi slowed down substantially. I can always associate with the 5GHz signal but either cannot access Internet at all, or at extremely slow speeds. My router provides a 400 Mbps connection. Currently, the extender's 2.4GHz wifi provides about 40 Mbps upload and download. The extender's 5GHz wifi provides either nothing or close to nothing. All lights are solid green on both the adapter and the extender. I tried moving the extender to other outlets in the house and resetting the unit with no success. I tried changing the 5GHz channel, channel width and transmit power, but still no success.

 

The tpPLC app says that the data rate between the adapter and extender is about 270 Mbps.

 

If I connect directly to my wifi router, I get fast Internet access.

 

Do you have suggestions on how to resolve the issue?

 

Thank you in advance.

 

0
0
#1
Options
5 Replies
Re:5Ghz wifi no longer gives Internet access, 2.4 GHz is slow.
2020-06-01 20:23:52

@dpo 

 

Try swapping the Ethernet cable the first powerline adapter is using to the router and switch LAN ports. You can also factory reset the wireless adapter by holding the reset pinhole for 5 seconds. 

 

Another thing to try is to place the wireless adapter in the same room as the first powerline adapter and test both bands. If speeds are normal (obviously) then the outlet you have been using may have come across interference with something else or something changed in the wiring. Move the wireless to a different outlet where it was to see if that helps.

0
0
#2
Options
Re:5Ghz wifi no longer gives Internet access, 2.4 GHz is slow.
2020-06-04 01:46:02

@Tony Many thanks for your reply. I tried all your suggestions: I changed the Ethernet cable between my router and the adapter, and tried all four LAN ports on the router. The results are the same: extremely slow 5GHz wifi. I did a factory reset: same results. Finally, I plugged the extender in a wall outlet in the same room as the adapter: same results also. The 2.4GHz wifi speeds are reasonable but also slower than expected (~30 Mbps download and ~45 Mbps upload while I get ~400 download and ~50 upload when I connect to the router's 5GHz wifi).

 

Any other suggestions? Did something get fried inside the device?

 

Thanks.

0
0
#3
Options
Re:5Ghz wifi no longer gives Internet access, 2.4 GHz is slow.
2020-06-04 22:09:22

@dpo 

 

Remove the Ethernet cable from the first powerline adapter and plug that into your computer to see what speeds that cable is pushing through.

 

You could also factory reset the wireless adapter by holding the reset button for 10 while the adapter is plugged in, then repair it with the main powerline adapter.

0
0
#4
Options
Re:5Ghz wifi no longer gives Internet access, 2.4 GHz is slow.
2020-06-06 22:42:30 - last edited 2020-06-06 22:43:03

@Tony Using the cable straight from the model, I get 180 Mbps download and 50 upload, but I think those are limitations of the ethernet dongle.

 

I've already gone through the factory reset twice. No joy.

0
0
#5
Options
Re:5Ghz wifi no longer gives Internet access, 2.4 GHz is slow.
2020-06-08 21:21:11

@dpo 

 

If you are currently getting 180 Mbps it could give a variable to the reduced speeds. Aside from that, the 5GHz should be giving internet, if it still is not then it would be best to contact our support. 

0
0
#6
Options