TP-Link range extender RE305 not working correctly with Pi-Hole

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
TP-Link range extender RE305 not working correctly with Pi-Hole
TP-Link range extender RE305 not working correctly with Pi-Hole
2020-10-14 16:30:15
Model: RE305
Hardware Version: V3
Firmware Version: 1.1.2 Build 20200212 Rel. 67183

Hello Everyone,

Is it possible that TP-Link range extender will work with Pi-Hole? I setup manually in my TP-Link RE305 static IP and DNS pointing out to my Pi-Hole devise as below:

 

IP Address: 192.168.0.254

Mask: 255.255.255.0

Default Gateway: 192.168.0.1

Primary DNS: 192.168.0.26 (this is address of my Pi-Hole devise)

Secondary DNS: 192.168.0.26 (this is address of my Pi-Hole devise)

 

When I am logged on my laptop or phone I have normal internet access via TP-link extender network, but seems that Pi-Hole (adblocking) is not working in this case. As a part of trouble-shooting I tried also change for a while manually DNS directly on my laptop to point out to PI-Hole (192.168.0.26) and then it work perfect, so there is no problem on other devices. I found somewhere information that DNS sever shouldn’t be on the same subnet – is that the case?

Is there any option to fix this problem?

0
0
#1
Options
1 Reply
Re:TP-Link range extender RE305 not working correctly with Pi-Hole
2020-10-14 21:53:30

@Proxim 

 

The DNS servers would be set according to the router, not the RE305. If the RE305 was your DHCP server, then you could go with the setup you mentioned, but the extender doesn't appear to have that option.

 

What may be happening is the device going through the extender may not be getting the DNS server from the routers DHCP server compared to it connecting directly to the router.

1
1
#2
Options