Smart plug HS105 losing connectivity to the wifi network

Smart plug HS105 losing connectivity to the wifi network
Smart plug HS105 losing connectivity to the wifi network
2017-03-30 21:43:38
Model :

Hardware Version :

Firmware Version :

ISP :

I have a complete TP-Link environment with AP225s and a separate 2.4gHz SSID just for the plugs. I have no problem getting to join the network, but both of my smart plugs will drop off the network after about 24-36 hours. They will have a blinking blue light or the Kasaa app will not recognize them. Simply unplugging them and re-plugging them will resolve the issue for another day or so.

I've set the DHCP lease to not expire, so that's not it. Firmware is current. Right now I am at a loss.
0
0
#1
Options
15 Replies
Re:Smart plug HS105 losing connectivity to the wifi network
2017-04-30 13:12:39
I'm having the same issue with 2 units. I've also tried firmware updates, two different wireless networks, forcing channels high and low (3/10), different authentication, HT20 and HT40, nothing improves the stability of these units.
0
0
#2
Options
I've given up
2017-05-02 20:35:48
I'm moving on to a Wink hub and Z-wave switches. These are just too unreliable
0
0
#3
Options
Re:Smart plug HS105 losing connectivity to the wifi network
2017-05-02 21:42:26
I found the same problem with reliability fixed as posted here: http://forum.tp-link.com/showthread.php?96845-HS105-Keep-Falling-off-from-network&p=203854&viewfull=1#post203854. Rock solid now - unlike the kasa app, my app checks them constantly so I can see if they lose connectivity at any time.
0
0
#4
Options
Re:Smart plug HS105 losing connectivity to the wifi network
2017-05-03 04:59:30
I found that when my smart plug loses wi-fi, it sets the date to January 1, 2000. This causes it to go "local" only. I have had to reset my device twice to fix this problem. Very annoying. Can this be fixed with firmware? I'm running the latest firmware version. Also, when this "date" change happens, Alexa can no longer control it. But, like I said, after pushing the button for 10 seconds and re-configuring the plug, it works again.

My biggest complaint is what happens when I go on vacation this summer and all of a sudden I can no longer control it from my Kasa app? The good news is, the last program remains and it will turn on and off based on the schedule, but I can not remotely control it in this state.

Any ideas? Do I need a replacemnet device?

Thanks
0
0
#5
Options
Re:Smart plug HS105 losing connectivity to the wifi network
2017-05-04 06:09:01
Same issues here, with or without Router Reboot shenanigans. I own 3 HS100's which are stable and 3 105's that like to 'disappear' individually or as a group about every 18 to 24 hours. On the bright side, it's somewhat euphoric when they actually work - but that's not really what I thought I was paying for. Firmware upgrade via Windows download tool resulted in error code -2 (apparently the firmware on the 105's is current).

adding my discontent to the thread in the off-chance a viable solution is posted.
0
0
#6
Options
Re:Smart plug HS105 losing connectivity to the wifi network
2017-05-04 15:42:40
thanks
0
0
#7
Options
Re:Smart plug HS105 losing connectivity to the wifi network
2017-05-04 21:50:09
Do they lose their wifi connection as in they're blinking and no local (or remote) control or are you losing the cloud connection only?

If it's local/wifi, Belkin too has a local connection issue with their "wemo mini plug". I would willingly bet the mini and 105 share the same hardware platform, and possibly the same firmware as belkin tends to use freeware in their plugs, I suspect TP Link does as well. I seem to have sorted the issue with my mini (it's been connected solid for weeks now, previously it was days) by forcing the router to a 20MHz channel width. I also configure the router to a fixed wifi channel for other reasons so that may or may not be a factor.
0
0
#8
Options
Re:Smart plug HS105 losing connectivity to the wifi network
2017-05-04 23:17:43
In my case, it still works from the Kasa app, but only when I'm on the same wifi network. But It won't let me see it remotely. Also, Alexa can no longer see it. To fix it, I need to hold the reset button down for 10 seconds, until it blinks blue/yellow, then reconfigure it. After that it is ok again, until my wifi has an issue. It has happened 2 times on the same plug for me. Support has suggested I use windows to get newer firmware, but I only own Macs at home, so there is no windows option for me. I had a different issue with a wall switch, and TP-Link sent me a new replacement unit. Came in yesterday. I was surprised that the packaging was different (different shade of blue). Almost makes me think that the Amazon one I got was old stock. They assured me that the new one had newer firmware (that has a fix for my issue). I'll wire it in this weekend and see if my issue gets resolved. NOTE: the wall switch issue is NOT the same as the date issue when wifi is lost.
0
0
#9
Options
Re:Smart plug HS105 losing connectivity to the wifi network
2017-05-05 09:41:58
Sounds different than the OP's problem - your devices are still connected to wifi but for some reason are having trouble getting through to the Kasa cloud. Makes sense (as well as being unfortunate) that Alexa will stop working too in that case as I'm pretty sure the Alexa skill is alexa cloud to tp link cloud to your device. Hopefully the new firmware will sort it, best of luck. If it doesn't you'll find my app works with alexa locally so as long as your TP Link is connected to your wifi it can continue to operate (by voice or app) even if the TP Link cloud stops working.
0
0
#10
Options
Re:Smart plug HS105 losing connectivity to the wifi network
2017-05-05 21:17:38
It happened again last night. This will be the 4th time in the month that I've owned this device. Device time is set to Jan 1, 2000 7:01:51 PM. H/W version 1, firmware version 1.0.6.
What's interesting is, the device still maintains it's timer setting. It still comes on at 7:15 pm and off at midnight, even when in the weird state. If I want to turn it off, I can use the Kasa app, but my phone has to be on the same wi-fi (home wi-fi). So you're right, it still seems to be connected to the wi-fi. I have contacted TP-link support to inquire about getting a replacement with newer firmware. When I chatted with support, they told me that i need a Windows PC to update the firmware. Unfortunately we are a Mac only house, no windows anywhere :-)
I'm waiting to hear back from support. They did replace my HS200. It even came in newer looking packaging. I will be wiring it up this weekend to see if it works better.
0
0
#11
Options