How I made TL-PA9020P work acceptably (but not perfectly)

How I made TL-PA9020P work acceptably (but not perfectly)
How I made TL-PA9020P work acceptably (but not perfectly)
2017-04-23 03:49:28
Model :

Hardware Version :

Firmware Version :

ISP :

Hi:



As I haven't seen many posts on this model, I'd like to share my experience.

I wanted faster connection than wireless for file transfer between my PC in the bed room and my NAS somewhere else. (As my internet is 18 MB/s, wireless was good enough for internet.)So I opted for the fastest, AV2000 TL-PA9020P (actually 2 kits, i.e., total 4 units).BUT, just like others mentioned in the other posts, my 9020s was very unstable.



My symptoms were:


(A) Lose connection (“no internet access”) during web surfing intermittently – sometimes the connection backs up itself after several (10 – 20) seconds, sometimes never comes back and requires reset of 9020, i.e., unplug and plug.

[COLOR=black][FONT=Segoe UI](B) Lose connection after sometime of inactivity or computer sleep mode – pretty much requires reset of 9020 every time.
[/FONT]
[COLOR=black][FONT=Segoe UI](C) Once you lose the connection, restarting of the computer sometimes recover the connection but sometimes not. Sometimes even unplug/plug of 9020 doesn’t work!

The following are what I did to make my connection acceptably stable. (I’m getting about 600-700 Mbps with the router connected to NAS with sometimes slow web surfing - it’s OK by me. And my son could manage to do online gaming through the night at similar speed last night.) I’m no network expert and no way am qualified to confirm what I did is right. This was done on try and error with no detailed network diagnoses. But as I spent so many hours to troubleshoot, I just want to share what worked for me. Obviously your problems, configurations and requirements may vary, so please treat this as “hints” rather than “guidelines” if you have any issues with 9020.
[/FONT]


[COLOR=black][FONT=Segoe UI]1. NIC Power Management[/FONT]



Disabled “Allow the computer to turn off this device to save power” option on Windows

[*]Set PC to “never sleep”

[COLOR=black][FONT=Segoe UI]It was obvious that 9020 sometimes cannot automatically recover the connection with the NIC after certain time of inactivity or sleep mode. By doing the above, your NIC is always on and so is 9020. I don’t know if NIC itself is part of the issue or maybe this it is the indirect results from 9020’s own “Power-Saving Mode” which you cannot control. I suspect 9020 sleeps when NIC sleeps? In any case, this eliminated my Symptom (2) 100%.)
[/FONT]


[COLOR=black][FONT=Segoe UI]2. Power-up Sequence
[/FONT]



Bought short 3-prong power extension cord

[*]Make sure to plug in 9020 first (until 2 LEDs on) and then ethernet cable



[COLOR=black][FONT=Segoe UI](Like most of you, 9020 blocked my bedroom’s corner outlet so I had to take the power for the PC and the display from 9020’s pass-through outlet. But, this way, when you reset 9020 (unplug and plug), you also shut down the PC, which was very tedious. So I bought this short extension cord and plug the power strip for the PC directly to the wall outlet, so that I can reset 9020 without shutting down the PC. But when I did this (unplug and plug 9020 with the PC on), the internet connection didn’t recover. When I unplug/plug the ethernet cable (or restart my PC), after 9020 reset, the connection does recover. T his eliminated my Symptom (3) 100%.)
[/FONT]
[COLOR=black][FONT=Segoe UI]
3. One (1) IPv6
[/FONT]


[COLOR=black][FONT=Segoe UI]Disabled Win7’s IPv6 randomization function[/FONT]
[*][COLOR=black][FONT=Segoe UI]Disabled Win7’s temporary IPv6 function[/FONT]
[*][COLOR=black][FONT=Segoe UI]Check Win7’s “Obtain IPv6 automatically”[/FONT]
[*][COLOR=black][FONT=Segoe UI]Check Win7’s “Use the following DNS…” (i.e., uncheck “Obtain DNS automatically) [/FONT]


(I noticed my internet drop-outs and losses happen most when I’m using Google search. I was using static IP(v4) but auto/auto for IPv6 as I had no clue. I originally suspect the issue is somehow related to the link between IP and NIC MAC address (well this turns out to be only applicable to IPv4, differently handled in IPv6), I set static IPv6 and specified DNS(v6) as well. In this set-up, “ipconfig” revealed I actually have total 5 IPv6s (3 regular and 2 temporary).Although it seems Windows should “prioritize” and manage multiple IPv6s so that there is no connection issue, 5 IPv6 just didn’t seem right to me.After a long research and try and error (I even went back to IPv4 only system, bad idea, more issues than 9020), the above is the way I find to make only one IPv6 (autoconfig on, HDCP off.)This improved my Symptom (1) significantly.So far I haven’t had any prolonged drop-outs to lose my internet connection.Loading of new sites from Google is still sometimes slow but 3-5 seconds rather than 10-20 seconds to recover the internet connection as before.

I hope this helps whoever haven’t given up on 9020.

AKam

PC, Windows 7
AT&T Gateway NVG599
0
0
#1
Options
8 Replies
Re:How I made TL-PA9020P work acceptably (but not perfectly)
2017-04-24 18:18:21
Bought short 3-prong power extension cord

[*]Make sure to plug in 9020 first (until 2 LEDs on) and then ethernet cable
0
0
#2
Options
Re:How I made TL-PA9020P work acceptably (but not perfectly)
2017-04-29 08:33:23
i.e. the 9020P product is awful and doesn't work reliably...
0
0
#3
Options
Re:How I made TL-PA9020P work acceptably (but not perfectly)
2017-06-08 19:17:16
New beta firmware now available that fixes most of this.
0
0
#4
Options
Re:How I made TL-PA9020P work acceptably (but not perfectly)
2017-07-31 17:27:32
Does it?
0
0
#5
Options
Re:How I made TL-PA9020P work acceptably (but not perfectly)
2017-09-16 00:18:32
Yes.
I'm happy to report that the latest firmware update (Ver. 3.2.4) resoved my issues, confirmed after testing of a few weeks.
- No slowig down / disconnction during web browsing.
- No disconnection even after long inactivity and/or power save mode

Per tp-link utility
Speed to "gateway" unit: 600-1,000 Mbps through circuit breaker (25 year-old, 3,000 sq. ft. 2-storey house).
Between units in the same room (same circuit): >1,400 Mbps! (not that I need this particular link...)

Now I'm happy I chose this road (powerline) rather than messing with wireless router, antennae and signal strength, etc.

AKam
0
0
#6
Options
Re:How I made TL-PA9020P work acceptably (but not perfectly)
2017-09-17 06:59:55
Just for reference - was that the production 3.2.4 from TP-Link, or the beta version from these forums?

nb - just in case you were not aware - the tp-link utility speeds have little relevance to the actual network transfer speeds you will see.
0
0
#7
Options
Re:How I made TL-PA9020P work acceptably (but not perfectly)
2017-09-19 21:24:18
Ver. 3.2.4. is official firmware update from TP-Link.
0
0
#8
Options
Re:How I made TL-PA9020P work acceptably (but not perfectly)
2017-09-20 00:27:57
To be precise - it's 3.2.4b - release 170628.
0
0
#9
Options