Making Windows 10 Mobile Hotspot work with the new TP-Link USB WiFi adapter

Used Products:

Credit to forum user @flkvjhsektjhs 

 

This isn't a request for help, I'm just documenting how I made my new USB wifi adapter work with Mobile hotspot on Windows 10. I mostly use these devices to create a hotspot at work for my phones to connect to the cabled Ethernet connection, and a full-fledged router isn't an option, so I need the mobile hotspot function to work properly. However, during both my previous install (TL-WN725N) and this one (T4U v3) I encountered several hurdles before I could make them work. Perhaps others have the same problems and these points might help them troubleshoot.

 

Basically, I was upgrading from the TL-WN725N to the T4U v3, uninstalled the old drivers and installed the new ones. WiFi started up fine, but the hotspot didn't work. I also tried to revert back to the TL-WN725N in one of the attempts to figure out what was wrong.

 

Issues I encountered & solutions that worked for me - YMMV. Most solutions are picked from online discussions and articles; however, some information out there is outdated and it's also better to have them in one place.

 

  1. TP-Link driver install hangs for a long time, both with TL-WN725N and T4U. I even aborted one install because it was stuck at 54% for ages. The solution was to just wait; the install completed eventually.
  2. The wifi device isn't ready after the first restart (Code 56 = still setting up class for device warning in Device Manager). Restart again.
  3. Driver doesn't support hosted network (netsh wlan show drivers). Searching online for solutions, I found several posts claiming that this was the problem - as far as I understand the state of things, however, this is outdated information. Hosted network support isn't needed for mobile hotspot in new versions of Windows 10.
  4. Microsoft Wi-Fi Direct Virtual Adapter has "Windows is still setting up the class configuration for this device. (Code 56)" error. This does seem to be relevant. The solution was to uninstall various software that have network drivers/filters, such as firewall, VPN, and Virtual Machine; in my case, Comodo CIS and Oracle VirtualBox were the troublemakers. After removing them and restarting, the mobile hotspot started without issues, and the code 56 error didn't show up. Finally, I reinstalled CIS and VirtualBox and all is still fine.
  5. There seems to be no way to configure the hotspot, e.g. which band and channel it uses. At least there's a way to force the device into the 5 GHz band, by going into the WiFi device's properties in Device Manager (in my case it's called TP-Link Wireless MU-MIMO USB Adapter), Advanced panel, and setting Wireless Mode to 802.11 ac, for example.
  6. No internet connection through the hotspot. Check if the cabled connection is being shared - Windows tends to change this on its own sometimes. Network & Internet settings, Change adapter options, go into LAN/Ethernet connection properties, check the "Allow other network users to connect through this...", and set the "Home networking connection" to the hotspot's connection (the one with MS Wi-Fi Direct Virtual Adapter). If you want to share not the cabled LAN but some other connection, of course, you need to set that one to shared.

 

I hope this was helpful.

0 Subscribe Bookmark

Comment

upload
    upload
      Subscriptions