KL120 Smart Bulb Intermittent 'Device Unreachable'

KL120 Smart Bulb Intermittent 'Device Unreachable'
KL120 Smart Bulb Intermittent 'Device Unreachable'
2020-07-10 15:17:14
Model: KL120
Hardware Version: V1
Firmware Version: 1.8.11

Hi there, I'm wondering if there are any tips to ensure that my KL120 smart bulb stops dropping off my network. I have a KL60 in the same room which never loses connection and doesn't give me any problems.

 

The Kasa app doesn't indicate that any firmware updates are available for either so I presume them to be running the latest versions. This does not seem to be a WiFi signal strength related issue because the KL120 has a signal strength at -58 dBm whereas the non problematic KL60 reports -65 dBm (somewhat weaker from my understanding).

 

Measures I've tried:

  • I've factory reset the bulb/deleted it from the app
  • Physically removed and reinserted the bulb
  • Reinstalled the Kasa software
  • Rebooted my router

 

However, despite all of that, this intermittent problem randomly comes and goes. The last time I factory reset it, it took several tries to get it to connect to the WiFi at all.The typical error message is says 'Device Unavailable', suggesting that it is powered off or out of the network range.

 

Greatly appreciate if anyone has any tips - maybe there is a less problematic firmware for this bulb?

0
0
#1
Options
2 Reply
Re:KL120 Smart Bulb Intermittent 'Device Unreachable'
2020-07-10 22:26:13

@Zatowashi 

 

When doing the reset either with the light switch or physically unscrewing it, that it be done five times, three times will just reset the Wi-Fi settings. 

 

Even though the signal strength shows it is better to move it to an area that is much closer to rule outdistance. If the issue follows the bulb, then I would reach out to support as the KL120 may have issues.

0
0
#2
Options
Re:KL120 Smart Bulb Intermittent 'Device Unreachable'
2020-09-03 02:01:24

@Tony I'm having that same issue.  After losing power from Hurricane Laura for six days of course they all came on as usual when power was restored but this time I can't get them back online. 
I've done all the reinstalling, reset turning 3 times, factory reset turning 5 times; and everything else they try to say very frustrating especially after a hurricane. Last night I gave up and tonight I'm doing the same; however, on a brighter note, all of my smart plugs behaved beautifully, the older and the mini ones. 

0
0
#3
Options