HS100 daylight saving not working

HS100 daylight saving not working
HS100 daylight saving not working
2020-10-25 21:46:52 - last edited 2 weeks ago
Model: HS100
Hardware Version:
Firmware Version:

Since the clocks changed, my two HS100's have not adjusted their internal clocks. Opening the Kasa app I forced the location sync but if I look at each device under DeviceInfo, the wrong time is shown.

 

Why can't these devices do this automatically?

How can I force a correction?

 

thanks

1
1
#1
Options
1 Accepted Solution
Re:HS100 daylight saving not working-Solution
2020-10-28 17:20:36 - last edited 2020-10-29 17:14:00

From the information I was able to get this will be resolved after November 1st. In the meantime, alternative solutions mentioned already are suggested if you are not able to wait that long.

Recommended Solution
1
1
#17
Options
20 Replies
Re:HS100 daylight saving not working
2020-10-25 23:48:12 - last edited 2020-10-26 00:04:10

Same here in the UK. I don't remember it being a problem previously, I've had these two HS100s for a few years.

 

Update: Just did a firmware update (now 1.2.6, hardware version 1.0), but still the device info shows an hour later than the actual time.

 

0
0
#2
Options
Re:HS100 daylight saving not working
2020-10-26 10:18:36 - last edited 2020-10-26 15:20:46

@HiZ @Rallyz @TP_LINK @Tony  I can confirm I have the same issue with my HS100 here in Germany. I have tried the following:

 

0. updating to the lastest 1.2.6 firmware

1. re-syncing the location in the Kasa app

2. manually setting the timezone in the Kasa app

3. soft resetting the HS100

4. factory resetting the HS100.

 

None of the above worked - the plug's Device Time is still stuck on daylight saving time, and hour ahead of the current time. It was never an issue in the past. How can this be fixed?

0
0
#3
Options
Re:HS100 daylight saving not working
2020-10-26 10:52:55

@Rallyz and others

 

Same here in France. I don't remember it was a problem previously (although I've had these three HS100s for a few years); after the firmware update (now 1.2.6, hardware version 1.0), same issue: the device info shows an hour later than the actual time.

Other info: all my other HS100 (v2.0 or v4.0, FR and EU) do not have any issue with the time sync following the daylight saving upgrade since last saturday.

I have open a support ticket to TP-Link; not really confident with the answer and/or the solution (especially if the answer do consist in "no additionnal FW for HS100 v1.0" which may signify that my three running HS100 may go the the trash which is not all compliant with the planet health of course). Let's wait for any answer.

0
0
#4
Options
Re:HS100 daylight saving not working
2020-10-26 14:24:24

Me 5 (in UK).
 

How is it possible that the time synced at 14:13 but the device time is in the future?

 

0
0
#5
Options
Re:HS100 daylight saving not working
2020-10-26 14:53:56

Ah! I have two HS100 plugs with hardware version 1.0, firmware version 1.2.6 and two with hardware version 2.1, firmware version 1.5.10. It's only the 1.0 devices that have the problem. 
 

So the solution is to throw away the version 1.0 plugs and buy new ones :^)

0
0
#6
Options
Re:HS100 daylight saving not working
2020-10-26 21:19:50 - last edited 2020-10-26 21:20:53

OK so I've got a workaround. In the Kasa app force the TimeZone to a different one than say "UTC Europe/London" which it automatically detected. I initially picked UTC-1 to see if that sorted it but it then skipped back 2 hours! Anyway after several attempts picking UTC/UTC has resulted in the right time.

 

Perhaps the issue is actually with the app and not the the plugs. Crazy how there are so many variations of the same timezone listed in the app such as UTC/GMT-0 and UTC/GMT+0.

4
4
#7
Options
Re:HS100 daylight saving not working
2020-10-27 16:51:41

Thank you guy for the information, I will see what I can find.

 

I've seen cases before or everyone being affected by certain features so something may be going on in the backend.

2
2
#8
Options
Re:HS100 daylight saving not working
2020-10-27 19:31:33

I have exactly the same problem. I have 4 HS100 units that all suffer from this problem. My other HS110 units reflected the change from DST to Standard time just fine.

 

I hope tp-link will fix this very soon.

 

I'm located in western Europe.

0
0
#9
Options
Re:HS100 daylight saving not working
2020-10-27 20:18:34 - last edited 2020-10-27 20:23:16

@HiZ 

Same here. I have 6 smartplugs, only 2 keep the old DST time, both HS100 v1 FW 1.2.6.

Two v2's work as expected, also my 2 HS110's.

Tried reset and force sync, even new time zone, but nothing changed.

 

0
0
#10
Options
Re:HS100 daylight saving not working
2020-10-27 22:13:35

@HiZ 

Did not work for me.

However, UTC/London seems okay. All clocks are UTC+1, although I do not see the logic here.

Maybe the location (Netherlands) adds the extra hour. 

 

0
0
#11
Options