Reconnect after router restart

Reconnect after router restart
Reconnect after router restart
2017-06-22 19:38:48
Model :

Hardware Version :

Firmware Version :

ISP :

Good day all.I have a number of HS 105 Smart Plug Mini. Love them and so far they are working very well.I recently had to go thru a firmware update for my router, which required a router restart. Well, once the restart was completed, none of the smart plugs would work via My Echoand the Kasa app indicated that the plugs were offline.With no knowledge of how to correct the problem, I went through the entire reinstall process to get the plugs to work again. THERE HAS TO BE AN EASIER WAY.If anyone has a solution I would surely appreciate hearing from you and thanks in advance for your assistance.
1
1
#1
Options
6 Reply
Re:Reconnect after router restart
2017-07-21 15:35:43
i am afraid you have to reconfigure them. press the button for 5 seconds then you can add it using the app but keep the settings when kasa asks you do you want to keep it
0
0
#2
Options
Re:Reconnect after router restart
2017-07-29 05:29:29
Same issue with 3 of 4 HS100's. Had to reboot router for firmware update and only 1 of the 4 devices came back without intervention. All 3 of the others had to be reinstalled just as if they were new out of the box. Don't understand how the 1 HS100 worked flawlessly; maybe it could train the other 3?
1
1
#3
Options
Re:Reconnect after router restart
2017-07-31 16:51:48
As I know, the devices would re-connect automatically as long as the wifi name and password haven't been changed. But when you upgrade the firmware for the router, it will take several minutes, while the smart plug may try to re-connect once it get disconnected. Then the smart plug will fail to disconnect because the router haven't finished upgrading. In this case, it should be working again if you just reboot the smart plug.
0
0
#4
Options
Re:Reconnect after router restart
2020-12-09 19:19:02 - last edited 2020-12-09 19:19:33

I found a solution that worked for me. Hopefully it works for anyone reading.

 

My scenario:

I have a number Kasa Smart Plug Mini (they all look the same but turn out to have slighly different part numbers), 3 regular switches, and a dimmer switch. I purchased them all from Amazon in the last month.

 

I woke up one morning and my internet was down. My phone was connected to wifi but no data. I rebooted my network and everything I own began working again, except the kasa products. Not a single one reconnected! The best I could find on the internet was to reformat each unit and re-add them to my network. I wasn't even able to accomplish that, which was especially infuriating.

 

Solution:

I live in a neighborhood. A surprising number of my neighbors networks have reasonable signal strength in my house. I decided to do a "channel scan" for all 2.4 Ghz networks. It turned out that pretty much everyone, including myself was on the same channel. My router channel was set to "Auto." Not sure what the point of that is if it's not looking for empty channels. Anyway, I changed to an empty channel. Just like that, all of my Kasa hardware reconnected on its own!

 

In summary, I think there was too much signal traffic on the same channel. Every router will be different, but you can probably google how to change the channel for your specific router. If you have dual bands, its the 2.4 Ghz network you care about. Also they make apps for your smart phone that will tell you about the networks and channel usage near you.

 

Hope this helps anyone reading! 

0
0
#5
Options
Re:Reconnect after router restart
2021-12-23 21:04:02

I just had this same problem...loaded a firmware update on my router the other day, then half of my Kasa switches wouldn't connect. Tried several router reboots, several switch "restarts," plus turned off power at breakers to truly power the switches down and reboot. Nada....

 

So, I ended up brute-forcing it and doing something that I should NOT have had to do, but it worked. I went into my wireless router config and changed the DHCP address range to something completely different, which forced the router to drop all the IP reservations for my devices. Then I changed it back, and hit "restart" on all the switches that still wouldn't connect. That forced the switches to restart and grab a new IP. Everything seems happy now.

 

 

0
0
#6
Options
Re:Reconnect after router restart
2022-04-30 14:55:37

  @Armor LTC  I couldn't  re connect  the tplink

0
0
#7
Options