How to resolve common problems when setting up the Kasa smart device (Plug/Bulb)

Released On: 2018-11-05 12:19:52Last update time: 2021-02-16 18:32:20

Our Kasa app is designed to provide an easy step-by-step process to set up your new smart device. However, there may be instances where issues come up during the installation. This guide will try and provide steps to try in order to resolve your issue.


Case 1 

  • Go into the “Settings > Wi-Fi” menu of your smartphone for Android or "Settings > Wi-Fi > Choose a network" for iOS, manually connect to the smart device's network. Open Kasa and select the option that you are manually connected to the smart device located on the bottom of the setup screen
  • Make certain you choose the correct smart device to connect to. The last four characters of the MAC address are also apart of the network name of the smart device.
  • Disable any VPN connection that your phone may be using during the setup.
  • Perform a factory default on the smart device and repeat the process.
  • If your Apple device is running iOS 14, check the app permission to allow local network access


Case 2

  • Make sure the smart device is not connecting back to your home Wi-Fi network. If so, connect back to the TP-Link Wi-Fi network.
  • Reinstall the Kasa app on your smartphone.


Case 3

  • When on the screen where you join the smart device to the network. The wireless network name you see above the wireless password box should be the one you normally connect to in order to receive internet, if not, select the link below to choose a different network name.
  • The wireless signal should be at least two bars, if it is one bar, move the device closer for setup.
  • If the router’s SSID is hidden, please choose “manually setup my Wi-Fi” to input SSID and password.


Case 4

  • Wait 15 seconds then check LED status. If the smart device's LED indicates it is connected to the network or if the bulb blinks several times, do not select the option to start over. Sign out and back into the Kasa app and wait a few minutes to see whether the device is working.
  • Check to see if your phone is now connected back to your home Wi-Fi. If not, connect back, and go back to Kasa.
  • Verify that the wireless password being used is correct. Going into your phone Settings > Wi-Fi menu. Forget the wireless network that you are trying to connect the smart device to, and then reconnect. When the phone asks for the wireless password, use the same password that you tried in Kasa. Delete the password that exists in the box and enter the wireless password for your network again.

I'm trying to set up the device and just doesn't connect to the cellphone. What can I do?


hack pubg mobile

Have a Kasa smart plug set up successfully & connected to Alexa.  Want to add 2 Kasa smart bulb-not having any success.  Do I have to register the bulbs w/Kasa?  If so, how?  If not, how can I connect the bulbs to Alexa? Have gone through the Kasa instructions but continue to receive "no device found' from both Kasa and Alexa (I think-?? have repeated steps so many times, I don't know which is which now-ugh). Thanks

how do you get ahold of tplink by phone?


@Brocanvas your idea is good, I love this view!

Thankyou somuch for the great article..... i learned a lot from this....thankyou

in case 2   " If so, connect back to the TP-Link Wi-Fi network. " Where is the option to do this?


I have a problem with case 3, trying to connect a smart plug. My home network is never found, my ssid is not hidden. Even when i manually enter my SSID and password, the app still cannot connect. I have tried deleting and redownloading the app, same issue.

Any suggestions as to why this might be happening, thanks

Perform factory default on smart device,............ Yup,...... might help I think,......... But why not describe how to do a factory default ;-) ? ,............. You guys have a lot to improve still.


iOS ?,......... What about Android,......


Your product and your web pages are made in a hurry.


Hurry up to imrpove them :-)


You need to make it clear if you're talking about the mobile phones WLAN or the TP-Link products WLAN,........... it's not obvious which one you're talking about in your terrible KASA app which is after factory reset and re-install of kasa apparently managing to collect the information and send it to the TP-link device, but then it thinks it failed for some reason ?,............ probably because of bug in the device or the KASA app in relation to mye somewhat complicated WLAN setup here at home (many WLANs).

If Kasa is hanging forever after you have selected you home network and given your password for it (and you consequently don't get the device configured), then the reason could be that you have entered the wrong WLAN password.


You can do factory reset of the EU100 by holding the tiny button in the top for more than 10 seconds,... it will first flash slowly, then later quickly, and then you have factory settings.


Thanks to tp-link phone support for helping me out making me realize I've maybe entered the wrong password.


The design is such that you don't get an error message of what you did wrong (regrettably).