How to resolve common problems when setting up the Kasa smart device (Plug/Bulb)

Released On: 2018-11-05 12:19:52Last update time: 2021-02-16 18:32:20

Our Kasa app is designed to provide an easy step-by-step process to set up your new smart device. However, there may be instances where issues come up during the installation. This guide will try and provide steps to try in order to resolve your issue.


Case 1 

  • Go into the “Settings > Wi-Fi” menu of your smartphone for Android or "Settings > Wi-Fi > Choose a network" for iOS, manually connect to the smart device's network. Open Kasa and select the option that you are manually connected to the smart device located on the bottom of the setup screen
  • Make certain you choose the correct smart device to connect to. The last four characters of the MAC address are also apart of the network name of the smart device.
  • Disable any VPN connection that your phone may be using during the setup.
  • Perform a factory default on the smart device and repeat the process.
  • If your Apple device is running iOS 14, check the app permission to allow local network access


Case 2

  • Make sure the smart device is not connecting back to your home Wi-Fi network. If so, connect back to the TP-Link Wi-Fi network.
  • Reinstall the Kasa app on your smartphone.


Case 3

  • When on the screen where you join the smart device to the network. The wireless network name you see above the wireless password box should be the one you normally connect to in order to receive internet, if not, select the link below to choose a different network name.
  • The wireless signal should be at least two bars, if it is one bar, move the device closer for setup.
  • If the router’s SSID is hidden, please choose “manually setup my Wi-Fi” to input SSID and password.


Case 4

  • Wait 15 seconds then check LED status. If the smart device's LED indicates it is connected to the network or if the bulb blinks several times, do not select the option to start over. Sign out and back into the Kasa app and wait a few minutes to see whether the device is working.
  • Check to see if your phone is now connected back to your home Wi-Fi. If not, connect back, and go back to Kasa.
  • Verify that the wireless password being used is correct. Going into your phone Settings > Wi-Fi menu. Forget the wireless network that you are trying to connect the smart device to, and then reconnect. When the phone asks for the wireless password, use the same password that you tried in Kasa. Delete the password that exists in the box and enter the wireless password for your network again.

 have just upgraded my BT router and have been trying to reconfigure my Smart Plug to connect to the new router. Thanks for sharing very knowledgeable information

Purchased some HS103P4 and they will not complete the setup process.  I get to the "case 4" part; the plug flashes blue (quickly) while the "connecting smart plug to your home network" runs.  After about 30 seconds the LED goes back to blue / amber flashing and the app eventually tells me "unable to connect to your wi-fi network".  I have checked and triple-checked everything (including how many wireless devices can be connected to my router). I have many HS105 which all work perfectly and set-up as expected.  Is it possible I received 4 103 plugs that are all defective? I have run the setup app on 2 different phones and 2 different tablets all resulting in the same error.

thanks i connected in this service


seo expert  :

Follow-up to my HS103 connectivity issues.  It seems these plugs are incompatible with routers set to WPA2/WPA Mixed security.  If you change the router's wireless security to WPA2 everything (setup, etc) works fine.   That said, if you change your router back to WPA2/WPA Mixed they go offline and are not controllable with the app nor Alexa.  My HS105 are unaffected either way. The solution seems to be TP-Link needs to update their firmware to use the same protocols in the HS1103 as the HS105.


TL;DR.  To fix the HS103 connectivity issue, change your 2.4 wireless security to WPA2.

Make sure you have updatedyour Kasa app to the newest 2.11.0 version.

Thank's for giving complete guid set up your new smart device.

Thanks, Connected too.

I am connected with tp-link and tp-link service .this is the best product ever. 


more details- click here

The signature of symbol thats make you just crazy. visit-

Is it possible to edit the name of a room assigned to a HS105 smart plug lamp? problem

The signature of symbol thats make you just crazy. visit-

thanks for giving infromation on How to resolve common problems when setting up the Kasa smart device it helps me well..for best lyrics visit.