How to add an Omada Gateway to the network with Controller v4.4.3 or above

How to add an Omada Gateway to the network with Controller v4.4.3 or above

Re:【FAQs Released】How to add an Omada Gateway to the network?
2021-04-02 21:22:26

Ok, my solution was to restore from a backup that I had. I luckly had incerted a USB drive and enabled the system settings backup option.

I hit restore and it reset the system back to a configuration that was good and the R605 then was automaticly adopted.

 

I conclude that the Firmware has a bug that under certain combination of things it gets crooupted and will not allow the R605 to be adopted.

 

Its not perfet but it works. Another note, when you restore from the backup it erases the good backup you restored from. I think that is really stupid!

  0  
  0  
#24
Options
Re:【FAQs Released】How to add an Omada Gateway to the network?
2021-04-19 22:37:27

 

Ljugtomten wrote

@Fae Well, these instructions to adopt a GW works for a while...

My GW have almost 27 days of uptime, today I noticed that Omada (SW-controller) is back to a loop trying to Adopt and Provision the GW..

 

Did you get this resolved?

My TL-R605 and OC200 had been playing nice for almost 2 months. I was trying to figure out why I could ping vLan 1 to 10, but not the other way around. In fact, the devices on vLan 10 couldn't ping their appropriate gateway. Rebooted the entire system thinking that'd fix it...

Now the Gateway and controller are in a constant adopt, configuring, adopt failed loop. 

 

  • Factory reset the gateway, logged in, changed the LAN IP, tried to adopt it. It wouldn't adopt.
  • Factory reset the gateway and controller, adopted successfully. Changed the LAN (vLan 1) subnet. Worked for 5 mins, went into the loop of death again.
  • Factory reset the gateway and controller, adopted successfully, restored the controller backup, not successful. Went into the adopt, configuring loop for a minute and then the gateway isolated itself, none of the admin accounts worked anymore.
  • Build a software based controller on Ubuntu 18.04. Adopted the gateway, same issue, looped and then gateway isolated itself again.
  • Bought a brand new gateway (figured it was bad hardware, since both software and hardware controller had the same issue). Left the subnets unchanged, rebuilt the entire network on default subnet . Upgraded the gateway to the latest firmware. Worked fine for abotu 12 hours, now adopt failed.

 

At this point, i'm at wit's end. Unfortunately wife is hope, so internet has to stay up so I can't troubleshoot anymore. I really like this system, I really want it to work, but... I have no idea what to do now, seems like I'm running into several bugs.

  1  
  1  
#25
Options
Re:【FAQs Released】How to add an Omada Gateway to the network?
2021-04-20 01:37:32

@Infinity3 I'm in exactly the same position (even vis a vis the wife). I don't even have the problem of needing to adopt to a different subnet - everything else is static allocated to 192.168.0.x and I actually have constant pass through of WAN-LAN all the time, but the adopt-provisioning cycle is ongoing. 

  0  
  0  
#26
Options
Re:【FAQs Released】How to add an Omada Gateway to the network?
2021-04-20 03:01:21

Dear @cromagnon, @Infinity3,

 

For the ER605 adopt-provisioning cycle issue, would it help if you reboot the ER605 by unplugging the power cord and plug it back?

 

What's the firmware version of your ER605 router? May I know the version of your Omada Controller, is it v4.2.11?

2022 TP-Link Wi-Fi 7 Product Launch Event | Watch the Replay at https://www.tp-link.com/us/wifi7/event/.
  0  
  0  
#27
Options
Re:【FAQs Released】How to add an Omada Gateway to the network?
2021-04-20 05:27:12

@Fae I just had the same issue and that was the solution. I had tried restoring a recent backup and that didn't work, so I unplugged the router for 10 seconds, which was successful.

  0  
  0  
#28
Options
Re:【FAQs Released】How to add an Omada Gateway to the network?
2021-04-25 07:21:39

@Fae 

 

Hi there,

 

I have difficulty with adopting tl-er 7206 with my oc200. I followed the instruction to change oc 200 to static with the same subnet to 198.168.0.xx. I still cannot connect the router. Power light is stable and sys light is flashing, but no link/act light from any port. I reset the router quite a few times still no luck. Doesn't my router work?

 

 Thanks

  0  
  0  
#29
Options
Re:【FAQs Released】How to add an Omada Gateway to the network?
2021-05-17 10:02:58

@BFH Your solution worked for me and I am SO happy about this. Took me days trying to figure out wat was wrong.

 

Greatly appreciated!

 

Regards from a, now happy, Dutch TP Link user :)

  0  
  0  
#30
Options
Re:【FAQs Released】How to add an Omada Gateway to the network?
2021-05-19 18:01:32

@Fae 

 

Why don't you allow the main config to initially happen in stand-alone mode, then on adoption you allow the user to bring those settings with the device? That would work great, and I can't imagine too hard to implement prior to version 5 coming out.

 

I run my OC in docker, and the instructions you provided won't work.

 

  1  
  1  
#31
Options
Re:【FAQs Released】How to add an Omada Gateway to the network?
2021-05-22 00:50:43

@Fae 

I have a similar issue that occurred on April 30, 2021, while updating 4 remote networks using the upgrade function in the Omada Cloud portal.  I had a few different outcomes on different networks.

 

On the one relevant to this post, the gateway router is operational, it functions and is visible in Omada, but has DISCONNECTED status.  Initially I had the option to adopt, re-adopt and force provision, currently I only have options to Move to site which works successfully and Force Provision which says successful, but status does not change.  I can access and change most gateway parameters, but from the dashboard it will not report speeds and says it's disconnected.   I attempted to solve by following recommendation to set Controller/General Settings/Network Settings to Static.  The controller rebooted with static IP, no change on gateway status.  Maybe this is a bug report.

 

OC200v1 4.3.5 [1.8.0 20210406 rel 58757] + TL-R605 v1.0 [1.0.1 Build 20210113 Rel.35074] + EAP225v3.0 [5.0.3 Build 20210316 Rel. 67358]

Gateway: 192.168.0.1

Controller: 192.168.0.100

 

Thanks.

  0  
  0  
#32
Options
Re:【FAQs Released】How to add an Omada Gateway to the network?
2021-07-10 20:19:46

@Fae I am installing the TL-ER7206 for the load balance of two internet services: AT&T and Blue Stream. However, there is an ip conflict between the WAN: DHCP client setting IP and the Gateway of one modem. It seems both use the same IP. Any recommendation?

  0  
  0  
#33
Options