No internet access when connected to OpenVPN

No internet access when connected to OpenVPN

No internet access when connected to OpenVPN
No internet access when connected to OpenVPN
2021-01-14 10:53:45 - last edited 2022-08-31 03:16:04
Model: ER605 (TL-R605)  
Hardware Version: V1
Firmware Version: 1.0.0

Hi all,

I have a Client-to-Site VPN with OpenVPN running on my TL-R605. This works perfectly fine on my iPhone, however I can only connect to local devices. Access to the internet is not working and that is annoying since I have to disconnect from the VPN to access internet resources.

I read the documentation but nothing is mentioned regarding additional configuration to access the internet.

How I configured the VPN:


Joeri

  1      
  1      
#1
Options
1 Accepted Solution
Re:No internet access when connected to OpenVPN-Solution
2022-07-29 03:16:40 - last edited 2022-08-31 03:16:04

Dear @JsJh,

 

JsJh wrote

@Fae  Has anyone had technical support, or anyone in TPLink, acknowledge this as a real issue (I have not read all 5 pages of the posts here!)?

I've been going around with business technical support on this for a few days now via email & they appear to have no clue about the problem.

 

Besides the newly acquired ER605, I have a TPLInk AC1750 and a TPLink AC4000, both of which can be OpenVPN servers. When I enable their servers, there is an option for clients to have either "Home Network Only" access, or "Internet and Home network" access. With "Home Network Only" chosen, I see exactly what my ER605 is doing, with "Internet and Home network", I see the behaviour I want and expect i.e. I can get out to the wider Internet via the OpenVPN connection.

 

Even the help available on these routers OpenVPN setup pages explains that the difference is in routing configuration rules. It seems clear that the ER605 is incapable of setting up the routing for "Internet and Home network", and doesn't even have that option.


Sorry for any trouble caused. I'm afraid that the ER605 is only capable of the "Home Network Only" mode for the time being, which doesn't support the remote device to access the internet through the VPN Server with ER605. However, there is a plan to add the support for the "Internet and Home network" mode in the firmware adapted to Controller v5.8, let's stay tuned!

2022 TP-Link Wi-Fi 7 Product Launch Event | Watch the Replay at https://www.tp-link.com/us/wifi7/event/.
Recommended Solution
  3  
  3  
#48
Options
51 Reply
Re:No internet access when connected to OpenVPN
2021-01-14 11:36:18 - last edited 2021-04-18 09:19:17

@joeri1 

 

Im guessing you are running via SDN Adoption?

 

I have the same setup and so far no issues like this, however just my 2 cents

 

 

1.  Is the pool in the same classification as the LAN?   Namely is the LAN running on 172.16.x.x range?     mine is set LAN on 192.168.25.1/24  VPN clients on 192.168.30.1/28  and appears to be working

 

2.  Try changing the last octect (the 0) to a 1

 

may not be of any help but just what jumps to mind :)

 

  0  
  0  
#2
Options
Re:No internet access when connected to OpenVPN
2021-01-15 14:40:38 - last edited 2021-04-18 09:19:17

@joeri1 I am also experiencing this issue. I am also unable to access the internet when using L2TP/IPSec server or OpenVPN server. 

  0  
  0  
#3
Options
Re:No internet access when connected to OpenVPN
2021-01-16 09:35:02 - last edited 2021-04-18 09:19:17

@joeri1 

I too have the same problem. Using a TL-R605 router, iPhone as client with the OpenVPN config generate by sdn and can only access local devices via the VPN and not the internet. 

  1  
  1  
#4
Options
Re:No internet access when connected to OpenVPN
2021-01-16 19:10:18 - last edited 2021-04-18 09:19:17

Yes me to. No internett when OPENVPN is connected on my computer.

 

I Delete OpenVPN server in SDN, its gone from the console but I can steel log in with OpenVPN, Its deleted from SDN but not in the TL-R605.

 

Hmmm Strange. It seems to be a bug.

 

comment: after restart off TL-R605 OpenVPN is gone :-)

  0  
  0  
#5
Options
Re:No internet access when connected to OpenVPN
2021-01-18 18:04:38 - last edited 2021-04-18 09:19:17

@joeri1 Same problem here, but I cannot connect to devices on my LAN while I am using the VPN from outside. 

  0  
  0  
#6
Options
Re:No internet access when connected to OpenVPN
2021-01-18 18:11:41 - last edited 2021-04-18 09:19:17

@Philbert Are you able to access any devices on your local network through the VPN?

  0  
  0  
#7
Options
Re:No internet access when connected to OpenVPN
2021-01-18 18:52:19 - last edited 2021-04-18 09:19:17

@infinitytec 

 

Hey

 

Yeah I am indeed, I set it up to access my server via RDP if i needed, only used it twice but works both times.

 

Using OPENVPN and on a different subnet of the LAN that the server is on.  

 

Given the number of peopel reporting this issue, I think i have just been lucky :)

 

 

As said, noting fancy on the setting..

  1  
  1  
#8
Options
Re:No internet access when connected to OpenVPN
2021-01-18 19:10:32 - last edited 2021-04-18 09:19:17

@Philbert  Ah, I am suspicious subnets are my issue. Admittedly i am not very good at them. Can you give me an example of how yours are set up?

  0  
  0  
#9
Options
Re:No internet access when connected to OpenVPN
2021-01-18 23:29:04 - last edited 2021-04-18 09:19:17

@infinitytec 

 

Yeah certainly

 

I have LAN on 192.168.10.x/24 range   -   WAN on 192.168.0.x/28  range   VPN on 192.168.20.x/26   guest on 30.x/24   IOT  40.x/24.  you get the idea

 

So far it seems to be working ok

  1  
  1  
#10
Options
Re:No internet access when connected to OpenVPN
2021-01-19 01:43:16 - last edited 2021-04-18 09:19:17

@Philbert Interesting. That seems to be similar to what I am doing. I will need to check my config and see what's going on.

 

Thanks for the information. This helps quite a bit!

  0  
  0  
#11
Options