No internet access when connected to OpenVPN

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
123...

No internet access when connected to OpenVPN

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
No internet access when connected to OpenVPN
No internet access when connected to OpenVPN
2021-01-14 10:53:45 - last edited 2022-08-31 03:16:04
Model: ER605 (TL-R605)  
Hardware Version: V1
Firmware Version: 1.0.0

Hi all,

I have a Client-to-Site VPN with OpenVPN running on my TL-R605. This works perfectly fine on my iPhone, however I can only connect to local devices. Access to the internet is not working and that is annoying since I have to disconnect from the VPN to access internet resources.

I read the documentation but nothing is mentioned regarding additional configuration to access the internet.

How I configured the VPN:


Joeri

  1      
  1      
#1
Options
2 Accepted Solutions
Re:No internet access when connected to OpenVPN-Solution
2023-04-17 02:35:22 - last edited 2023-05-17 03:28:49

Hi All,

 

For OpenVPN Full mode support, please refer to the following details:

1. As for Controller, the Software Controller has supported it from v5.8 and the Hardware Controller has released new firmware v5.9.32 recently to support the full mode either.

2. As for ER605 v1, a new official firmware v1.3.0 has been released and has supported this feature.

3. As for ER605 v2, it has supported the Full mode from official firmware v2.1.1.

4. As for ER7206, from the official firmware v1.3.0 start to support it.

 

Here are some guidelines related the OpenVPN as your reference:

How to Configure TP-Link Omada Gateway as OpenVPN Server on Standalone Mode

How to Configure TP-Link Omada Gateway as OpenVPN Server on Controller Mode

How to Configure TP-Link Omada Gateway as OpenVPN Client

Recommended Solution
  0  
  0  
#59
Options
Re:No internet access when connected to OpenVPN-Solution
2023-05-17 03:39:08 - last edited 2023-05-17 03:39:51

Hi All,

 

A new 1.3.0 Official firmware has been released, please follow the post link below for details.

ER605 V1_1.3.0 Official Firmware (Released on May 17th, 2023)

 

The missing Full mode issue has been fixed in this official firmware, you may take your time to upgrade the 1.3.0 firmware and confirm the issue you encountered has been resolved.

Recommended Solution
  0  
  0  
#69
Options
70 Reply
Re:No internet access when connected to OpenVPN
2021-01-14 11:36:18 - last edited 2021-04-18 09:19:17

@joeri1 

 

Im guessing you are running via SDN Adoption?

 

I have the same setup and so far no issues like this, however just my 2 cents

 

 

1.  Is the pool in the same classification as the LAN?   Namely is the LAN running on 172.16.x.x range?     mine is set LAN on 192.168.25.1/24  VPN clients on 192.168.30.1/28  and appears to be working

 

2.  Try changing the last octect (the 0) to a 1

 

may not be of any help but just what jumps to mind :)

 

  0  
  0  
#2
Options
Re:No internet access when connected to OpenVPN
2021-01-15 14:40:38 - last edited 2021-04-18 09:19:17

@joeri1 I am also experiencing this issue. I am also unable to access the internet when using L2TP/IPSec server or OpenVPN server. 

  0  
  0  
#3
Options
Re:No internet access when connected to OpenVPN
2021-01-16 09:35:02 - last edited 2021-04-18 09:19:17

@joeri1 

I too have the same problem. Using a TL-R605 router, iPhone as client with the OpenVPN config generate by sdn and can only access local devices via the VPN and not the internet. 

  1  
  1  
#4
Options
Re:No internet access when connected to OpenVPN
2021-01-16 19:10:18 - last edited 2021-04-18 09:19:17

Yes me to. No internett when OPENVPN is connected on my computer.

 

I Delete OpenVPN server in SDN, its gone from the console but I can steel log in with OpenVPN, Its deleted from SDN but not in the TL-R605.

 

Hmmm Strange. It seems to be a bug.

 

comment: after restart off TL-R605 OpenVPN is gone :-)

  0  
  0  
#5
Options
Re:No internet access when connected to OpenVPN
2021-01-18 18:04:38 - last edited 2021-04-18 09:19:17

@joeri1 Same problem here, but I cannot connect to devices on my LAN while I am using the VPN from outside. 

  0  
  0  
#6
Options
Re:No internet access when connected to OpenVPN
2021-01-18 18:11:41 - last edited 2021-04-18 09:19:17

@Philbert Are you able to access any devices on your local network through the VPN?

  0  
  0  
#7
Options
Re:No internet access when connected to OpenVPN
2021-01-18 18:52:19 - last edited 2021-04-18 09:19:17

@infinitytec 

 

Hey

 

Yeah I am indeed, I set it up to access my server via RDP if i needed, only used it twice but works both times.

 

Using OPENVPN and on a different subnet of the LAN that the server is on.  

 

Given the number of peopel reporting this issue, I think i have just been lucky :)

 

 

As said, noting fancy on the setting..

  1  
  1  
#8
Options
Re:No internet access when connected to OpenVPN
2021-01-18 19:10:32 - last edited 2021-04-18 09:19:17

@Philbert  Ah, I am suspicious subnets are my issue. Admittedly i am not very good at them. Can you give me an example of how yours are set up?

  0  
  0  
#9
Options
Re:No internet access when connected to OpenVPN
2021-01-18 23:29:04 - last edited 2021-04-18 09:19:17

@infinitytec 

 

Yeah certainly

 

I have LAN on 192.168.10.x/24 range   -   WAN on 192.168.0.x/28  range   VPN on 192.168.20.x/26   guest on 30.x/24   IOT  40.x/24.  you get the idea

 

So far it seems to be working ok

  1  
  1  
#10
Options
Re:No internet access when connected to OpenVPN
2021-01-19 01:43:16 - last edited 2021-04-18 09:19:17

@Philbert Interesting. That seems to be similar to what I am doing. I will need to check my config and see what's going on.

 

Thanks for the information. This helps quite a bit!

  0  
  0  
#11
Options

Information

Helpful: 1

Views: 16788

Replies: 74

Related Articles