Problem with mbentley/docker-omada-controller on Synology NAS

Problem with mbentley/docker-omada-controller on Synology NAS

Problem with mbentley/docker-omada-controller on Synology NAS
Problem with mbentley/docker-omada-controller on Synology NAS
2022-08-08 14:40:25 - last edited 2022-08-08 14:52:51
Hardware Version:
Firmware Version: 5.4.6

@mbentley Hoping you can help...  Docker image of 5.4.6 has stopped working after about 24h.  Problem starting mongodb.  Tried to revert to previous 5.1.7 docker image, but devices are reporting 'managed by other' now.   In both cases, I setup the container as 'host networking', as opposed to bridged to simply PORT remappings.  This has previously worked for 5.0.30 and 5.1.7 for months.

 

I would be happy to rebuild the container and re-apply the original backup, but my concern is the new controller instance has changed the Device admin login info, and now I can no longer access it because the web UI won't come up.

 

Here's the startup log:

 

Initial indication of problem in logs:

 

 

then this sequence just starts repeating

 

  0      
  0      
#1
Options
3 Reply
Re:Problem with mbentley/docker-omada-controller on Synology NAS
2022-08-08 14:48:50 - last edited 2022-08-08 14:49:10

  @d0ugmac1 

 

From the mongod.log

 

022-08-08T14:46:54.972+0000 I CONTROL  [main] ***** SERVER RESTARTED *****                                                                                                    

2022-08-08T14:46:55.853+0000 I CONTROL  [initandlisten] MongoDB starting : pid=1127 port=27217 dbpath=../data/db 64-bit host=Omada_Controller_5.4.6                            

2022-08-08T14:46:55.854+0000 I CONTROL  [initandlisten] db version v3.6.8                                                                                                      

2022-08-08T14:46:55.855+0000 I CONTROL  [initandlisten] git version: 8e540c0b6db93ce994cc548f000900bdc740f80a                                                                  

2022-08-08T14:46:55.856+0000 I CONTROL  [initandlisten] OpenSSL version: OpenSSL 1.1.1f  31 Mar 2020                                                                           

2022-08-08T14:46:55.857+0000 I CONTROL  [initandlisten] allocator: tcmalloc                                                                                                    

2022-08-08T14:46:55.857+0000 I CONTROL  [initandlisten] modules: none                                                                                                          

2022-08-08T14:46:55.858+0000 I CONTROL  [initandlisten] build environment:                                                                                                     

2022-08-08T14:46:55.859+0000 I CONTROL  [initandlisten]     distarch: x86_64                                                                                                   

2022-08-08T14:46:55.860+0000 I CONTROL  [initandlisten]     target_arch: x86_64                                                                                                

2022-08-08T14:46:55.861+0000 I CONTROL  [initandlisten] options: { net: { bindIp: "127.0.0.1", port: 27217 }, processManagement: { pidFilePath: "../data/mongo.pid" }, storage:

 { dbPath: "../data/db", journal: { enabled: true } }, systemLog: { destination: "file", logAppend: true, path: "../logs/mongod.log" } }                                       

2022-08-08T14:46:55.867+0000 E STORAGE  [initandlisten] Failed to set up listener: SocketException: Address already in use                                                     

2022-08-08T14:46:55.868+0000 I CONTROL  [initandlisten] now exiting                                                                                                            

2022-08-08T14:46:55.869+0000 I CONTROL  [initandlisten] shutting down with code:48                                                                                             

  0  
  0  
#2
Options
Re:Problem with mbentley/docker-omada-controller on Synology NAS
2022-08-08 14:51:15

  @d0ugmac1 

 

and some filtered netstat -a

 

root@Omada_Controller_5:/opt/tplink/EAPController/logs# netstat -a | grep 27217                                                                                                

tcp        0      0 localhost:27217         0.0.0.0:*               LISTEN                                                                                                     

tcp        0      0 localhost:27217         localhost:38725         ESTABLISHED                                                                                                

tcp        0      0 localhost:27217         localhost:38692         ESTABLISHED                                                                                                

tcp        0      0 localhost:27217         localhost:38724         ESTABLISHED                                                                                                

tcp        0      0 localhost:27217         localhost:38691         ESTABLISHED                                                                                                

tcp        0      0 localhost:27217         localhost:38702         ESTABLISHED                                                                                                

tcp        0      0 localhost:27217         localhost:38719         ESTABLISHED                                                                                                

tcp6       0      0 localhost:38719         localhost:27217         ESTABLISHED                                                                                                

tcp6       0      0 localhost:38702         localhost:27217         ESTABLISHED                                                                                                

tcp6       0      0 localhost:38692         localhost:27217         ESTABLISHED                                                                                                

tcp6       0      0 localhost:38725         localhost:27217         ESTABLISHED                                                                                                

tcp6       0      0 localhost:38724         localhost:27217         ESTABLISHED                                                                                                

tcp6       0      0 localhost:38691         localhost:27217         ESTABLISHED                                                                                                

unix  2      [ ACC ]     STREAM     LISTENING     193620   /tmp/mongodb-27217.sock

  0  
  0  
#3
Options
Re:Problem with mbentley/docker-omada-controller on Synology NAS
2022-08-08 20:53:25

  @d0ugmac1 

 

I tried killing and restarting the processes, no dice.

Restarted the NAS and container, in various orders, no dice.

Tried changing the IP from 127.0.0.1 to a fixed IP (My NAS has multiple IPs), no dice.

Tried changing the port for mongdb to 27717, no dice.

 

I was able to create a new container from the image and it's up and running just fine.  Leads me to believe that something happened in the first day or so of operation that corrupted the Omada install.

 

If there is a way to extract the device management user/password from the DB or via shell access to the docker container, that would be a lifesaver, or maybe just fine a way to have a new image leverage the data store of the non-working image?

  0  
  0  
#4
Options