ER7206 OpenVPN

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

ER7206 OpenVPN

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
ER7206 OpenVPN
ER7206 OpenVPN
2023-04-18 12:09:52 - last edited 2023-04-20 15:46:47
Model: ER7206 (TL-ER7206)  
Hardware Version: V1
Firmware Version: 1.2.3

Hi,

 

I have an ISP router (Virgin) connected to my router (ER7206). The ISP is configured as DHCP and is giving an IP (192.168.0.77) to my router, that gives an DHCP IP to the rest of the office through his LAN (192.168.10.1). So its: ISP > ER7206 > LAN Office

 

I was trying to create a VPN trough L2TP, but it seems to have an issue with recent updates on Windows, so when I tried to create a OpenVPN Server, the file exported is getting the DHCP IP from the ISP router instead of what I believe that should be the public IP.

 

Am I doing something wrong? Do I need to setup something on the WAN port to get the public IP there?

 

Thanks in advance.

  0      
  0      
#1
Options
1 Accepted Solution
Re:ER7206 OpenVPN-Solution
2023-04-19 12:59:22 - last edited 2023-04-20 15:46:47

  @felipe321 

 

I wouldn't disable DHCP...very unlikely that will do what you want.  As I stated, next step is to try to tell the modem that your router is the DMZ (basically it means all ports are 1:1 forwarded from the public IP to the designated DMZ IP).  Obviously you will want the DMZ IP fixed...statically assigned or IP reserved for obvious reasons.

<< Paying it forward, one juicy problem at a time... >>
Recommended Solution
  0  
  0  
#4
Options
4 Reply
Re:ER7206 OpenVPN
2023-04-18 13:32:25

  @felipe321 

 

Ideally you'd put your Virgin router in passthrough or bridged mode, which would allow the public IP assigned by Virgin to be assigned to the WAN of your 7206.

 

If you cannot put your router in the above 'transparent' mode, then your next option is to make the private IP of your 7206 be statically assigned by the Virgin router AND then configure the 7206's IP to the be the DMZ IP for your Virgin router.  Determine the public IP of your Virgin router and set that as the public IP of your OpenVPN server (use a site like formyip,com)

<< Paying it forward, one juicy problem at a time... >>
  0  
  0  
#2
Options
Re:ER7206 OpenVPN
2023-04-19 11:20:10

  @d0ugmac1 

 

After your message, I searched and found a post on Virgin website that shows how to use it on "modem mode only", but turns out that my specific modem model don't have this option.

 

Do you think that if I just disable the DHCP (I was thinking to disable NAT too, but didn't find this option too) it will give the public IP to the 7206? I'll try this soon, but I just wanted to make sure before doing it.

 

Thanks!

  0  
  0  
#3
Options
Re:ER7206 OpenVPN-Solution
2023-04-19 12:59:22 - last edited 2023-04-20 15:46:47

  @felipe321 

 

I wouldn't disable DHCP...very unlikely that will do what you want.  As I stated, next step is to try to tell the modem that your router is the DMZ (basically it means all ports are 1:1 forwarded from the public IP to the designated DMZ IP).  Obviously you will want the DMZ IP fixed...statically assigned or IP reserved for obvious reasons.

<< Paying it forward, one juicy problem at a time... >>
Recommended Solution
  0  
  0  
#4
Options
Re:ER7206 OpenVPN
2023-04-20 15:47:59

  @d0ugmac1 

 

That worked. After setup the DMZ it worked, but then I just set up manually a port forward necessary to work the VPN server.

 

Thank you so much.

  0  
  0  
#5
Options

Information

Helpful: 0

Views: 482

Replies: 4

Related Articles