OC200 - failed to upgrade

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

OC200 - failed to upgrade

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
OC200 - failed to upgrade
OC200 - failed to upgrade
2023-05-07 12:48:19 - last edited 2023-05-22 05:14:46
Model: OC200  
Hardware Version: V1
Firmware Version: OC200(UN)_v1_1.24.0_20230328

Current situation

Controller Version: 5.7.6

Model: OC200 1.0

Firmware Version: 1.21.7 Build 20221206 Rel.58608

Internal Storage: Disk (1.88 GB free of 3.00 GB)

 

Issue

Trying to upgrade my OC200 v1 with firmware 1.21.7 to the latest firmware 1.24.0, I'm getting an error that an incorrect firmware file was provided.

I downloaded it several times and stored on different disk locations and mediums (PC, NAS), so ruling out the download itself.

 

Log info

In the server.log I notice the following:

 

05-07-2023 12:19:32.067 INFO [https-jsse-nio-443-exec-15] [] c.t.s.o.h.b.b(1119): Upgrade failed in omadacId <...>, reason Invalid firmware file.
05-07-2023 12:19:32.126 ERROR [https-jsse-nio-443-exec-15] [] c.t.s.o.h.b.b(1524): Read file /tmp/sysinfo/version.json error
05-07-2023 12:19:32.198 WARN [https-jsse-nio-443-exec-15] [] c.t.s.o.c.u.r(224): fail to transfer json to map .
<...>MismatchedInputException: No content to map due to end-of-input
 at [Source: (String)""; line: 1, column: 0]

05-07-2023 12:19:32.460 WARN [https-jsse-nio-443-exec-15] [] c.t.s.o.h.b.b(1129): Catch exception <...>MismatchedInputException: No content to map due to end-of-input
 at [Source: (String)""; line: 1, column: 0] when get firmware version in <...>

 

Note: I obfuscated the omadacId (is it critical?) and cut out all trace dependencies down to bare minimum to avoid form checker identifying "illegal" links

1* OC200 v1.0 1* TL-R605 v1.0 1* TL-SG2428P v1.0 3* EAP245(EU) v3.0 1* EAP225-Outdoor (EU) v3.0
  0      
  0      
#1
Options
1 Accepted Solution
Re:OC200 - failed to upgrade-Solution
2023-05-22 05:14:12 - last edited 2023-05-22 05:14:46

Finally I received the official update notification for my ER605v1 and after updating also for my OC200.

1* OC200 v1.0 1* TL-R605 v1.0 1* TL-SG2428P v1.0 3* EAP245(EU) v3.0 1* EAP225-Outdoor (EU) v3.0
Recommended Solution
  0  
  0  
#4
Options
3 Reply
Re:OC200 - failed to upgrade
2023-05-07 13:07:05
Did you unzip the file you downloaded? With what? I just did this yesterday process works, in fact I did it all with my Android phone. You are sure yoyr hardware is v1 and not v2? I do find it odd that 5.7.6 still thinks it os the latest firmware when you ask it to check for an update though.
<< Paying it forward, one juicy problem at a time... >>
  0  
  0  
#2
Options
Re:OC200 - failed to upgrade
2023-05-07 13:14:39

  @d0ugmac1 

I did not realize the ZIP must be extracted blush. I did, then read the included upgrade manual.

The manual states that once I upgrade OC200 I should also upgrade the other Omada products (router, switch and access points). However the router (ER605 v1) has no official 5.9 firmware update available. Could that be the reason why the OC200 firmware update is not offered yet through it's web interface?

1* OC200 v1.0 1* TL-R605 v1.0 1* TL-SG2428P v1.0 3* EAP245(EU) v3.0 1* EAP225-Outdoor (EU) v3.0
  0  
  0  
#3
Options
Re:OC200 - failed to upgrade-Solution
2023-05-22 05:14:12 - last edited 2023-05-22 05:14:46

Finally I received the official update notification for my ER605v1 and after updating also for my OC200.

1* OC200 v1.0 1* TL-R605 v1.0 1* TL-SG2428P v1.0 3* EAP245(EU) v3.0 1* EAP225-Outdoor (EU) v3.0
Recommended Solution
  0  
  0  
#4
Options

Information

Helpful: 0

Views: 656

Replies: 3

Related Articles