Both my and a clients ER605 crash when I connect a 5G router as a second WAN!

Both my and a clients ER605 crash when I connect a 5G router as a second WAN!

Both my and a clients ER605 crash when I connect a 5G router as a second WAN!
Both my and a clients ER605 crash when I connect a 5G router as a second WAN!
2023-12-18 07:33:50
Model: ER605 (TL-R605)  
Hardware Version: V2
Firmware Version: 2.1.2 Build 20230210 Rel.62992

Both me and my client have a VDSL connection as a landline that we use PPPoE as a connection method. That works fine and is very stable. My client wanted to add parity and a faster 5G connection to her network because her dsl connection is super slow (under 24Mbps). We got a mikrotik chateau 5g. I added the SIM and connected the router to my second wan port as a dynamic address just to try the connection. Lo and behold the whole network comes down! The second I connect the 5g router to my WAN 2 the er605 marked both connections as offline and after some seconds CRASHED and Restarted! Just to be sure I pull the DSL connection and the internet gets restored! So unless I have ONE of the two connections both would stay down.

 

I Then set the mikrotik router to passthrough mode just to get an external IP to the dynamic ip port of the wan 2 and connect it to the ER605 again. This time it can stay on with both WANS connected but it marks both as offline EVEN THO THEY BOTH HAVE AN IP!!! 

 

This is getting annoying because my network HAS internet and it should see it as online!

 

So two problems are prevalent:

1) if the DHCP server is running on my mikrotik the ER605 straight up crashes and DOES NOT recover until I pull the cable. I am talking not responding at all! (FYI the subnet of my network is 10.10.20.0 and the mikrotik is 192.168.88.0 so they are not classing!)

 

2) When I set the mikrotik as a passthrought to an ether port and connect that port to WAN of ER605 the network gets internet but BOTH DSL and Cellural are marked as OFFLINE even tho they both have an IP and an internet connection( and can ping ofc). The makes it IMPOSSIBLE to have both connections on the network at all times and use the cellular as primary and the DSL as backup in case the first one goes down.

 

This is a really annoying problem and the whole point of getting an ER605 for balancing.  

  0      
  0      
#1
Options
9 Reply
Re:Both my and a clients ER605 crash when I connect a 5G router as a second WAN!
2023-12-18 07:47:16 - last edited 2023-12-18 07:51:07

Hi @Xarishark 

Thanks for posting in our business forum.

You look like a smart guy but have you ruled out the basic possibilities yet?

A quick read-through brings two questions from my side:

IP conflict which can cause it to convert to offline.

A backup WAN will remain offline.

 

Which I have explained in this KB.

 

Post some screenshots. I don't have any idea why it crashes by your word description.

 

 

Update:

Xarishark wrote

So two problems are prevalent:

1) if the DHCP server is running on my mikrotik the ER605 straight up crashes and DOES NOT recover until I pull the cable. I am talking not responding at all! (FYI the subnet of my network is 10.10.20.0 and the mikrotik is 192.168.88.0 so they are not classing!)

 

It crashes straight up. So, what is the status on this WAN?

What do you do to verify the WAN is down? Ping 192.168.88.1, 10.10.20.1, and 8.8.8.8 or a website in your country?

Xarishark wrote

 

2) When I set the mikrotik as a passthrought to an ether port and connect that port to WAN of ER605 the network gets internet but BOTH DSL and Cellural are marked as OFFLINE even tho they both have an IP and an internet connection( and can ping ofc). The makes it IMPOSSIBLE to have both connections on the network at all times and use the cellular as primary and the DSL as backup in case the first one goes down.

Screenshot of the WANs.

Best Regards! If you are new to the forum, please read: Howto - A Guide to Use Forum Effectively. Read Before You Post. Look for a model? Search your model NOW Official and Beta firmware. NEW features! Subscribe for the latest update!Download Beta Here☚ ☛ ★ Configuration Guide ★ ☚ ☛ ★ Knowledge Base ★ ☚ ☛ ★ Troubleshooting Manual ★ ☚ (Disclaimer: Short links are used above solely for guidance to TP-Link subdomains and are safe and tracker-free. Exercise caution with short links from non-official members on forums. We are not liable for external content or damage from non-official members' link use.)
  0  
  0  
#2
Options
Re:Both my and a clients ER605 crash when I connect a 5G router as a second WAN!
2023-12-18 09:44:59 - last edited 2023-12-18 11:52:58

Hi  @Clive_A and thanks for the fast response. 

 

First off all let me clarify that I manage everything with omada local connection. 

 

1) (For the DHCP problem) As I said all 3 routers use a  different subnet. DSL router is 192.168.1.0 the mikrotik uses the mikrotik default at 192.168.88.0 and my clients network uses 10.10.50.0

 

2) (For the DHCP problem)To verify that the wan is down I try to get into google or ping google or even try get onto the net and nothing responds

 

3) (For the DHCP problem) The ER605 crashes but the the computer I have connected directly to the mikrotik still has a wan connection meaning the mikrotik does not alter its status (it still has internet and its own wan connection)  and the ER605 is crashing and not responding(crashing and restarting). What I see if I go to the devices menu is that I get a notification that the "Router ER605 was disconnected". After it restart I get the configuring status instead of the connected status in the devices list in omada. The second I pull the mikrotik from the wan port of the ER605 the router starts recovering. Again I see this crash only if the mikrotik is using working as a router too. But for the omada network the whole network loses wan even if I have another wan connected and the dual wan is in balancing mode and not in active backup. Thats how I verify that the whole ER605 is dropping. Instead of losing the mikrotik wan or have the mikrotik wan not work it also drops the DSL wan and then crashes (stops responding in the local omada interface).

 

4) (for the passthrough mode) I know the backup WAN stays offline until needed. I am talking about both of them marked as offline when they are set up as balanced and NOT in an active backup configuration. On the router pop up menu on the right both WANs are marked as OFFLINE and  if I drop the menu to check each wan it says offline in the dial up section  even tho they BOTH have a internet connection and a WAN ip populated. And ofc I can connect to the internet. 

 

5) Let me clarify that the OFFLINE  problem persists EVEN when I only have the 5g router as wan and have the DSL disconnected (Link down in the omada interface and cable removed from the wan port) as a connection. So The omada network cant work with the 5g router in general!

 

For example 

 

on this screenshot I have ONLY the 5g connected as a wan but if I also connected the DSL it would have the same status of offline.

 

I also attached the logs.

I did the trials in my clients network thisSunday 17th check from that day only so you dont waste your time.  

 

I cannot for the life of me understand why the ER605 would even crash and restart tho! I get if it drops the WAN because something is wrong but to completely crash means something very wrong.

File:
LogList_2023-12-18-11-42.xlsxDownload
  0  
  0  
#3
Options
Re:Both my and a clients ER605 crash when I connect a 5G router as a second WAN!
2023-12-20 07:56:23

Hi @Xarishark 

Thanks for posting in our business forum.

Xarishark wrote

Hi  @Clive_A and thanks for the fast response. 

 

First off all let me clarify that I manage everything with omada local connection. 

 

1) (For the DHCP problem) As I said all 3 routers use a  different subnet. DSL router is 192.168.1.0 the mikrotik uses the mikrotik default at 192.168.88.0 and my clients network uses 10.10.50.0

 

2) (For the DHCP problem)To verify that the wan is down I try to get into google or ping google or even try get onto the net and nothing responds

 

3) (For the DHCP problem) The ER605 crashes but the the computer I have connected directly to the mikrotik still has a wan connection meaning the mikrotik does not alter its status (it still has internet and its own wan connection)  and the ER605 is crashing and not responding(crashing and restarting). What I see if I go to the devices menu is that I get a notification that the "Router ER605 was disconnected". After it restart I get the configuring status instead of the connected status in the devices list in omada. The second I pull the mikrotik from the wan port of the ER605 the router starts recovering. Again I see this crash only if the mikrotik is using working as a router too. But for the omada network the whole network loses wan even if I have another wan connected and the dual wan is in balancing mode and not in active backup. Thats how I verify that the whole ER605 is dropping. Instead of losing the mikrotik wan or have the mikrotik wan not work it also drops the DSL wan and then crashes (stops responding in the local omada interface).

 

4) (for the passthrough mode) I know the backup WAN stays offline until needed. I am talking about both of them marked as offline when they are set up as balanced and NOT in an active backup configuration. On the router pop up menu on the right both WANs are marked as OFFLINE and  if I drop the menu to check each wan it says offline in the dial up section  even tho they BOTH have a internet connection and a WAN ip populated. And ofc I can connect to the internet. 

 

5) Let me clarify that the OFFLINE  problem persists EVEN when I only have the 5g router as wan and have the DSL disconnected (Link down in the omada interface and cable removed from the wan port) as a connection. So The omada network cant work with the 5g router in general!

 

For example 

 

 

on this screenshot I have ONLY the 5g connected as a wan but if I also connected the DSL it would have the same status of offline.

 

I also attached the logs.

I did the trials in my clients network thisSunday 17th check from that day only so you dont waste your time.  

 

I cannot for the life of me understand why the ER605 would even crash and restart tho! I get if it drops the WAN because something is wrong but to completely crash means something very wrong.

So I looked at this yesterday. I did not want to reply since it's a story without anything useful to me. It is quite strange, I admit that, but I cannot tell why with the log which seems to be plain fact without anything useful.

You might wanna give some information like IP stuff with screenshots. Both WANs. Load balance config. WAN config. What you wrote is long enough but not telling enough. I have to verify something first before I present this to the dev or test team to reproduce the issue. This is something new to us, telling a story does not work that well.

Have you Wireshark to check what happened to the DHCP on WAN?

Best Regards! If you are new to the forum, please read: Howto - A Guide to Use Forum Effectively. Read Before You Post. Look for a model? Search your model NOW Official and Beta firmware. NEW features! Subscribe for the latest update!Download Beta Here☚ ☛ ★ Configuration Guide ★ ☚ ☛ ★ Knowledge Base ★ ☚ ☛ ★ Troubleshooting Manual ★ ☚ (Disclaimer: Short links are used above solely for guidance to TP-Link subdomains and are safe and tracker-free. Exercise caution with short links from non-official members on forums. We are not liable for external content or damage from non-official members' link use.)
  0  
  0  
#4
Options
Re:Both my and a clients ER605 crash when I connect a 5G router as a second WAN!
2023-12-20 09:29:37 - last edited 2023-12-20 09:30:18

Hi  @Clive_A thanks for the answer and sorry if I am not providing the info you need. 

Is it ok with you to start with the offline mark on the connected mikrotik router?

 

My client only has one WAN now ( The 5g mikrotik router) so I can provide all the info you want and screenshots without the need to drop their connection for now or interrupt their workflow.

 

If we can resolve that then i would be happy to move on to the crash weirdness when both wans are connected. So we can check that too.

 

Please tell me exacty what you need and I will provide everything to the best of my ability! 

  0  
  0  
#5
Options
Re:Both my and a clients ER605 crash when I connect a 5G router as a second WAN!
2023-12-20 09:39:39

Hi @Xarishark 

Thanks for posting in our business forum.

Xarishark wrote

Hi  @Clive_A thanks for the answer and sorry if I am not providing the info you need. 

Is it ok with you to start with the offline mark on the connected mikrotik router?

 

My client only has one WAN now ( The 5g mikrotik router) so I can provide all the info you want and screenshots without the need to drop their connection for now or interrupt their workflow.

 

If we can resolve that then i would be happy to move on to the crash weirdness when both wans are connected. So we can check that too.

 

Please tell me exacty what you need and I will provide everything to the best of my ability! 


Try this article.

 

You should at least list the model number of the 5G router, your config on Load Balancing, and WANs parameters. When it crashes, what is the IP address on both WANs? etc.

If you are advanced, you can give the Wireshark result on the 5G WAN when it connects and another capture of the primary WAN.

 

Think of this from my shoes, if I present this to the dev and I say someone said the 5G router from another brand does not work. Just crashes. Turns into Disconnected. It would not make a wave. It's bad news but not a report with details so that they can investigate. I read your story and I got it but everything you can provide relates to the WAN, your network diagram and config would help find out the reason why.

Best Regards! If you are new to the forum, please read: Howto - A Guide to Use Forum Effectively. Read Before You Post. Look for a model? Search your model NOW Official and Beta firmware. NEW features! Subscribe for the latest update!Download Beta Here☚ ☛ ★ Configuration Guide ★ ☚ ☛ ★ Knowledge Base ★ ☚ ☛ ★ Troubleshooting Manual ★ ☚ (Disclaimer: Short links are used above solely for guidance to TP-Link subdomains and are safe and tracker-free. Exercise caution with short links from non-official members on forums. We are not liable for external content or damage from non-official members' link use.)
  0  
  0  
#6
Options
Re:Both my and a clients ER605 crash when I connect a 5G router as a second WAN!
2023-12-20 10:39:13 - last edited 2023-12-20 14:35:56

Hi  @Clive_A and thanks for the answer.

 

The Mikrotik model is the s53ug+m-5haxd2haxd-tc&rg502q-ea (Mikrotik Chateau 5G AX)

Here is the current topology with only one WAN (5g) connected.

Everything is controlled from the Omada controller

Mikrotik Chateau 5G AX set into passthrought to the ether1 port from the LTE interface so it works as a modem only!(managment at 192.168.88.1 but not visible as the ether1 port is set as a passthrough)

|

|

(WAN/LAN1 Port) ER605 v2.0 (2.1.2 Build 20230210 Rel.62992) (DHCP gateway 10.10.50.254) (WAN only port is disconnected for now as its set up for DSL with credentials over PPPoE) (Intergrated into Omada).

|

|

TL-SG3452P v2.0(2.0.6 Build 20230705 Rel.44420) (10.10.50.252) (Intergrated into Omada)

|

|

OC200 2.0(2.11.3 Build 20230906 Rel.36272) (5.12.9) (10.10.50.253)

 

The echo servers are the default. Here are some pings to inside and outside the network. 

 

 

Also here is the WAN/LAN 1 Config:

 

 

Here is the status

 

 

 

On the matter of the DUAL wan I will need to be in the clients office later but for now I would like to fix the detection error for the online status. 

After fixing that I will also check for a broadcast storm and provide you with everything you need (wireshark screenshots etc). 

 

Let me clarify that I like omada A LOT and I would like to manage all my clients through that instead of something like UBQ or even a non SDN solution but I will need for it to be rock solid so I can trust it more. I get that there is a chance I have made the mistake and I am more than happy to verify everything with you because I will leave this post knowing more regardless of the reason.

 

Thanks again for you time and I will update you with whatever more you need as soon as you answer

 

 

 

  0  
  0  
#7
Options
Re:Both my and a clients ER605 crash when I connect a 5G router as a second WAN!
2023-12-21 06:48:37

Hi @Xarishark 

I have added some parts and new information in the KB of Load Balancing and link backup. You can take a look at it to troubleshoot the online detection issue.

Best Regards! If you are new to the forum, please read: Howto - A Guide to Use Forum Effectively. Read Before You Post. Look for a model? Search your model NOW Official and Beta firmware. NEW features! Subscribe for the latest update!Download Beta Here☚ ☛ ★ Configuration Guide ★ ☚ ☛ ★ Knowledge Base ★ ☚ ☛ ★ Troubleshooting Manual ★ ☚ (Disclaimer: Short links are used above solely for guidance to TP-Link subdomains and are safe and tracker-free. Exercise caution with short links from non-official members on forums. We are not liable for external content or damage from non-official members' link use.)
  0  
  0  
#8
Options
Re:Both my and a clients ER605 crash when I connect a 5G router as a second WAN!
2023-12-21 09:45:09

 Hi @Clive_A 

 

Sorry for asking but can you link me to those 2 KB because I cant seem to find them. Thanks in advance. 

  0  
  0  
#9
Options
Re:Both my and a clients ER605 crash when I connect a 5G router as a second WAN!
2023-12-22 03:41:52

Hi @Xarishark 

Thanks for posting in our business forum.

Xarishark wrote

 Hi @Clive_A 

 

Sorry for asking but can you link me to those 2 KB because I cant seem to find them. Thanks in advance. 

It is a pinned thread..

Best Regards! If you are new to the forum, please read: Howto - A Guide to Use Forum Effectively. Read Before You Post. Look for a model? Search your model NOW Official and Beta firmware. NEW features! Subscribe for the latest update!Download Beta Here☚ ☛ ★ Configuration Guide ★ ☚ ☛ ★ Knowledge Base ★ ☚ ☛ ★ Troubleshooting Manual ★ ☚ (Disclaimer: Short links are used above solely for guidance to TP-Link subdomains and are safe and tracker-free. Exercise caution with short links from non-official members on forums. We are not liable for external content or damage from non-official members' link use.)
  0  
  0  
#10
Options

Information

Helpful: 0

Views: 593

Replies: 9

Related Articles