HS210, Kasa ON/OFF indicator not working

HS210, Kasa ON/OFF indicator not working
HS210, Kasa ON/OFF indicator not working
2018-12-11 18:20:45 - last edited 2018-12-18 08:07:34

Hardware Version: 1.0
Firmware: 1.5.5
Kasa App: 2.7.0 Build 816

 

HS210 works fine as a manual switch.
However, Kasa does not indicate correctly whether the switch is ON or OFF.
For example, I manually press the switch on, but Kasa shows switch is OFF.

 

I can also use Kasa to turn the switch ON, but the Kasa ON indicator turns grey after several seconds (OFF).

 

Any type of automation (e.g. scheduling) will not work since the ON/OFF indicator light is wrong.

 

This has been reported previously in 2 separate threads in the forum:
https://forum.tp-link.com/showthread.php?108308-HS210-Kasa-Schedule-On-Off-Problem&highlight=hs210
https://forum.tp-link.com/showthread.php?108920-HS-210-on-off-issue-with-Kasa&highlight=hs210

1
1
#1
Options
8 Replies
Re:HS210, Kasa ON/OFF indicator not working
2018-12-18 09:07:46
When the indicator is off on kasa app, if you tap on the switch, what would it say? There should be error message. HS210 is three way switch. If you press power button on swtich A, the white circle light on both switch A and B should be off. Press power button on switch B then, white circle light on both should be lit up. Repeat this process. If they don't function, check your wiring.
0
0
#2
Options
Re:Re:HS210, Kasa ON/OFF indicator not working
2018-12-26 22:19:59 - last edited 2018-12-26 22:30:43

Same problem, no error message in app.

 

OP - did you find an error in wiring?  I have identical symptoms as you described.

 

In addition, I can say Alexa "switch on" and it turns on, a second "switch on" will turn the light off.  Alexa "switch off" does nothing.

 

Hardware Version: 1.0
Firmware: 1.5.5
Kasa App (Android): 2.7.0 Build 816

 

 

Found this TP Link Thread and wonder if the problem is linked and if either will get technical replies.

0
0
#3
Options
Re:Re:Re:HS210, Kasa ON/OFF indicator not working
2019-01-05 16:53:11

Same issue here. Any news?

0
0
#4
Options
Re:Re:Re:Re:HS210, Kasa ON/OFF indicator not working
2019-01-05 22:25:45

I ended up installing the other HS210 at the other end of the 3 way and it is functioning properly. I tried all kinds of combination of smart and dumb switches and this was the only way I got it to work. Live support was little help.

2
2
#5
Options
Re:HS210, Kasa ON/OFF indicator not working
2019-01-13 00:06:44

My setup on my several switches is hs210 smart switch on one end of the circuit, standard (dumb) 3 way switch on the other. (one of them has a 4 way in the middle)

 

I  had the same issue discussed here  on one of mine, the off circle would stay on even when light on, and the switch would stay gray on the app. After playing around with it for a while and checking the other circuits with same setup, one of the things I tried was disconnecting both ends of the ground (bare copper wire) on the cable  with the two "traveler" wires. Now this circuit also works as it should. (Don't do this if you don't understand electricity)


My theory is that there was a small voltage "leak" along the travelers, which caused the 3 way smart switch to "think" the lights were off. Even though the circuit wasn't shorting out, there must have been a very small amount of voltage "jumping" off a traveler to the ground (bare) wire.

 

An important thing to remember is these switches were designed to have an hs210 on both sides of the 3 way circuit. The fact that it usually works with one hs210 on only one side, and dumb switch on the other is a bonus.

2
2
#6
Options
Re:HS210, Kasa ON/OFF indicator not working
2019-12-01 03:25:35 - last edited 2019-12-01 03:29:18

Hardware Version: 1.0
Firmware: 1.5.6
Kasa App: 2.17.0 Build 738

 

Anyone else get anywhere with this issue? In reading across the TP-link and Amazon forums/reviews, it sounds like some people are having success with 3 and 4-way configs where replacing one (or sometimes two) of the switches with an HS210 works fine, and yet others have this issue where the switch/app doesn't detect the on/off state. I've escalated my case with TP-link engineering, but it will be at least a few days before I hear anything back.

 

In my case, I'm using one HS210 switch in a 4-way circuit with three total switches, replacing one of the 3-way standard switches (I also tried replacing both 3-way switches with HS210 switches, with no change in behavior). Electrically, things all seem to be working fine - all the switches work manually just fine, no matter what state any of them are in, but the TP-Link switch continues to always show the OFF state on the switch itself, and of course the app follows suit.

 

Any suggestions?

0
0
#7
Options
Re:HS210, Kasa ON/OFF indicator not working
2020-03-20 13:37:08

@bovineyard This is exactly what I had to do to get mine to work - thanks!

 

Experimenting showed that if either end of the ground wire in the traveler bundle was connected, the LED was on dim all the time. Also, the status of the light was not correct in the app, and the schedule didn't work to turn off the light.

 

As an interesting note. I have a non-Kasa controlled light in a hallway that may have a similar issue. I have a sconce light controlled by two 3-way and one 4-way switches. When I first put in an LED bulb in the sconce, if the 4-way switch was in one position the LED bulb was on dim instead of off. If the 4-way was in the other position, the LED bulb was completely off. I tested with a Fluke meter and there was induced voltage on the traveler wires.

 

I'm curious now if I isolate the ground in the traveler bundle if the induced voltage would be eliminated.

0
0
#14
Options
Re:HS210, Kasa ON/OFF indicator not working
2020-03-20 21:05:35
Having any voltage at all showing in the ground wires would concern me greatly. It's a safety issue, isolation by disconnection is a risk not a fix, hopefully you mean something else.
AutomationManager: Secure home automation without relying on cloud servers.
0
0
#15
Options