TL-MR6400 v2 - Sim Card Not Found After Firmware Update
TL-MR6400 v2 - Sim Card Not Found After Firmware Update
TL-MR6400 v2 - Sim Card Not Found After Firmware Update
2019-04-28 07:17:41 - last edited 3 weeks ago
Model: TL-MR6400
Hardware Version: V2
Firmware Version: 1.0.19 Build 181219 Rel.59200n

Hi. So I bought this device about six months ago and was running without issue.

 

I was in the process of upgrading other TP-Link device firmwares so also upgraded my MR6400v2 from stock firmware to current.

 

Since then I get constant disconnects saying "sim card not found". A power cycle resolves this issue but I wish to revert back to the original firmware.

 

Please provide link as older firmwares are not available on the TP-Link sites.

 

Regards,

Brenton Venables

0
0
#1
Options
24 Replies
Re:Sim Card Not Found After Firmware Update
2019-04-28 11:15:24

Hi,

 

Do you remember what the older firmware is?

 

Meanwhile, could you please show us a screenshot of the error message?

 

Besides, you can try  to create the profile manually to give it a go. 

Note: Login to the web UI first, tab on advanced-network/internet-Dail-up settings and then hit create profile to do that. 

 

How to login: https://www.tp-link.com/en/support/faq/1678/

 

Good day. 

 

Brent0n wrote

Hi. So I bought this device about six months ago and was running without issue.

 

I was in the process of upgrading other TP-Link device firmwares so also upgraded my MR6400v2 from stock firmware to current.

 

Since then I get constant disconnects saying "sim card not found". A power cycle resolves this issue but I wish to revert back to the original firmware.

 

Please provide link as older firmwares are not available on the TP-Link sites.

 

Regards,

Brenton Venables

 

0
0
#2
Options
Re:Re:Sim Card Not Found After Firmware Update
2019-04-29 01:40:59 - last edited 2019-04-29 01:43:53

Hi Kevin,

 

I'm unsure what the previous firmware version was. Please provide a link to all of them.

 

Here's the screenshots you requested:

As you can see it's not possible to create a manual profile while the Sim is undiscoverable.

 

Regards,

Brenton Venables

0
0
#3
Options
Re:Re:Re:Sim Card Not Found After Firmware Update
2019-05-06 05:34:30

Hi,

 

You do not have to go to quick setup  to create the profile manually, instead, go to network-LTE dial-up and click create to do that. 

 

Meanwhile, below is the download link of the official firmware which is older than the current one. You can install it and give it a go. 

http://support.tp-link.com/f/0ab25d6d8f/?dl=1

 

Any updates, please let us know.

 

Good day. 

0
0
#4
Options
Re:Re:Re:Re:Sim Card Not Found After Firmware Update
2019-05-10 02:31:46

Thanks Kevin_Z

 

I will try this when I'm next at home but currently I am away.

 

Please note there are new posts since mine with the same issue so it seems obvious the firmware needs to be fixed.

 

Regards,

Brenton Venables

 

0
0
#5
Options
Re:Re:Re:Re:Re:Sim Card Not Found After Firmware Update
2019-05-14 02:32:08

Firmware version 1.0.19 Build 181219 Rel.59200n downgraded to firmware version 1.0.17 Build 180508 Rel.39703n. Will post back any disconnects or performance issues. 

0
0
#6
Options
Re:Re:Re:Re:Re:Re:Sim Card Not Found After Firmware Update
2019-05-14 03:01:22

Hi,

 

Thanks for your reply.

 

Please take your time to test the stability, any updates, just let us know. 

 

Have a nice day. 

 

 

0
0
#7
Options
Re:Re:Re:Re:Re:Re:Re:Sim Card Not Found After Firmware Update
2019-05-21 05:04:07

Hi Kevin_Z

 

Firmware version 1.0.17 Build 180508 Rel.39703n has been running for a week without issue.

 

I don't experience Sim card disconnects any more but speed is inconsistent. As you can see I'm on full signal and speed varies between 4mbps and 22mbps.

 

I'm assuming this is network capacity as I'm close to a large regional medical precinct and a congested residential area.

 

I'll be staying on this firmware. Thanks for your help.

 

Regards,

Brenton Venables

0
0
#8
Options
Re:Re:Re:Re:Re:Re:Re:Re:Sim Card Not Found After Firmware Update
2019-05-22 12:51:52

I did find that speed improves after a reboot. I've been told mobile works off priority and a device constantly connected would fall to last priority in the tower. Makes sense. But to remedy this could you guys please implement a reboot timer or schedule. Thanks

0
0
#9
Options
Re:Re:Re:Re:Re:Re:Re:Re:Re:Sim Card Not Found After Firmware Update
2019-05-29 15:12:46

Att: Kevin_Z

 

It seems the 4G modem part of my modem/router is now dead. Uptime was around two weeks. Perhaps a reboot option might have helped. Please advise Kevin_H

 

Regards,

Brenton Venables

 

0
0
#10
Options
Re:Re:Re:Re:Re:Re:Re:Re:Re:Re:Sim Card Not Found After Firmware Update
2019-05-30 05:03:03

It seems the device is now completely dead. Apart from wifi nothing else works. Can't upgrade or downgrade firmware. Can't even factory restore from web UI or reset button.

 

RMA required.

 

0
0
#11
Options