Deco M5 speed issues since update to v1.3.1

Deco M5 speed issues since update to v1.3.1
Deco M5 speed issues since update to v1.3.1
2019-08-20 16:37:49
Model: Deco M5
Hardware Version: V1
Firmware Version: 1.3.1

Since updating to v1.3.1 I have been suffering with many different devices having internet connection issues. All are connecting to deco but very poor throughput. Is a fix available or firmware downgrade available?

1
1
#1
Options
13 Replies
Re:Deco M5 speed issues since update to v1.3.1
2019-08-20 18:59:50

I am also unable to take a call on my mobile using WiFi calling since the update as the other callers say it keeps breaking up. This latest update is very unstable.

 

1
1
#2
Options
Re:Deco M5 speed issues since update to v1.3.1
2019-08-21 02:12:23

@Ali9521 

 

We will get some details to do further analysis and try to fix it. 

 

What is the current network topology/layout? And may I know who is your internet service provider? And what's the bandwidth  you pay for them?

 

With your device connected to modem and main Deco by wired cable directly, what is the actual speed you can get separately? And please click here to check the wired negotiation speed.
Note: The steps are the same, while you need right click on local area connection or ethernet connection.      

                                                                    
Besides, please try to run a speed test via the Deco app and show us the results. 

 

With your computer or cellphone connected to the slave Deco only, please run the speed test for 3 times and show us the test results; Furthermore, please connect your computer to the slave Deco by ethernet cable to verify the wired speed.

 

Please uncheck obtain DNS automatically and change the primary DNS to 8.8.8.8 under advanced>>IPv4>>Internet connection type page and and click save.

 

After that, please run the speed test again and check whether it work.

 

Have a great day.

0
0
#3
Options
Re:Re:Deco M5 speed issues since update to v1.3.1
2019-08-21 05:36:51
Current topology - modem - ethernet - deco M5 - Ethernet - switch - 2 X ethernet 2 X deco m5. Supplier is BT with 52 Mb connection. Speed test from main Deco on app shows 54 down and 18 up. I will carry out the other requested test later tonight but setup was exactly the same prior to the update with no issues, only change to cause the issue is the F/W version.
0
0
#4
Options
Re:Re:Re:Deco M5 speed issues since update to v1.3.1
2019-08-22 06:43:37

Didn't get chance to carry out the requested diagnostics yet, but last night main deco disconnected with solid red led, deco was very hot to touch. Removed power for a bit and when came back on still had solid red led but then after a while started working again. This new firmware is having big issues

 

0
0
#5
Options
Re:Re:Re:Re:Deco M5 speed issues since update to v1.3.1
2019-08-23 07:22:54 - last edited 2019-08-23 08:45:42

@Ali9521 

 

Hello, thanks fo ryour reply. 

 

When the main Deco shows red, can you get internet from the modem directly with your computer connected? 

 

For the temparature, as an electrical device and network gateway, it will produce heat inevitably, please locate it in an open and fairy place. 

 

If possible, you can use a thermometer to measure its temparature.

 

Besides, you can try to degrade the firmware via the web UI and give it a shot.

 

Best regards. 

 

0
0
#6
Options
Re:Re:Re:Re:Re:Deco M5 speed issues since update to v1.3.1
2019-08-23 08:31:03

Please can you provide a link to the older firmware to allow me to downgrade.

Thanks

0
0
#7
Options
Re:Re:Deco M5 speed issues since update to v1.3.1
2019-08-24 09:16:33

Carried out the requested test.

Unable to carry out wired test as I have no suitable device.

All other test showing similar results of 64 down and 18 up.

Changed DNS and same result.

Devices work but either start buffering video or music pauses, or games pause, or WiFi calling is poor.

0
0
#8
Options
Re:Re:Re:Deco M5 speed issues since update to v1.3.1
2019-08-25 08:34:28

I am unable to find the older firmware to download , only the current firmware seems available. Please can you let me know where to get the older firmware 

0
0
#9
Options
Re:Re:Re:Re:Re:Deco M5 speed issues since update to v1.3.1
2019-08-27 07:04:19

Hi, please can you provide the older firmware as I can only find the latest firmware on tplink site.

Many thanks

0
0
#10
Options
Re:Re:Re:Re:Re:Re:Deco M5 speed issues since update to v1.3.1
2019-08-28 09:45:04 - last edited 2019-08-28 09:47:54

@Ali9521 

 

Hi, sorry to respond late.

 

The older firmware is listed on the US official website, and the firmware is universal. 

https://www.tp-link.com/us/support/download/deco-m5/#Firmware

 

Meanwhile, we need use the TFTP firmware recovery to downgrade the firmware. I will send it to you later. 

 

And you can refer to the story as well: https://community.tp-link.com/en/home/stories/detail/582

 

Please notice the file name of the firmware, it is important.

 

Good day. 

 

0
0
#11
Options