Frequent Connection Loss & Poor Internet Speed

Frequent Connection Loss & Poor Internet Speed
Frequent Connection Loss & Poor Internet Speed
2019-09-25 03:29:18
Model: Archer MR400
Hardware Version: V2
Firmware Version: 1.3.0 0.9.1 v0001.0 Build 180621 Rel.66827n

Hi TP-Link Support,

 

I am using TP-Link Archer MR400 AC1200 3G/4G router with Airtel SIM card.

Earlier, I was getting 50-60Mbps speed but from past 20 days, I am getting only 100-200Kbps speed.

Also, the router frequently disconnects from the internet. After 2-5 minutes, I need to restart my router to reconnect with the internet.

 

While, at the same Location and same SIM card, I am getting good speed in mobile and my other Hotspot device.

 

When I try to upgrade the firmware, it showing  "Internet is unavailable", I did a manual upgrade from here- https://www.tp-link.com/in/support/download/archer-mr400/v2/

Can you help me to fix this?

 

Please check the attachment.

 

 

 

0
0
#1
Options
1 Reply
Re:Frequent Connection Loss & Poor Internet Speed
2019-09-26 07:56:52

@BabaJi 

 

Hello, I found that there is only original firmware available on the India official website. 

 

Below is download link of the latest firmware for Archer MR400 from global official website.

https://www.tp-link.com/en/support/download/archer-mr400/v2/#Firmware

 

You can try to download the first one and upgrade it locally. Instruction as below: 

https://www.tp-link.com/support/faq/1667/

 

May it help and have a good day. 

0
0
#2
Options