Need driver for Mac OS Catalina version 10.15? Please read this.

Need driver for Mac OS Catalina version 10.15? Please read this.
Need driver for Mac OS Catalina version 10.15? Please read this.
2019-10-15 10:27:32 - last edited 2020-08-05 09:56:06

Hello, I know some of you updated to Catalina 10.15 of your Mac, and need the driver for it. 

 

Generally speaking, the TP-Link official driver for Mac 10.15 will be released in a month after the official 10.15 OS version came out. That is to say, the driver of 

TP-Link network adapters released by TP-Link for Mac 10.15 will arrive in the middle of November. 

 

Please wait with patience and keep your eyes on our TP-Link official web site for the updates.

https://www.tp-link.com/support/download/

Currently, there has a beta driver for Mac 10.15 on Github which is available for Realtek network adapter according to our test, please have a try to install it temporarily until the official TP-Link driver released: https://github.com/chris1111/Wireless-USB-Adapter-Clover

 

11.26 update:

 

Hi all, we TP-Link have released the driver for MAC10.15 for Realtek wireless adapter.  We have uploaded it to the official website already. For others, our R&D team are working on it and will update graudually. 

 

You can go to download center to get it.

https://www.tp-link.com/support/download/

 

Good day. 

4
4
#1
Options
1 Accepted Solution
Re:Need driver for Mac OS Catalina version 10.15? Please read this.-Solution
2020-08-05 09:55:39 - last edited 2020-08-05 09:56:06

 

To those who may be concerned,

Hi all, Thank you very much for all your detailed information so far.

For Mac OS Catalina version 10.15:

If your devices are wireless USB adapters,

TL-WN722N(EUUSES) v3.0, TL-WN727N(EU) v5.20, TL-WN725N(EUUSES) v3.0.

https://static.tp-link.com/2020/202001/20200108/TL-WN7xxN_EUUSES_V3_191211_Mac10.15.zip

 

Archer T2U(EU_US_JP_RU) v3.0, Archer T2U Plus(EU_US_JP_RU) v1.0, Archer T2U Nano(EU_US_JP_RU) v1.0.

https://static.tp-link.com/2020/202001/20200113/Archer%20T2U_Plus_Nano_200105_Mac10.15.zip

 

TL-WN821N(EUUS) v6.0, TL-WN822N(EUUS) v5.0, TL-WN8200ND(UN) v2.0, TL-WN823N(EUUSRU) v3.0.

https://static.tp-link.com/2020/202001/20200108/TL-WN8xxN_EUUS_191211_Mac10.15.zip

 

For Archer T3U v1 & Archer T9UH v2, still Only beta driver available so far:

https://static.tp-link.com/2019/201911/20191122/TP-Link_Installer_Mac%2010.15_Beta.zip

 

And for the models not listed above, we are working on it now, any updates, we will post on the website.

Besides, you can search the suitable driver online, like Github or manufacturer’s website.( Please also tag me If you could not find out the related chipset. )

 

PS: if your device is powerline adapters and need powerline utility for Mac OS Catalina version 10.15, you could tag me here or email our support team for the software compatible with Mac OS 10.15;

 

Thank you for your cooperation in advance and have a nice day.

Best Solution
1
1
#178
Options
54 Replies
Re:Need driver for Mac OS Catalina version 10.15? Please read this.
2019-10-24 04:10:15

@Kevin_Z The beta driver worked for me, thanks!

0
0
#2
Options
Re:Need driver for Mac OS Catalina version 10.15? Please read this.
2019-10-29 08:48:00

@spt which version did you installed and what are the steps.. Please do share buddy.... Thanks

0
0
#4
Options
Re:Need driver for Mac OS Catalina version 10.15? Please read this.
2019-10-29 22:43:09

@Shubham_Kale I actually used this link https://github.com/chris1111/Wireless-USB-Adapter

If you look on that page there's a link to a video with full instructions. Good luck man

0
0
#5
Options
Re:Need driver for Mac OS Catalina version 10.15? Please read this.
2019-11-17 14:10:57

@spt 

I tried installing and followed the steps as per video.

Disabled SIP and gatekeeper

Installed the v7 pkg

restarted the machine

usb wifi adapter plugged in 

but still getting No USB WiFi Plugin

 

Any additional thing to be done.. Pls let me know. Kindly help.

 

Thanks.

0
0
#8
Options
Re:Need driver for Mac OS Catalina version 10.15? Please read this.
2019-11-20 07:57:58

@Sankar_SV 

 

So with USB adapter plugged into the USB port, it cannot be detected by the computer? 

 

What is the model number of your adapter? 

 

Try to change another USB port or computer to give it a go.

 

Good day. 

0
0
#9
Options
Re:Need driver for Mac OS Catalina version 10.15? Please read this.
2019-11-20 08:08:19 - last edited 2019-11-20 08:10:41

@Kevin_Z 

 

I tried all the usb ports but the adapter isn't getting detected.

The model No. of the adaptor is TP-Link TL WN725N

I installed the provisional driver as per instructions but no luck.

In the list of supported devices, this adapter is not mentioned in the driver's read me txt.

 

I installed with the  windows driver on one of my friend's windows desktop and the adapter is working there. So the issue must be w.r.t the driver only.

 

Thanks for any help provided.

0
0
#10
Options
Re:Need driver for Mac OS Catalina version 10.15? Please read this.
2019-11-21 01:10:04

@Sankar_SV 

 

What is the hardware version of the TL-WN725N? 

https://www.tp-link.com/support/faq/46/ 

 

The driver attached is suitable for TL-WN725N as we tested, for others, you can install it; but if it does not work, you can try to search the driver online from Github or the manufacturer's official website with the chipset.

 

Good day. 

0
0
#11
Options
Re:Need driver for Mac OS Catalina version 10.15? Please read this.
2019-11-21 03:52:21 - last edited 2019-11-21 04:06:58

@Kevin_Z 

 

The link added is FAQ.

I checked in the product box, its mentioned version 3.0, however I dont see anything etched on the adapter.The driver u have mentioned attached, r u referring to the github chris1111 wifi adapter ? that's not working for me.

When will the tp link's official driver be released for v3?

 

 

0
0
#12
Options
Re:Need driver for Mac OS Catalina version 10.15? Please read this.
2019-11-23 10:02:26

@Sankar_SV 

 

Yes, the link attached is the FAQ which guides you to find the hardware version of the adapter. 

 

The download link in my original post is suitable for TL-WN725N V3, try to download and install it to give it a go. 

 

Any further problem, please let us know. 

 

 

0
0
#13
Options
Re:Need driver for Mac OS Catalina version 10.15? Please read this.
2019-11-23 10:04:53
0
0
#14
Options