Very strange issue with TL-MR6400

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

Very strange issue with TL-MR6400

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Very strange issue with TL-MR6400
Very strange issue with TL-MR6400
2019-11-04 21:16:15 - last edited 2019-11-11 09:39:16
Model: TL-MR6400  
Hardware Version: V3
Firmware Version: 20190730

I am facing very strange issue with my router.

When I send emails (gmail) with attached files, I get a timeout on my Linux Ubuntu computer. If no attachment, the email goes out without issue.

I tried another computer on MacOS: no issue.

I tried another router: no issue.

I tried to ping google while sending the message. Ping answers all the time, while the email blocks at 83%...

 

Has anyone an idea what can be wrong ? Maybe I need a new (beta) firmware ?

  0      
  0      
#1
Options
2 Accepted Solutions
Re:Very strange issue with TL-MR6400-Solution
2019-11-06 09:20:54 - last edited 2019-11-11 09:39:16

@JLH 

 

Thanks for your reply; cause you mentioned that the MacOS works fine, the router should be working properly as well.

 

Try to change the MTU size of your Linux computer to give it a go. Like 1400.

 

May it work. 

2022 TP-Link Wi-Fi 7 Product Launch Event | Watch the Replay at https://www.tp-link.com/us/wifi7/event/.
Recommended Solution
  0  
  0  
#4
Options
Re:Very strange issue with TL-MR6400-Solution
2019-11-11 07:33:06 - last edited 2019-11-11 09:39:24

Indeed. Changing the MTU solved the issue. Still wonderning why the router does not support the standard MTU 1500.

Anyway thanks a lot for the suggestion !

Recommended Solution
  0  
  0  
#5
Options
5 Reply
Re:Very strange issue with TL-MR6400
2019-11-06 03:46:58

@JLH 

 

Try to ping gmail.com on your Linux computer. 

 

And you can change the DNS server of TL-MR6400 to 8.8.8.8/8.8.4.4 to give it a go. 

 

Besides, you can customize the DNS server on the linux computer itself as well. 

 

Furthermore, you can forget the profile and reconnect to it. 

 

And try to change another attachment with lower capacity. 

 

 

2022 TP-Link Wi-Fi 7 Product Launch Event | Watch the Replay at https://www.tp-link.com/us/wifi7/event/.
  0  
  0  
#2
Options
Re:Very strange issue with TL-MR6400
2019-11-06 07:44:23

@Kevin_Z 

 

Hello Kevin,

 

Thanks for your suggestions. However, I already set the DNS to 8.8.8.8 and 8.8.4.4 on the linux box itself. Nothing changed. I also sent emails without attachments which are some Kb in size (less than 16 Kb, but more than 1Kb), and the issue still exists. I have the feeling that the gmail server times out when my computer tries to copy the sent message into the 'Sent' Imap folder of gmail. Pinging google during the whole process seems to indicate the LTE connection does not break.

I reapplied the latest firmware I could find on the tp-link website, I also reset the router and reconfigured it, but it did not help.

By the way, I do not have any issue when reading mails, or when sending emails with another LTE modem. 

  0  
  0  
#3
Options
Re:Very strange issue with TL-MR6400-Solution
2019-11-06 09:20:54 - last edited 2019-11-11 09:39:16

@JLH 

 

Thanks for your reply; cause you mentioned that the MacOS works fine, the router should be working properly as well.

 

Try to change the MTU size of your Linux computer to give it a go. Like 1400.

 

May it work. 

2022 TP-Link Wi-Fi 7 Product Launch Event | Watch the Replay at https://www.tp-link.com/us/wifi7/event/.
Recommended Solution
  0  
  0  
#4
Options
Re:Very strange issue with TL-MR6400-Solution
2019-11-11 07:33:06 - last edited 2019-11-11 09:39:24

Indeed. Changing the MTU solved the issue. Still wonderning why the router does not support the standard MTU 1500.

Anyway thanks a lot for the suggestion !

Recommended Solution
  0  
  0  
#5
Options
Re:Very strange issue with TL-MR6400
2019-11-11 09:38:48

@JLH 

 

Thanks for your reply, glad to hear that you figured it out finally. 

 

It seems that there is a mistake happened during MSS negotiation which causes this issue. 

 

Changing MTU size is a method to verify it. 

 

Good day. 

2022 TP-Link Wi-Fi 7 Product Launch Event | Watch the Replay at https://www.tp-link.com/us/wifi7/event/.
  0  
  0  
#6
Options

Information

Helpful: 0

Views: 689

Replies: 5

Related Articles