tpPLC Android app won't connect to device

tpPLC Android app won't connect to device
tpPLC Android app won't connect to device
2019-11-23 22:51:49
Hardware Version:
Firmware Version:

I have a TP-Link TL-WPA4220 Powerline Wifi Extender in our garage (25m from the house) and am trying to use the tpPLC app on my Android smartphone to connect to the device so I can check the settings.

 

The issue is that the app says "No device found", yet I know the phone is connected to the extender by Wifi (only 30cm from the device).

 

Looking at the reviews of the tpPLC app on the Google Play store I see that lots of people are having the same issues, but there's no clue about how to fix it.

 

The reason I wanted to use the tpPLC app was to check the settings on the Extender, as it disconnects once or twice a day - but the router in the house is not disconnecting.  I know this because I have a Nest camera on the garage and two on the house (connected to the main router), but it is only ever the one on the garage that disconnects.  Therefore it must be due to the extender, not the main router and its internet connection.

 

Please help.

 

Thanks.

1
1
#1
Options
5 Reply
Re:tpPLC Android app won't connect to device
2019-11-24 11:40:53

ps - the tpPLC Utility on my Windows 10 laptop doesn't connect to the device either.  It just displays a spinning circle in the centre of the display.

 

TP-Link Support - can you please help?

 

Thanks.

0
0
#2
Options
Re:tpPLC Android app won't connect to device
2019-11-27 09:53:38

@mike222 

 

Hello, the TL-WPA4220KIT does not support tpPLC app, generally speaking, we can use the tpPLC utility to check the settings; considering it does not work either, you can try to install the powerline scan utility: https://www.tp-link.com/en/support/download/tl-wpa4220kit/v1/#Utility

 

Then you can login to the web UI to check the settings.

 

Besides, you can refer to https://www.tp-link.com/support/faq/2230/ to do more troubleshooting.

 

May it help. 

0
0
#4
Options
Re:tpPLC Android app won't connect to device
2019-11-27 21:54:30

@Kevin_Z Thanks, but I thought the WPA4220KIT code was for the "base unit" (connected to the router) plus the Extender (which is WPA4220 V1.2).  According to the tpPLC app page on the Play Store it does support WPA4220.  Furthermore, as I noted in the reply to my first post, the tpPLC Utility on Windows doesn't work either.

 

Whether using the Android app or the Windows utility, my device connects to the Extender by Wifi, but neither app/utility will actually detect the Extender.

 

Mike

0
0
#5
Options
Re:tpPLC Android app won't connect to device
2019-11-28 06:14:55

@mike222 

 

What is the hardware version of the TL-WPA4200kit? You can find it on the back panel of the actual device. 

 

Cause the tpPLC app and tpPLC utility did not work, per I said, you can use the powerline scan utility to give it a go. 

 

Any updates, please let me know. 

 

 

0
0
#6
Options
Re:tpPLC Android app won't connect to device
2019-11-28 10:40:45

@Kevin_Z the hardware version is UK/1.20 according to the label.

 

I've followed the link to the "powerline scan utility" but that leads me to "tpPLC_Utility_Windows", published date 2018-08-16, which is the tpPLC Utility that I mentioned in my post.  I've uninstalled it and reinstalled it but cannot get it to work.

 

Kevin_Z wrote

@mike222 

 

What is the hardware version of the TL-WPA4200kit? You can find it on the back panel of the actual device. 

 

Cause the tpPLC app and tpPLC utility did not work, per I said, you can use the powerline scan utility to give it a go. 

 

Any updates, please let me know. 

 

 

 

0
0
#7
Options