I've been having ping and download problems.

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
I've been having ping and download problems.
I've been having ping and download problems.
2020-01-07 21:51:20 - last edited 2020-01-08 02:28:20
Model: TL-WA801ND
Hardware Version: V2
Firmware Version:

So I've recently built my first gaming pc and managed to make an actual functioning pc first try. Ever since I got the PC my ethernet adapter started to not work so i just got a Network card at Curry's PC world (which was a TL-WA801ND) and it's not really working that well.

 

For some reason when ever I play games like Counter-strike, gmod, or any other online game with my friends my ping would go way higher than it should even go around 150 ish on average and sometimes the ping would just increase and increase to the point were I rubber-band everywhere and end up having to leave games because it's practically unplayable.

 

There's also a problem with my download speed which when I had the ethernet adapter was around 20-50 Mbps but now it's usually 2 - 6 Mbps which really is just unacceptable.

 

If anyone knows what the problem is and a fix to said problem, please tell me!

0
0
#1
Options
1 Reply
Re:I've been having ping and download problems.
2020-01-08 02:28:09 - last edited 2020-01-08 02:28:20

@Locki 

 

Hello, may I know who is your internet service provider and what is the bandwidth you paid? 

 

Except online games, what about other network activities? Like browsing or downloading?

 

With computer connected to the main router directly, do you have the same issue? 

 

And what is the current speed you can get from the TL-WA801ND and main router separately? 

 

Good day. 

0
0
#2
Options