2020-02-01 19:10:42
Model: LB120
Hardware Version:
Firmware Version:

I have 4 LB120 Bulbs.


Yesterday all these bulbs were controlled from the TP-Link app.


Today, I cannot access these bulbs from the TP-Link app.


When I go through the reset option I receive a message 


"Select your Smart Bulb -

TP-Link_Smart Bulb_2FD2


TP-Link_Smart Bulb_DA56



Connecting to Smart Bulb


Choose a Network

(List of Networks)


I select my Recommended Network

Enter the Password.


Tap join


Message............Unable to Connet to your Wi-Fi Network

1) Check for Typos

2) Still Need Help


Allmy other devices are working of the router.

Nothing has changed.

1 Reply
2020-02-13 06:06:10



Hello, is the recommended network your host 2.4G WiFi network? if not, please select your host WiFi network and enter correct password.

If it stil stucks on the same step, please refer to the following steps:

1. Click “Exit Setup” to exit setup, go to the Devices page on the Kasa app to see whether you can control the bulb, if yes, go to the Device Settings page to change the device name and icon. If you can’t control the bulb, confirm whether the router has enabled "AP Isolation/Client Isolation" function or not.

2. Make certain the router’s Wi-Fi signal strength is strong, and the phone is connected to the same home Wi-Fi network as the smart bulb.

3. Make certain the Wi-Fi password of the router is correct. Password length cannot exceed 64 characters and does not contain characters such as single and double quotes.

4. Try other phones if you have.

5. If possible, try to change wireless channel (fix channel to channel 1, 6 or 11) of the router and start over again


In addition, what is the WiFi LED status on the plug after the setup? 


Hope it helps! Have a nice day!


Related Articles