TL-WPA7510 Kit not connecting to the network

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

TL-WPA7510 Kit not connecting to the network

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
TL-WPA7510 Kit not connecting to the network
TL-WPA7510 Kit not connecting to the network
2020-03-12 18:58:27
Model: TL-WPA7510 KIT  
Hardware Version: V2
Firmware Version: 3.2.4_701013_171124_902

I have this kit connected to my network (less than 9 months old)

 

I have the base unit as the main one for all my powerlines on the network

 

This one has all of a sudden stopped connecting to the network (either as the base unit or as another unit)

 

I can swap over to anther tp-link unit and the network all kicks in.

 

TP-Link help desk are not being much help

 

I tried doing a firmware upgrade but the file on the webiste to download in a .bin file and I need the .ggl file

 

Can anyone shed some light on this for me!

 

Thanks

  0      
  0      
#1
Options
8 Reply
Re:TL-WPA7510 Kit not connecting to the network
2020-03-13 07:43:20

@Funkykebab 

 

What is the led status of the TL-WPA7510Kit when it stops working? Try to change another socket to plug the adapter and verify whether it works. And how many adapters do you have? Did you mean swap their locations to recover the network? 

 

The bin file is what you need to update the firmware for the extender unit. You can follow the instruction below: 

https://www.tp-link.com/support/faq/1419/

 

Good day. 

 

If you found a post or response helpful, please click Helpful (arrow pointing upward icon). If you are the author of a topic, remember to mark a helpful reply as the "Recommended Solution" (star icon) so that others can benefit from it.
  0  
  0  
#2
Options
Re:TL-WPA7510 Kit not connecting to the network
2020-03-13 10:50:13

@Kevin_Z 

 

Top and bottom lights on...middle light wont come on

 

Shows up on the tpPLC app but it wont connect to the rest of the powerline.

 

Done factory reset (lost count) but I cant do  fimware as the Tp Link download page only has a .bin filem when I need a .ggl file

 

TP  Link help desk want to get some out of the factory to see if they can recreate the fault!

 

The kit is only 9 months old and amazon are sending me to them!

 

  0  
  0  
#3
Options
Re:TL-WPA7510 Kit not connecting to the network
2020-03-16 10:52:59 - last edited 2020-03-17 06:55:42

@Funkykebab 

 

The powerline led ( middle one) should be on otherwise, it won't be able to access internet. 

 

You can plug them into the same room and test whether it works well.

 

Besides, where did you see that it needs the .ggl file to update the firmware? As far as I know, there are three types file available, one is bin file for extender adapter, the other two are PIB and NVM for base unit ( some may use .ggl file). 

 

And you can hard reset them and pair them via the tpPLC utility to give it a go. 

https://www.tp-link.com/support/faq/1615/

 

Good day. 

 

If you found a post or response helpful, please click Helpful (arrow pointing upward icon). If you are the author of a topic, remember to mark a helpful reply as the "Recommended Solution" (star icon) so that others can benefit from it.
  0  
  0  
#4
Options
Re:TL-WPA7510 Kit not connecting to the network
2020-03-16 12:16:20

@Kevin_Z 

 

As stated already factory reset multiple times. The .ggl file is whats asked when I try to firmware update the base unit (no wifi half of the kit)

  0  
  0  
#5
Options
Re:TL-WPA7510 Kit not connecting to the network
2020-03-17 06:55:01

@Funkykebab 

 

I confirmed again, the .ggl file is used for powerline adapter with no wifi function, so does NVM/PIB; It varies due to different chipset. 

 

The base unit should be TL-PA7010, you can go to the official website and download the firmware as its hardware version and then install it. 

https://www.tp-link.com/en/support/download/tl-pa7010-kit/v3/#Firmware 

 

For the .bin file, you can upload it to upgrade the firmware of TL-WPA7510.

 

Good day. 

 

If you found a post or response helpful, please click Helpful (arrow pointing upward icon). If you are the author of a topic, remember to mark a helpful reply as the "Recommended Solution" (star icon) so that others can benefit from it.
  0  
  0  
#6
Options
Re:TL-WPA7510 Kit not connecting to the network
2020-03-19 08:59:30
Still no joy even after firmware installed
  0  
  0  
#7
Options
Re:TL-WPA7510 Kit not connecting to the network
2020-03-20 07:20:07

@Funkykebab 

 

You still failed to pair them after installed the firmware? Try to hard reset it, change another wall socket to plug it. 

 

If it is still the same thing, I'm afraid that there is not much we can do. You can contact the retailer or local tech support to verify whether a replacement is qualified. 

 

 

If you found a post or response helpful, please click Helpful (arrow pointing upward icon). If you are the author of a topic, remember to mark a helpful reply as the "Recommended Solution" (star icon) so that others can benefit from it.
  0  
  0  
#8
Options
Re:TL-WPA7510 Kit not connecting to the network
2020-03-20 08:44:59

@Kevin_Z 

Yes done all that....

 

TP-link customer services are hopefully going to replace....even though I have had to explain to them that the faulty TL-PA7010 is the based unit in the TL-WPA7510 kit as they keep asking for the pictures of the TL-PA7510 base unit from the TLWAP7510 kit!

 

 

  0  
  0  
#9
Options

Information

Helpful: 0

Views: 2452

Replies: 8

Related Articles