How to force TP-Link Deco X20 to prefer 5ghz band instead of 2.4ghz

How to force TP-Link Deco X20 to prefer 5ghz band instead of 2.4ghz
How to force TP-Link Deco X20 to prefer 5ghz band instead of 2.4ghz
2020-06-03 04:39:31
Model: Deco X20
Hardware Version: V1
Firmware Version: 1.2.3 Build 20200330 Rel. 41081

Hi,

 

Hoping someone at TP-Link can address this. Most of the forum posts seem to have many user issues but with little to no help from the TP-Link admins.

 

I've been getting very spotty internet with the TP-Link Deco X20. This is especially so when trying to do video calls. Halfway through my call, the internet drops off, and ruins my call.

 

For context, this is my setup:

ONT (1Gbps) -> TP-Link Deco X20 Main -> 1 Tp-Link Deco Wireless Mesh (A) and 1 Tp-Link Deco X20 with ethernet backhaul (B)

 

Current issues:

1. My computer is connected to the TP-Link Deco X20 with ethernet backhaul (B), but constantly drops connection when trying to do video call

a. The main Deco X20 is only 8 metres away from the Deco X20 with ethernet backhaul (B), with no walls between - it's just an empty corridor. Originally, this was set up to be wireless mesh because the distance is so short, but the mesh connection was bad and kept dropping, so I tried to include an ethernet backhaul, but it's not helping with speed or stability
 

2. My computer keeps connecting to the TP-Link Deco X20 via the 2.4ghz spectrum, and there's no way in the TP-Link Deco app to set it to prefer 5Ghz spectrum

a. I can't turn off the 2.4ghz spectrum because I need my printers to connect via 2.4ghz

b. I can't make changes to my computer's wifi settings, because it's locked down by my company IT admin

 

The suggested workarounds for this have been to use the Guest Network function to create a 5ghz only band to connect the devices to, but this creates issues because when the Deco X20 is functioning in Router mode, I'm unable to view the printers on the main network when connected to the guest network, and so can't do wireless printing effectively.

 

 

What I want:

1. I want to ensure a stable connection between the Main Deco X20 and the Deco X20 with ethernet backhaul (B), ideally without having to rely on ethernet backhaul (because what's the point of a wireless mesh system otherwise??); AND

2. I want to get the Deco X20 to prefer the 5ghz spectrum when connected to devices that support it.

 

Is there some feature that can be built into the TP-Link Deco system to:

1. Allow the creation of separate SSIDs for the 5ghz and 2.4ghz bands; or

2. Allow me to set the router to prefer the 5ghz band over 2.4ghz for certain devices; or at the very least

3. Allow me to evaluate the signal strength and stability between Deco X20s? Having a simple 3 bar signal strength indicator that jumps around every time you open the app is not useful at all.

 

Thank you.

2
2
#1
Options
5 Reply
Re:How to force TP-Link Deco X20 to prefer 5ghz band instead of 2.4ghz
2020-06-04 12:04:09

@Meh456 

Hi,

For the connection issue, how about the Deco A, does it have a stable connection from the main Deco? How far between the main Deco and the Deco A?
If the Deco A has a stable connection, please try to swap the location of the Deco A and B, then check if the Deco B will work properly on the location where Deco A was.

Generally, when a client device near to a Deco, Deco will recommend the device connect to the 5G network, but whether to switch the Wi-Fi band is dependent on the device itself.

Currently, there is no option on the Deco to separate SSIDs for the 5GHz and 2.4GHz bands, and no option to let the device prefer to connect to the 5G network, I'll keep recording the same kind of request, and then forward it to our product engineer thus they can evaluate and work on it. 
Good day.

0
0
#2
Options
Re:How to force TP-Link Deco X20 to prefer 5ghz band instead of 2.4ghz
2020-10-25 12:27:34

@TP-Link_Deco it amazes me that that we cannot choose which band we want to be on, I have a fire stick is I would rather have 2.4 on and not 5ghz because of the wall in the way... Since the deco app can specify which device is connected, we should be able to charge preferred bands within the connected devices settings

1
1
#3
Options
Re:How to force TP-Link Deco X20 to prefer 5ghz band instead of 2.4ghz
2020-10-25 14:04:25 - last edited 2020-10-25 14:13:17

I have very strong 5GHz signal all over the house thanks to Deco, so I turned off 2.4GHz network. After that, I have found that one of devices at my house can only connect at 2.4GHz. I enabled Guest network, password protected it, and made that device connect to Guest network. Because I don't need 5GHz on Guest network, I disabled it. I now have two networks supported by my Deco: one is strictly 5GHz, one is strictly 2.4GHz. You can try that workaround if you have an option to turn on/off WiFi bands in Deco app for your device. Mine is M9Plus running in AP mode.

2
2
#4
Options
Re:How to force TP-Link Deco X20 to prefer 5ghz band instead of 2.4ghz
2020-10-27 02:52:36

Thanks, @Alexandre.  Great suggestions.yes

 

@Loopy27  You may try to enable the 2.4GHz guest network for this fire stick and leave others on the main network.

0
0
#5
Options
Re:How to force TP-Link Deco X20 to prefer 5ghz band instead of 2.4ghz
2021-02-16 23:40:21
Can your firestick be able to connect via local network? I have the same problem to enable 5GHz only when my printer only have 2.4Ghz only.
0
0
#6
Options