Very slow download speeds with PA7017

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Very slow download speeds with PA7017
Very slow download speeds with PA7017
2020-08-12 08:39:13 - last edited 2020-08-19 01:46:05
Model:Adapter
Hardware Version:
Firmware Version:

Hi. I've just recently bought the PA7017 kit 1-port gigabit powerline adaptor, connected to my EE router and then to my PC two floors up. I have fibre broadband with typical download speeds of 50-60Mbps. Through the adaptors, I am struggling to get to 2Mbps. I've checked firmware (doesn't appear to be any for this model), cables, swapped ports etc. Still no difference. Any hep appreciated.


Thanks

David

0
0
#1
Options
2 Reply
Re:Very slow download speeds with PA7017
2020-08-19 10:15:41

@daveyhall 

Hello!

Good day.

For the TL-PA7017kit,  there is only firmware for V4:

TL-PA7017KIT(EU)_V4_190426

https://static.tp-link.com/2019/201905/20190527/TL-PA7017KIT_V4_190426.zip

 

Is the speed slow since you bought it?

Have you tried to check the speed when the two adapters both are downstairs in the same room with the main router?

and please try to download the power-line utility to check the power-line rate between the adapters:

https://static.tp-link.com/2018/201809/20180904/PowerLineUtility_Win_180816.zip

 

Thank you!

0
0
#2
Options
Re:Very slow download speeds with PA7017
2021-04-24 11:06:05

@daveyhall 

 

I'm experiencing similar issues with my PA7017 kit. I have a 1000Mbps internet connection. I have tested (with my laptop's ethernet connection) a direct connection to the modem to give ~850Mbps (with speedtest.net). Then I added the 2 powerline adapters in the middle. Now I'm consistently getting ~150Mbps. I've tried moving them to different sockets, same results. The tp-link tool shows ~600Mbps connection between the powerline adapters, but I'm not getting anywhere near that:

 

 

Clarifying again, there's no other adapter on the way to the modem, and direct connection to modem gives ~800Mbps, so the bottleneck has to be the powerline adapters

I've updated firmware, got the same result:

 

How can it be that those adapters show 600Mbps between them, but internet connection is 150Mbps? that's x4 slowdown. I just paid extra to replace my older 100Mbps to those 1000Mbps adapters, apparently with no good reason to do so...

 

1
1
#3
Options