[Troubleshooting] Slow Internet Speed with Deco Devices

[Troubleshooting] Slow Internet Speed with Deco Devices
[Troubleshooting] Slow Internet Speed with Deco Devices
2021-02-23 09:18:58 - last edited 2 weeks ago
Model: Deco
Hardware Version:
Firmware Version:

There are different situations of the slow speed issues, please refer to the following suggestions provided:

 

Some notice before we run the speed test:

1. Make sure every Deco unit is properly placed and any enclosed space is not recommended;

2. If you are using a wired PC to test speed, please make sure both the Ethernet cable and PC are gigabyte supported;

3. If you are using a wireless device to test speed, make sure the wireless device is 5Ghz supported;

4. Speedtest in "Deco APP>>>MORE menu" measures the maximum speed of the main Deco and it doesn't mean all devices connected to Deco could reach that speed.

5. Speedtest in Deco Lab measures your cellphone's real-time speed, the results of this speedtest should be the same as Speedtest App of Ookla

 

Methods and Steps to verify speed:       

1. Use Ookla Speedtest App or https://www.speedtest.net  to measure Internet speed.

2. Verify maximum broadband speed by connecting a Gigabyte PC directly into the ISP Modem first;

3. Verify wired speed into the Main Deco after verifying the ISP Modem's maximum speed;

4. Disconnecting every wireless device if you are trying to measure the maximum wireless speed of Deco units;

5. Always reconnect Wi-Fi on your cellphones/laptops every time you perform a speedtest.

 

Troubleshooting steps:

1. Remove QoS settings: Deco APP>QoS>(Set Application priority to Standard, Remove all high priority devices, set the Bandwidth to 1000Mbps upload and 1000Mbps download);

2. Turn off the UPNP feature in the Deco app: Deco APP>More>Advanced>UPNP;

3. Download the Wi-Fi Analyzer to check wireless channel interference;

 

So after the testing, if the speed is still slow, you could leave me a private message for notification with the following details:

1. the speedtest results and Deco network topology;

2. the model number and operating system about the speedtest devices;

 

If you have any other ideas to improve the speed, please feel free to post here.

 

0
0
#1
Options
5 Replies
Re:[Troubleshooting] Slow Internet Speed with Deco Devices
a week ago

@TP-Link 

Hi there,
I received yesterday my new Deco M5 (3 pieces) and I installed in my house (2 floors and about 4,000 ft2).
I don't have any wifi dark spaces in the house, but I have a serious speed problem. The main Deco speed test show as the same Mbps that I have by contract with my internet provider (200 Mbps download/60 Mbps upload), but the other two Decos shows a very poor speed (6-10 Mbps / 4 Mbps).
Can you give me a recommendation or an specific set up to solve the problem?
Best regards,
Gonzalo

0
0
#2
Options
Re:[Troubleshooting] Slow Internet Speed with Deco Devices
Wednesday

@Gonzalo1976 

Hi, could you please provide a picture of the network topology of your Deco system?

At the same time, please check the following details:

1. the signal source and signal source strengthen of the two satellite Deco units;

2.if possible, please test the Ethernet speed of the two satellite Deco units as well;

Thank you.

 

0
0
#3
Options
Re:[Troubleshooting] Slow Internet Speed with Deco Devices
Wednesday

@TP-Link 

 

Well I have been through the process suggested in your post.

 

But there is absolutely no improvement at all.

 

Please refer to my original post copied below for my issue.

 

Deco P9 / Firmware update 1.1.3 Build 20201228 Rel.55057

17 hours ago

Model: Deco P9

Hardware Version:

Firmware Version: 1.1.3 Build 20201228 Rel.55057

Since updating firmware version 1.1.3 Build 20201228 Rel.55057, my internal internet connection via the Deco 9 has become slow and unstable.

Prior to the update everything has been fine for over 12 months.

I now have issues with connectivity dropping every few minutes.

I have a great broadband speed of 1g and have checked my broadband link and all is as normal.

Its alarming that prior to this update everything worked perfect.

As I work from home this is very critical to either turn back to the old firmware of something is fixed to change this issue.

I have became very disappointed with this product.

0
0
#4
Options
Re:[Troubleshooting] Slow Internet Speed with Deco Devices
Friday

@Meyshia5000 

Hi, I have replied to the first post, and please feel free to let me know whether the provided firmware made any changes;

Thank you.

0
0
#5
Options
Re:[Troubleshooting] Slow Internet Speed with Deco Devices
Friday

@TP-Link 

 

Greetings... Are Internet speeds better if the Deco V60's are used as a Router or as an Access point ??

0
0
#6
Options