Everythin looks good, yet no internet. Please help with PA9020

Everythin looks good, yet no internet. Please help with PA9020
Everythin looks good, yet no internet. Please help with PA9020
2021-02-28 04:35:27 - last edited 2021-02-28 04:58:49
Model:Adapter
Hardware Version: V1
Firmware Version: Latest

For some reason, my adapters stopped working.

 

I've reset them and re paired them but when plugged in my PC, I get no internet.

 

All 3 Leds are green and solid. When running troubleshooter in Windows 10, it sees no problem with the connection. Yet when I try to go to a website, the page never loads (Google, Bing, Speedtest, doesn;t matter...)

 

I installed the Utility software on my PC and both adapters show up and speed is around 400 (internet plan is 600, but 400 is good enough!).

 

I tried to plug straight to my TV for Netflix, same problem it never loads...

 

The utility clearly shows there's a good connection (I just updated the firmware with no problem), yet both PC and TV don't get signal.

 

What could it be?

 

 

0
0
#1
Options
1 Reply
Re:Everythin looks good, yet no internet. Please help with PA9020
2021-03-01 03:24:00 - last edited 2021-03-01 03:25:23

@AnthVanCity Hi,

It looks like your Powerline adapters are paired properly, but the Master adapter does not get Internet from Router. 

Please make sure the Master adapter is  wired to router is properly with all 3 Leds On.

Try a different Ethernet cable between router and Master adapter, and try a different LAN port on main router. 

If still no Internet, please check the IP address on your powerline extender (salve adapter) and share a photo of IP address here 

https://www.tp-link.com/support/faq/838/

Disconnect the Master adapter from router and connect a  PC directly to router with same Ethernet cable that adapter has used.   Please also share a photo of PC at that time.

 

 

0
0
#2
Options