Connecting sonoff to the deco network (x20)

Connecting sonoff to the deco network (x20)

Connecting sonoff to the deco network (x20)
Connecting sonoff to the deco network (x20)
2021-05-18 05:03:58 - last edited 2022-03-14 09:24:09
Model: Deco X20  
Hardware Version: V1
Firmware Version:

I am having trouble to connect any sonoff smart plug or switch to the new deco x20 network setup.

 

The sonoff instructions states that you need to set an open Mac. What is this?

 

Also, any other possible solutions/methods to try?

 

Anyone can help please?

  2      
  2      
#1
Options
1 Accepted Solution
Re:Connecting sonoff to the deco network (x20)-Solution
2022-03-14 09:18:52 - last edited 2022-03-14 09:28:18

 Hi, @Wololo and All,

Thank you for all your feedback so far.
Based on the previous troubleshooting with some users, there are some useful suggestions for your reference:
At first, please confirm the issue you have here is that Sonoff smart devices are unable to connect to the Wi-Fi of Deco.
Note: If you have an unstable connection on Sonoff smart devices,things might be different. Please start a new thread here.


1.Since Deco X20/X60 is capable of WPA3, while most of the smart devices not, please go to Deco APP>More>Wi-Fi and change the network security to WPA2-PSK[AES].
2.Turn off the fast roaming and beamforming under Deco APP>More>Advanced
3.Most of the smart home devices are 2.4ghz only,so during setup, please turn off the 5ghz on the main network, disconnect the Wi-Fi on the smartphone and reconnect to Deco to ensure it is now on 2.4ghz only,then start the setup process. once it can be set up successfully, we can enable the 5ghz back.

 

Unfortunately, if the issue continues, it would be highly appreciated if you could record a video clip of the whole setup process on the smartphone and the model number of your Sonoff devices, then send here or email to support.forum@tp-link.com.
Thank you again.
Best regards.

 

TP-Link CES 2023 | Leave me a message with any Urgent Requests or Simply Feel Left Out
Recommended Solution
  0  
  0  
#19
Options
30 Reply
Re:Connecting sonoff to the deco network (x20)
2021-05-18 06:13:27

@KenBar 

Hi, would there be any error message when Sonoff failed to connect Deco X20?

Could you please try to turn off the 5ghz on the main network(or enable the guest network for 2.4ghz only with a different SSID) and set up the Sonoff devices again;

By the way, can I have a link of the Sonoff instructions which states the smart plugs/switches need an open MAC?

Thank you very much.

2022 TP-Link Wi-Fi 7 Product Launch Event | Watch the Replay at https://www.tp-link.com/us/wifi7/event/.
  1  
  1  
#2
Options
Re:Connecting sonoff to the deco network (x20)
2021-05-18 10:19:24

@TP-Link 

 

Here is the link to the user manual of one of the plugs I have.

 

https://sonoff.tech/product-document/smart-plug-doc/s26-doc/

 

In the meantime I tried to switch of the 5g since sonoff work only on 2.4 but still was unsuccessful.

 

No particular error messages popping up. Just the ewelink app does not manage to connect to the plug with my new network deco setup.

 

In the meantime will try the guest network as suggested and will let you know.

 

Many thanks.

 

  0  
  0  
#3
Options
Re:Connecting sonoff to the deco network (x20)
2021-05-19 01:54:03

@KenBar 

Thanks for the update;

please let me know whether the guest network worked or not;

By the way, As for the Open MAC, I guess it means to check whether there is any MAC Filtering on the Deco since it would block devices;--you could have a check on the Deco APP>More>Blacklist;

At the same time, Since Deco X20 is WPA 3 capable, just in case the smart plugs are not, please try to change the wireless security to WPA2-PSK to have a look;

Thank you very much.

 

2022 TP-Link Wi-Fi 7 Product Launch Event | Watch the Replay at https://www.tp-link.com/us/wifi7/event/.
  2  
  2  
#4
Options
Re:Connecting sonoff to the deco network (x20)
2021-05-19 05:59:03

@TP-Link 

Many thanks for your assistance.

 

The guest network did not work neither :-(

 

I also checked that the security is set to Wpa2.

 

The error I am getting from the ewe link app is 6101. DHCP is also enabled on the ISP modem.

 

I attached some photos. Hope it helps.

 

  0  
  0  
#5
Options
Re:Connecting sonoff to the deco network (x20)
2021-05-19 06:37:23

@KenBar 

Thanks for the update.

I would like to forward your case to the senior engineers for further assistance.

At the same time, After checking with the engineers, they want us to confirm the following details:

1. Please make sure fast roaming and beamforming disabled on the Deco APP as well;

2.When trying to set up Sonoff plugs with the guest network, the smartphone with ewelink App is also connected to the guest network, right?

 

Thank you very much.

2022 TP-Link Wi-Fi 7 Product Launch Event | Watch the Replay at https://www.tp-link.com/us/wifi7/event/.
  0  
  0  
#6
Options
Re:Connecting sonoff to the deco network (x20)
2021-06-26 08:30:07 - last edited 2021-06-26 08:31:00

@TP-Link , I have the same issue with Sonoff. I raised a support case, but received zero response. Any updated on Sonoff issue

  0  
  0  
#7
Options
Re:Connecting sonoff to the deco network (x20)
2021-06-28 08:54:24

@T.K 

 

Hi, we didn't get a response from KenBar previously, can you please also confirm the details he provided, such as the error screenshot when you try to pair the Sonoff plug to the Deco network?

 

Can we have a specific model of the Sonoff plug? Was it connecting to the other wireless networks before? You can try to disable the 5G network on the Deco APP if the Sonoff only supports 2.4G connection, connect the phone also to the 2.4G network, then try to pair them again.

2022 TP-Link Wi-Fi 7 Product Launch Event | Watch the Replay at https://www.tp-link.com/us/wifi7/event/.
  0  
  0  
#8
Options
Re:Connecting sonoff to the deco network (x20)
2021-07-12 23:05:29 - last edited 2021-07-12 23:06:34

@TP-Link I also having the same issue connecting Sonoff Basic and Deco X20

 

I'm on v2 hardware and latest firmware.

 

I have also followed all the above suggestions:

1. Use Guest Wifi and set to 2.4 GHz

2. Phone is connected to Guest Wifi @2.4GHz, confirmed with Wifi Analyzer.

3. Sonoff Error code 6101

4. Beamforming disabled 

5. Fast Roaming disabled

  0  
  0  
#9
Options
Re:Connecting sonoff to the deco network (x20)
2021-07-13 02:41:47 - last edited 2021-07-13 02:58:09

@carbotex 

Hi, have you tried to change the wireless security mode to WPA2-PSK[AES] on the guest network?

By the way, have you seen the suggestions on this link

https://help.ewelink.cc/hc/en-us/articles/360038256611-Pairing-failed-Read-this-before-you-try-again#main-content

We could have a try of the Compatible Pairing and Bluetooth Pairing;

Thank you very much.

2022 TP-Link Wi-Fi 7 Product Launch Event | Watch the Replay at https://www.tp-link.com/us/wifi7/event/.
  0  
  0  
#10
Options
Re:Connecting sonoff to the deco network (x20)
2021-07-22 15:04:09 - last edited 2021-07-22 15:08:29

@TP-Link 

 

Nothing works. I have SonOff Basic R1 and SonOff Basic R3. Both have the same issue, can't connect to Deco X20 but no issue connecting to my older router.

 

I know it's not the issue with SonOff because I can connect them just fine with different router. Just when I switch to Deco X20, none of my SonOff devices can connect to Wifi anymore.

 

Have you tried buying SonOff and debug the router on your end and provide us with the Firmware to address with the connection issue?

 

Regards,

wa

  0  
  0  
#11
Options

Information

Helpful: 2

Views: 3611

Replies: 32

Related Articles