5 Ghz doesn't work in archer TX50E, while 2.4 Ghz works just fine

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

5 Ghz doesn't work in archer TX50E, while 2.4 Ghz works just fine

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
5 Ghz doesn't work in archer TX50E, while 2.4 Ghz works just fine
5 Ghz doesn't work in archer TX50E, while 2.4 Ghz works just fine
2021-05-20 19:49:15 - last edited 2021-06-24 05:48:07

Hello! so I bought yesterday the Archer TX50E adapter and the 5 Ghz band doesnt work for some reason while the 2.4 Ghz does. I can see the 5 Ghz network and connect to it but it doesnt work. Before this adapter I had the Archer T6E and both 5 Ghz and 2,4 Ghz worked fine. The weird part is that it worked for a few seconds after installing the drivers from the disk, and now only works for a few seconds after I connect to it. Any clue what the problem might be?

  0      
  0      
#1
Options
1 Accepted Solution
Re:5 Ghz doesn't work in archer TX50E, while 2.4 Ghz works just fine-Solution
2021-06-05 04:11:35 - last edited 2021-06-24 05:48:07

@CasacciaCesar Check in your routers wireless settings that it's not set to bandwidth of 160MHz.

 

I get the exact same issue with mine when I force my router to 160MHz, it works fine on 80MHz and below though.

 

I've been tearing my hair out for the last month trying to work out why it doesn't work on 160MHz and am yet to find an answer.

Recommended Solution
  2  
  2  
#3
Options
6 Reply
Re:5 Ghz doesn't work in archer TX50E, while 2.4 Ghz works just fine
2021-05-26 12:25:30 - last edited 2021-05-26 12:29:05

@CasacciaCesar Good day, 

 

You could try some suggestion here:

  • Change a different Wi-Fi channel for router's 5Ghz, channel 36/40/44/48 is recommended
  • Customize different SSID & wireless password for router's 5Ghz (better do not use special symbols in the password)
  • Change wireless security to WPA/PWA2-PSK and see if that helps
  • Delete the Wi-Fi profile for 5Ghz and reconnect: https://www.tp-link.com/support/faq/918/
  • Try the latest chipset driver from Intel which is 22.40 for now: 

https://downloadcenter.intel.com/product/189347/-Wi-Fi-6-AX200

 

If still the same problem, may I have know the model of router and a photo of 5Ghz wireless settings of router?

May I have a photo of the Error if 5Ghz WiFi can not be connected, thank you. 

Happy New Year! Meet Us at CES 2023 | Featuring Wi-Fi 7, EasyMesh, Matter, and a New HomeShield Security
  0  
  0  
#2
Options
Re:5 Ghz doesn't work in archer TX50E, while 2.4 Ghz works just fine-Solution
2021-06-05 04:11:35 - last edited 2021-06-24 05:48:07

@CasacciaCesar Check in your routers wireless settings that it's not set to bandwidth of 160MHz.

 

I get the exact same issue with mine when I force my router to 160MHz, it works fine on 80MHz and below though.

 

I've been tearing my hair out for the last month trying to work out why it doesn't work on 160MHz and am yet to find an answer.

Recommended Solution
  2  
  2  
#3
Options
Re:5 Ghz doesn't work in archer TX50E, while 2.4 Ghz works just fine
2021-06-22 14:59:17 - last edited 2021-08-20 08:38:45

@Solla-topee Had the same problem with my TX50E. Using the original driver 21.10.1.2 dated 24/04/2019, 5Ghz and 2GHz wifi channels

work great. Upgrading to later versions caused 5Ghz channel to be seen, but can't connect to it.

 

I tried upgrading to the latest driver in the link above and my 5GHz works, but rather than 500 Mbit/sec, I was getting only 10 !

 

Have rolled back to the original driver 21.10.1.2 dated 24/04/2019 and all works perfectly again.

 

Hope this helps.

Solla-topee wrote

@CasacciaCesar Good day, 

 

You could try some suggestion here:

  • Change a different Wi-Fi channel for router's 5Ghz, channel 36/40/44/48 is recommended
  • Customize different SSID & wireless password for router's 5Ghz (better do not use special symbols in the password)
  • Change wireless security to WPA/PWA2-PSK and see if that helps
  • Delete the Wi-Fi profile for 5Ghz and reconnect: https://www.tp-link.com/support/faq/918/
  • Try the latest chipset driver from Intel which is 22.40 for now: 

https://downloadcenter.intel.com/product/189347/-Wi-Fi-6-AX200

 

If still the same problem, may I have know the model of router and a photo of 5Ghz wireless settings of router?

May I have a photo of the Error if 5Ghz WiFi can not be connected, thank you. 

 

  2  
  2  
#4
Options
Re:5 Ghz doesn't work in archer TX50E, while 2.4 Ghz works just fine
2021-06-24 05:51:16

@Sandyman0_1  Hello, 

 

Thanks for sharing,  another advice for users who have TX50E 5Ghz issue, thank you!

Happy New Year! Meet Us at CES 2023 | Featuring Wi-Fi 7, EasyMesh, Matter, and a New HomeShield Security
  0  
  0  
#5
Options
Re:5 Ghz doesn't work in archer TX50E, while 2.4 Ghz works just fine
2021-08-16 14:07:36 - last edited 2021-08-16 14:16:37

@Solla-topee I am aware channel 36/40/44/48 are recommended due to DFS, however my region (New Zealand) only has channel 68-96 restricted but the TX50E is slow/completely broken on 5GHz channel 100 and above. My old tp-link TL-WDN4800 worked fine on those channels. I am only using ac and 80Mhz channel width with the latest (22.70.0) Intel AX200 drivers. I would try using the older 21.10.1.2 drivers @Sandyman0_1 suggested but Intel seems to have removed access to them. It is disappointing that the TX50E seems to have so many issues as I have generally found tp-link products to be solid.

  0  
  0  
#6
Options
Re:5 Ghz doesn't work in archer TX50E, while 2.4 Ghz works just fine
2021-08-17 01:38:41

@r1ch4rdNZ 

Please check my reply on your new thread here .

The official driver on tp-link website are older, you may give it a try: 

https://www.tp-link.com/support/download/archer-tx50e/

 

Happy New Year! Meet Us at CES 2023 | Featuring Wi-Fi 7, EasyMesh, Matter, and a New HomeShield Security
  0  
  0  
#7
Options