Archer C6 Version 3.20 US not Connecting to Internet (PPPoE, Dynamic IP)

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

Archer C6 Version 3.20 US not Connecting to Internet (PPPoE, Dynamic IP)

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Archer C6 Version 3.20 US not Connecting to Internet (PPPoE, Dynamic IP)
Archer C6 Version 3.20 US not Connecting to Internet (PPPoE, Dynamic IP)
2021-07-04 19:24:40 - last edited 2021-07-04 19:30:20
Model: Archer C6  
Hardware Version: V3
Firmware Version: 1.0.5 Build 20201117 rel.41066 (5553)

Hi all,

 

I bought this TP-Link Archer C6 v 3.20 US about 2 weeks ago. From today, I am not being able to connect this router over PPPoE or dynamic IP to the internet. 

 

What I have done so far is-

- updated to the latest firmware

- done factory reset of the router several times

- checked the ISP connection with a different router and the connection works fine with another router

- tried to connect via dynamic IP from a different router but it did not connect

 

While connecting with the internet from Archer C6 v3.20 US, it repeatedly shows "failed to establish internet connection".

 

What can I do to solve the problem and get the router working?

 

Thank you. 

  0      
  0      
#1
Options
1 Reply
Re:Archer C6 Version 3.20 US not Connecting to Internet (PPPoE, Dynamic IP)
2021-07-05 02:20:25

@RI_Palash 

 

Hi, below is a setup video for your reference to install your wireless router:
https://www.tp-link.com/support/setup-video/

 

But if you still failed, please refer to the troubleshooting suggestions below to check your settings:
https://www.tp-link.com/support/faq/1556/

 

Be sure to confirm the internet is working fine first when you connect a computer directly to the ethernet cable from the ISP modem. BTW, who is your ISP? 

  0  
  0  
#2
Options

Information

Helpful: 0

Views: 421

Replies: 1

Related Articles