[Troubleshooting] Deco M4 update firmware problems

[Troubleshooting] Deco M4 update firmware problems
[Troubleshooting] Deco M4 update firmware problems
2021-07-16 16:20:16 - last edited 2021-08-06 01:23:24
Model: Deco M4
Hardware Version: V2
Firmware Version: 1.5.0 Build 20210511 Rel. 34580

Hi, i've been using a pair of M4 (r) decos flawlessly (seriously they were working amazing best internet connection in my life)
Recently i've received a notification to install firmware 1.5.0 Build 20210511 Rel. 34580 and the hell started.

I'm completely unable to... search for google and follow a link, the connection drops, even sending this post it's been an awfull experience, because of the constant dropouts.

 

Have you experienced this?how  should i troubleshoot this?

 

Thanks for your time

 

0
0
#1
Options
1 Accepted Solution
Re:[Troubleshooting] Deco M4 update firmware problems-Solution
2021-08-05 07:22:08 - last edited 2021-08-06 01:23:24

@Roman_Goldberg 

Hi, Did you see my private message?

Could you please help me check those two information?

At the same time, please have a look at the following link

https://community.tp-link.com/en/home/forum/topic/272384

Thank you very much.

 

 

 

 

 

Recommended Solution
0
0
#20
Options
21 Reply
Re:[Troubleshooting] Deco M4 update firmware problems
2021-07-19 06:44:30

@rafius15 

Hi, I might need your help to check more details:

1. Would any Deco turn red when the internet connection dropped?

2. Would all your clients drop the connection?

3.Did the Ethernet connection have the same issue as well?

Here are some suggestions for you:

1.turn off the 2.4ghz and leave the 5ghz only;

2. disable the fast roaming/ beamforming, and the Mesh technology on the devices?

Thank you and wait for your reply.

0
0
#2
Options
Re:[Troubleshooting] Deco M4 update firmware problems
2021-07-19 14:02:10

@TP-Link 

1. Would any Deco turn red when the internet connection dropped?

No

2. Would all your clients drop the connection? All wifi clients, when using the network yes 

3.Did the Ethernet connection have the same issue as well? 
no, ethernet works great

Here are some suggestions for you:

1.turn off the 2.4ghz and leave the 5ghz only;

tested, makes no effect 

2. disable the fast roaming/ beamforming, and the Mesh technology on the devices?

Fast roaming is already disabled by default.

disabling mesh has no effect

0
0
#3
Options
Re:[Troubleshooting] Deco M4 update firmware problems
2021-07-20 01:05:33

@rafius15 

Thank you very much for the update.

I would like to follow up on your case by email and please have a check of your email box later;

By the way, how many wireless clients are connected to Deco? And what are they?

When the connection dropped, was the device still connected to the Wi-Fi but no internet, or the device had already been disconnected from the Wi-Fi?

Since you have a pair of Deco M4, I guess Deco works on the wireless router mode and the satellite Deco is wirelessly connected to the main Deco?

0
0
#4
Options
Re:[Troubleshooting] Deco M4 update firmware problems
2021-07-20 05:42:53

@rafius15 

 

I am also having this issue and have tried everything to no avail. The firmware update really screwed up everything on my end and my speeds have gone down significantly. The app can't even find the devices half the time so troubleshooting is futile. I really hope there's a fix soon because this has been driving me nuts for the last two weeks.

2
2
#5
Options
Re:[Troubleshooting] Deco M4 update firmware problems
2021-07-20 08:03:53 - last edited 2021-07-20 08:09:43

@everglow  and anyone who has the same speed issue after the 1.5.0 firmware upgrade

 Thanks for the update.

I would like to forward your case to the senior engineers and could you please help me check the following information

1. When you said ‘The app can't even find the devices half the time’, Did you mean the Deco APP could not find the Deco M4?

--if yes, please go to Deco APP>Overview>settings on the top left>help>suggestions and send us the APP log;

 

2. As for the speed, could you please provide more details for me:

--How much speed you are supposed to get from the ISP?

--If connecting directly to the main Deco via Ethernet cable, how about the speed?

--Please refer to this link to set another Deco as the main Deco: https://www.tp-link.com/support/faq/2400/

0
0
#6
Options
Re:[Troubleshooting] Deco M4 update firmware problems
2021-07-21 04:27:47

@TP-Link 

 

1. The app starts up as normal, showing all my connected devices. After a few seconds, I get a screen that says "we couldn't find Deco" and to try again. Pressing try again does not do anything, the app just keeps loading. Other times, it tells me it can't find my network even though it is running. I have just sent the App log through the Deco app.

2. My normal speed is 500 Mbps but I am averaging 20-30 Mbps on WIfi after the firmware update. Restarting the modem helps for a day or two but speeds drop back down. Connecting via ethernet gets me about 200-300 Mbps, which is better but still not optimal.

 

TP-Link wrote

@everglow  and anyone who has the same speed issue after the 1.5.0 firmware upgrade

 Thanks for the update.

I would like to forward your case to the senior engineers and could you please help me check the following information

1. When you said ‘The app can't even find the devices half the time’, Did you mean the Deco APP could not find the Deco M4?

--if yes, please go to Deco APP>Overview>settings on the top left>help>suggestions and send us the APP log;

 

2. As for the speed, could you please provide more details for me:

--How much speed you are supposed to get from the ISP?

--If connecting directly to the main Deco via Ethernet cable, how about the speed?

--Please refer to this link to set another Deco as the main Deco: https://www.tp-link.com/support/faq/2400/

 

0
0
#7
Options
Re:[Troubleshooting] Deco M4 update firmware problems
2021-07-21 05:41:42

@everglow 

Thanks for the update.

Would there be any IPTV/VLAN configuration for the internet setup?

Have you referred to the link to set up another Deco as the main Decohttps://www.tp-link.com/support/faq/2400/

By the way, would turning off the 2.4ghz, leaving the 5ghz only improve the wireless speed?

0
0
#8
Options
Re:[Troubleshooting] Deco M4 update firmware problems
2021-07-22 04:14:59

@TP-Link 

 

I do not have IPTV/VLAN configured. I have tried changing the main Deco and that also did not help. Turning off the 2.4ghz band did not make a difference.

2
2
#9
Options
Re:[Troubleshooting] Deco M4 update firmware problems
2021-07-22 07:12:29

@everglow 

Thank you very much and the case has been forwarded to the senior engineers already.

Please refer to the email for further assistance.

 

0
0
#10
Options
Re:[Troubleshooting] Deco M4 update firmware problems
2021-07-24 04:53:41

@rafius15 

I am having the exact same problem. Started a new thread on this issue before seeing this post

The connection keeps dropping and I had to refresh this page several times to write this 

Also, my vpn wont work now. Although my vpn connects, it blocks all internet traffic when the vpn is on

 

This is SO FRUSTRATING!

 

I am currently working from home like most people and am resorting to going out to the store later to get another router as I dont know how I am gonna have my zoom calls come Monday with this going on

 

0
0
#11
Options