Issues: TP-Link Powerline 300Mbps Wi-Fi Adapter Triple Kit W4220

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

Issues: TP-Link Powerline 300Mbps Wi-Fi Adapter Triple Kit W4220

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Issues: TP-Link Powerline 300Mbps Wi-Fi Adapter Triple Kit W4220
Issues: TP-Link Powerline 300Mbps Wi-Fi Adapter Triple Kit W4220
2021-08-31 12:29:39 - last edited 2021-09-03 11:10:34

TP-Link W4220 Powerline 300Mbps Wi-Fi Adapter Triple Kit

A friend of mine has purchased this particular Triple Kit, I believe she purchased them like 3 months ago. During these 3 months she had issues with connectivity, requires resetting up from start. Is anyone coming across any similar problems? Sometimes it is just one unit, sometimes it is two units that are unable to provide connection.

We have followed every instruction provided, made sure that everything was in place and that everything was setup correctly. The issue comes every few weeks or so - it's really mind boggling. 
 
Previously she had a TP-Link Router, utilized it via Lan/Ethernet Bridging - didn't have any problems, except for the WiFi which was cutting off randomly so it needed to be replaced; hence the purchase of the TP-Link W4220 Powerline 300Mbps Wi-Fi Adapter Triple Kit.

Thanks!
Kindest regards! 

  0      
  0      
#1
Options
1 Reply
Re:Issues: TP-Link Powerline 300Mbps Wi-Fi Adapter Triple Kit
2021-09-01 07:16:24

@billyjmcbee Hello, 

May I know does your friend own 3 AV600? Can you help check the back label and confirm the model and hardware version? like TL-PAXX V4/ V5

You could try to reserve an IP address on router for devices connected to powerline unit, and see if that help with stability. 

Confirm powerline units are on the latest firmware: https://www.tp-link.com/support/faq/1614/
Turn off Power-saving mode on powerline devices:https://www.tp-link.com/support/faq/2018/
For test purpose,  put powerline units into the same room and test stability
If the above does not help,  may I know House Led/LED Status on both devices when AV600 lose connection  ?  

May I have a photo of  powerline rate between the powerline units on tpPLC Utility and device current firwmare and hardware version of your devices.

Thank you for confirming the details~

  0  
  0  
#2
Options

Information

Helpful: 0

Views: 285

Replies: 1