Deco M4 Selecting signal source

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Deco M4 Selecting signal source
Deco M4 Selecting signal source
2021-09-23 09:19:27 - last edited 2021-09-24 09:43:56
Model: Deco M4
Hardware Version: V2
Firmware Version: 1.5.0 Build 20210511 Rel. 34580

I'm in a situation where I have a "mesh" network of four M4R(EU) ver 2.0 Decos; dev2 is in basement, the living_room Main deco is on ground floor and master_bedroom and office are locate one floor above. The master_bedroom has a strong connection and signal to the Main Deco and the office device is near the master_bedroom so it should be linkin to living_room via master_bedroom, but instead it's opting for a weak 2.4ghz connection to the Main Deco. 

 

Choosing the "optimize network" option on the mobile software doesn't seem to do anything and there's no option to manually choose the signal source in the web ui either.

 

I've read there has been a beta firmware available previously that would include such a feature; could I have such a version to be installed in the problematic office -device? Mind you I'm currently running the latest release version 1.5.0 so I've also read that the "previous beta" cannot be installed anymore as it would be a downgrade - am I right and is there a version available to fix this problem at the moment?

 

Thanks!

2
2
#1
Options
1 Accepted Solution
Re:Deco M4 Selecting signal source -Solution
2021-09-24 09:19:22 - last edited 2021-09-24 09:43:56

@TP-Link 

 

I thought it was kind of obvious that along with the weak 2.4Ghz signal source came a slow connection - but yes, that was the problem.

 

I did receive a new beta firmware though that solved this issue and now the network structure is as expected.

Recommended Solution
0
0
#3
Options
5 Reply
Re:Deco M4 Selecting signal source
2021-09-24 07:09:27

@Rabbitsies 

Hi, yes, you are right and there is no beta firmware for 1.5.0 anymore.

So, could you please help me get the following details so that I could forward your case to the senior engineers:

1. Can I have a picture of the signal source strength on the office room Deco.

2. Is there any problem if office room Deco is connecting to the main Deco, such as unstable connection or slow speed?

At the same time, you could also have a look at this link:

[Deco] Manual Signal Source Selection

0
0
#2
Options
Re:Deco M4 Selecting signal source -Solution
2021-09-24 09:19:22 - last edited 2021-09-24 09:43:56

@TP-Link 

 

I thought it was kind of obvious that along with the weak 2.4Ghz signal source came a slow connection - but yes, that was the problem.

 

I did receive a new beta firmware though that solved this issue and now the network structure is as expected.

Recommended Solution
0
0
#3
Options
Re:Deco M4 Selecting signal source
2021-10-04 05:10:24

@Rabbitsies 

 

Except now the deco has reverted back to connecting to the further away signal source and speed is crap again.

Apparently there's no means to select or set the signal source here.

 

Are you going to ever fix this or do I just have to buy other brand products instead?

 

0
0
#4
Options
Re:Deco M4 Selecting signal source
2021-10-04 05:37:46

@Rabbitsies 

 

When my Office Deco connects via the master_bedroom deco, the download speed is 80Mbps. When it connects directly to the Main Deco, the download speed is 2Mbps as can be seen in my previous post. It is clear that the automatic selection is not working as it should. I want to be able to set the signal source manually. 

 

How can I achieve this?

0
0
#5
Options
Re:Deco M4 Selecting signal source
2021-10-04 06:05:05

@Rabbitsies 

 

I have now upgraded the rest of the M4s to use the provided beta firmware ( m4r-SP1-up-ver1-5-0-P1[20210804-rel77124]_2021-08-05_08.49.45 ) and at least after their reboot the network went back to proper order again.

 

We'll see if this stays or if they decide to downgrade the connection automagically again.

 

This is frustrating.

0
0
#6
Options