Android Devices connect to router but no Internet

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

Android Devices connect to router but no Internet

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Android Devices connect to router but no Internet
Android Devices connect to router but no Internet
2013-07-26 01:05:10
Region : Spain

Model : TD-W8961ND

Hardware Version : V3

Firmware Version : latest

ISP : vodafone


Hello
The problem is that Android devices (one Android TV and 2 Tablets) are connected to router but can't access Internet (only white wifi logo instead of blue)
they connect to Internet very rarely when changing some settings or turn Off/On the router
have 2 Windows PC connected to the same router and it's working fine
only Android devices have problem with the router
i tried changing some settings in router like DHCP, Static IP, BGN Mode, 20-40 Hz but the problem persists

How can i fix this ?
  0      
  0      
#1
Options
9 Reply
Re:Android Devices connect to router but no Internet
2013-08-03 19:55:46
Hi.
What is the security type of the wireless network on TD-W8961ND? WEP or WPA?
The windows PCs are connected to the router by Ethernet cables? Or using wireless?
Have you tested the Android devices by connecting them to the wireless network of another router? If so, can they access Internet wirelessly?
Have you tried to adjust the wireless channel on the TD-W8961ND?
  0  
  0  
#2
Options
Re:Android Devices connect to router but no Internet
2013-08-06 03:11:09
Security type: WPA2-PSK (i changed even to No Protection but didn't work better)
Windows PCs are connected with wireless adaptor type N
Yes, Android devices connected fine on other network
I tried different settings on router (B,G,N mode separately and all together, 20 MHz or 40 MHz) and now works better but not perfect
Now is on these settings:








  0  
  0  
#3
Options
Re:Android Devices connect to router but no Internet
2013-08-17 12:06:59
Hi.
What are the model numbers of the Android devices?
If you change the security type to WPA-PSK/AES, can the Android devices connect to the network?
What error message can you see when the Android devices are connecting to the network?
BTW, wireless MAC filtering on the modem is disabled, right? You can double check at the bottom of the wireless page.
  0  
  0  
#4
Options
Re:Android Devices connect to router but no Internet
2013-08-18 18:56:08
Hi

The Android devices have different versions: 4.1.2, 4.0.2, 4.0.1 and they behave the same

Changed security type to all in list even to NO Security but the problem persists

There is no error message, the devices connect to wireless network but the Wifi icon remains Gray (is Blue when working)
then need to turn Wifi Off/ON (from Android Settings) for 1 or 2 or 3 times (it depends can be 1 or 5 times) then it connect fine and Wifi icon turns Blue
sometimes it connects to internet even if Wifi icon is still Gray for a few minutes then turns Blue

Yes the MAC filtering is turned OFF
  1  
  1  
#5
Options
Re:Android Devices connect to router but no Internet
2013-08-18 20:24:53
Insert DNS servers manually in DHCP settings
  0  
  0  
#6
Options
Re:Android Devices connect to router but no Internet
2013-08-18 21:37:07

jimasek wrote

Insert DNS servers manually in DHCP settings

Tried that already, didn't notice any improvement
  0  
  0  
#7
Options
Re:Android Devices connect to router but no Internet
2013-08-18 21:43:46
Did you make save and reboot router after those changes.
  0  
  0  
#8
Options
Re:Android Devices connect to router but no Internet
2013-08-19 10:01:46
You can change the SSID(wireless network name) to a new one for a try. For the channel, you can change it to a static one, such as 6, 11 or the others, rather than Auto.


File:
WK1GLO@JXER`TPH%D8}V)OK.jpgDownload
  0  
  0  
#9
Options
Re:Android Devices connect to router but no Internet
2013-08-19 10:04:07
You can change the SSID(wireless network name) to a new one for a try. For the channel, you can change it to a static one, such as 6, 11 or the others, rather than Auto.


  0  
  0  
#10
Options