Deco X90 issues - disconnecting devices

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

Deco X90 issues - disconnecting devices

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Deco X90 issues - disconnecting devices
Deco X90 issues - disconnecting devices
2022-02-19 00:39:34 - last edited 2024-01-24 03:42:58
Model: Deco X90  
Hardware Version: V1
Firmware Version: 1.1.2

After TP-Link failing to solve my bad signal problem with the M9 Plus for more than a 2 months (remote sessions, suggestions, articles), I bought the "best Deco" - X90 a dual package. (what a fool)

 

Now I have stable and speed connection between my computers and NASs. However I have about 40 IoT devices - Shelly (mostly ESP8266 based).

 

They worked perfectly with 3 generations routers - Archer C7, Dual pack M4 and the prototype product, sold by TP-Link - M9 Plus - dual pack.

 

Now they are randomly disconnecting - from minute After router boot they are starting losing connection one by one. Usually I am making guest network - 2.4 GHz only and IoT devices there. Always worked like this.

 

This time I tried everything - connecting them to the main network, hard reset, deleting them, trying with only one X90, creating new account, stopping Fast Roaming, Beamforming, UPNP and all the things that can be disabled, stopping Mesh from the toggle for each device, so PLEASE DONT SIMULATE SUPPORT BY SENDING ME POOR ARTICLES IN YOUR SITE!

 

Ans of course, latest firmware for your NEWEST DECO IS 7 months old! 
 

Is there a Deco product that everything works?????????

Frustrated Deco (X90, M9 Plus, M4R, E4) & Tapo (C200, C210) owner looking for solutions to use the investment in them. Expensive Plastic...
  1      
  1      
#1
Options
1 Accepted Solution
Re:Deco X90 issues - disconnecting devices-Solution
2022-03-03 02:53:27 - last edited 2024-01-24 03:51:39

  @Momcho  Nice to see you again.

I used to see many users complain that the new Mesh technology was not a good choice for smart IoT devices here and there. Since different brands all have developed their own Mesh strategies, the Mesh routers will start a new lead. During this process, there are surely different kinds of negative reviews and I believe all will be improved along with time.

And I have reviewed your Facebook post in the Shelly group and based on the comments from other users, you can see some users have no issue with Deco.

 

So if you experienced any disconnection issues of Shelly devices with Deco, please refer to the following suggestions:

1. Are Shelly devices the only mobile clients that dropped out frequently?

If yes, please refer to this link to edit the Shelly devices first:

Shelly device keeps going unavailable and disconnected

2. Turn off "Mesh Technology" on the Deco APP for Shelly smart devices.

3. Temporarily disable "Fast roaming" and "Beamforming" under Deco APP>More>Advanced.

 

Thank you very much and best regards.

Recommended Solution
  0  
  0  
#9
Options
9 Reply
Re:Deco X90 issues - disconnecting devices
2022-02-19 00:43:48 - last edited 2022-02-19 01:34:25

Also tried changing WPA type, disabling password, changing SSID, and literally everything.

Of course, also changing the positions of Decos multiple times, changing main Deco, hard resetting the decos, even buying the subscription (yes, 600 euro router requires subscription for Time Limit In parent control for example).

Also connecting Decos with cable, etc.

spend more than 30 hours trying all possible combinations, the devices keep disconnecting after 2-3 minutes and never connecting again.

 

*What an AI!*

Frustrated Deco (X90, M9 Plus, M4R, E4) & Tapo (C200, C210) owner looking for solutions to use the investment in them. Expensive Plastic...
  0  
  0  
#2
Options
Re:Deco X90 issues - disconnecting devices
2022-03-01 13:17:31 - last edited 2022-03-01 13:18:38

Update for the users who follow the topic:

Since starting this topic I had multiple sessions with @TP-Link (thank you for that) for more than 12 hours combined.

Of course it is too annoying and time consuming to give access to them, to fix their own product every morning.

 

Today the remote session was 5 hours long and they managed somehow to connect some of the devices. It seems all of them are connected to the Main Deco, which is not good, because the signal is weak to the devices which are closer to the Satellite X90 and this makes once again the term "mesh" in their systems useless.

They said they will develop Beta for this case, but still I don't have it.

 

So just information for the new buyers, if you have some IoT devices or Homepod which you want to stereo pair, you will lose a lot of your nerves to make them work and you will not be able to do it.

If you want stable and good signal, you should take X90, you don't have a choise, however your IoT devices will not be compatible at this time with it.

Frustrated Deco (X90, M9 Plus, M4R, E4) & Tapo (C200, C210) owner looking for solutions to use the investment in them. Expensive Plastic...
  0  
  0  
#3
Options
Re:Deco X90 issues - disconnecting devices
2022-03-02 10:16:11 - last edited 2023-03-07 00:57:24

Update: Today TP-Link wrote me that is not fixable issue.

 

Great! One more proof, this time for X90 it is useless peace of plastic.

 

Frustrated Deco (X90, M9 Plus, M4R, E4) & Tapo (C200, C210) owner looking for solutions to use the investment in them. Expensive Plastic...
  2  
  2  
#4
Options
Re:Deco X90 issues - disconnecting devices
2022-03-02 18:37:04

I was having the same problem with my Deco X60.

 

Also, slower internet issues. It was supposed to be a WiFi 6 access point, but I was able to show the technician I was working with that I was able to get better speeds connecting to my EAP-225 outdoor (TP-Link Omada AC1200).

 

I have about 70 devices total on my network (wired and wireless), and 37 devices listed in my Apple Home app. And as @Momcho said, these devices disconnect randomly. Sometimes they need to be reset, and sometimes they will start working again. I noticed that my devices are listed not only in the Deco app, but also in my ISP's router (Bell HomeHub 3000), which led me down the path that it may be my ISP's crappy router that is causing that issue. I was thinking about upgrading to the X90 to fix the issue, but if you are having the same problem, then I will have to think on this a little longer.

  1  
  1  
#5
Options
Re:Deco X90 issues - disconnecting devices
2022-03-02 19:07:28

  @Dave.W thank you for sharing that very much!

 

They are currently trying to "replace" my expensive X90 for X60 (which is 2 times cheaper), which is not solution in my opinion. And as now when you said this, I am not sure I will agree.

 

They said is because of the Broadcom chipset, but I am sure that they are unable to support their products, after this is the second high end Deco they can't deal it.

Maybe their developers are from India, just like Boeing.

 

So in my opinion don't go for X90. Just until they don't review all their practices and support, which in my opinion will never going to happen. They just don't care after they sold the product.
 

P.S. I shared my experience in the international Shelly group and it turns out many, many users are having this issue and are replacing Deco with competitions.

Frustrated Deco (X90, M9 Plus, M4R, E4) & Tapo (C200, C210) owner looking for solutions to use the investment in them. Expensive Plastic...
  1  
  1  
#6
Options
Re:Deco X90 issues - disconnecting devices
2022-03-02 19:24:04

@Momcho I spent 3 nights working with their technician logging into my windows and mac comptures, making configuration changes programmatically, and retesting. Probably over 8 hours over the course of three nights. He suggested I return them since they were still under warranty, which I am doing. I was one of those dumb people who paid for the extended BestBuy warranty, which worked out in this case because rather than exchaning them for a second set of X60s they will be sending me a gift card which I can use to purchase new routers (hence looking at the X90s). I have had a very good experience with my Omada network (which I use outside, garage, etc.), so I am reluctant to disparage TP-Link in general, but I agree then X60s are less than stellar in my opinion. I may try the XE75 units which are supposed to come out this month, but if I don't see immediate improvement I will return them for a refund within the 30 day period and try something else. 

  1  
  1  
#7
Options
Re:Deco X90 issues - disconnecting devices
2022-03-02 21:08:23

  @Dave.W Me too, I had more than 7 morning sessions, starting from engeneer who can't exit Vim and closing the terminal because of that going to the R&D.

They said that M9 problem is not fixable and 2 weeks later when I changed with X90, that the problem with X90 is also not fixable.

 

so based on your comment, I am going to refuse the offer (which is against me, based on the value anyway) about the X60. And if you want my advice - don't get X90. Out issues are some similar.

 

also they should add basic funcs like to choose the WiFi channel and I am sure the customers will tweak what is the reason why is not working.

Frustrated Deco (X90, M9 Plus, M4R, E4) & Tapo (C200, C210) owner looking for solutions to use the investment in them. Expensive Plastic...
  0  
  0  
#8
Options
Re:Deco X90 issues - disconnecting devices-Solution
2022-03-03 02:53:27 - last edited 2024-01-24 03:51:39

  @Momcho  Nice to see you again.

I used to see many users complain that the new Mesh technology was not a good choice for smart IoT devices here and there. Since different brands all have developed their own Mesh strategies, the Mesh routers will start a new lead. During this process, there are surely different kinds of negative reviews and I believe all will be improved along with time.

And I have reviewed your Facebook post in the Shelly group and based on the comments from other users, you can see some users have no issue with Deco.

 

So if you experienced any disconnection issues of Shelly devices with Deco, please refer to the following suggestions:

1. Are Shelly devices the only mobile clients that dropped out frequently?

If yes, please refer to this link to edit the Shelly devices first:

Shelly device keeps going unavailable and disconnected

2. Turn off "Mesh Technology" on the Deco APP for Shelly smart devices.

3. Temporarily disable "Fast roaming" and "Beamforming" under Deco APP>More>Advanced.

 

Thank you very much and best regards.

Recommended Solution
  0  
  0  
#9
Options
Re:Deco X90 issues - disconnecting devices
2022-05-17 21:13:08

  @Momcho I will most likely return mine and get an Orbi again. I am having similar issues with 2.4GHz, they all drop after a week requiring a reboot of the main Deco node. This is silly, there are a LOT of 2.4Ghz devices out there, mostly IoT such as cameras and power switches. Sad.

  0  
  0  
#10
Options

Information

Helpful: 1

Views: 2123

Replies: 10

Related Articles