Deco M9 - Slow Speed Help

Deco M9 - Slow Speed Help
Deco M9 - Slow Speed Help
2022-05-16 10:44:08 - last edited 2022-05-18 10:28:35
Hardware Version:
Firmware Version:

Hi all

 

I'm struggling a bit with my M9+ Mesh network speeds, and just need some help/advice on what the best setup should be.

 

Here is my setup:

 

Deco#1 : Main Deco setup in entrance hall of the house.

Deco#2 : Setup in the main bedroom, on the floor above Deco#1 (+/- 5 meters away from Deco#1).

Deco#3 : Setup in my son's room, through 2 walls from Deco#2 (+/- 6 meters away from Deco#2).

Deco#4 : Setup on the 3rd floor in my office, on the floor above Deco#3 (+/- 3 meters away from Deco#3)

Deco#5 : Setup in my shed, on the same level as Deco#1, but quoite far away. It is 'close' to Deco#3 (+/- 15 meters line of site, no walls, just 2 windows on either side)

 

Is my logic correct in saying that Deco#5 is receiving the internet through these steps : Deco#5-to-Deco#3-to-Deco#2-to-Deco#1-to-Internet ..?

 

Is there an app I can download that can show me the above graphically?

 

Is there a way I can resolve the slow speed in my shed[Deco#5] and office[Deco#4]? Possibly buying more Deco access points?

 

If it is something I cannot avoid, is there a Deco WiFi booster that I can install that could solve the problem?

 

 

Thanks!

 

 

 

0
0
#1
Options
1 Accepted Solution
Re:Deco M9 - Slow Speed Help-Solution
2022-05-17 03:46:22 - last edited 2022-05-18 10:28:35

Hi Alexandre. thank you very much for your advicelaugh

  @JamesSolomon, I guess your current firmware might be the problem.

the firmware below 1.4.0 does not have web UI and you could refer to this link to get your firmware updated to the latest one first:

How to update Deco M9 plus from firmware 1.2.12 Build 20191014 Rel. 42025

The latest firmware for Deco M9 Plus V2 is Deco M9 Plus(EU)_V2&V2.2_1.5.6_211018

 

Thank you very much.

best regards.

 

--------------------------

Deco X50-PoE is ready for your advice. Please spare a moment and help us complete the following survey.

Deco X50-POE Survey

Please leave me a message if I haven't seen your post and your issue is quite urgent!
Recommended Solution
0
0
#7
Options
7 Reply
Re:Deco M9 - Slow Speed Help
2022-05-16 13:11:25 - last edited 2022-05-16 13:11:50

  @JamesSolomon 

 

To see where Satellite Deco is connected to, open Deco app, touch the Globe, you should see the list of all Deco nodes in your Deco mesh. Touch Deco node in that list that you want to get info about, a new page will open with info for that specific Deco node.

 

In that page, look for "Signal Source," it will tell you where connection goes and with what quality. Example from my Satellite Deco M9:

 

 

In this example, my Satellite M9 is connected to Main Deco M9 which I named "Living Room," with excellent quality of connection between them.

 

------------

 

You can also see the full map of your Deco mesh connectivity through Deco mesh Web interface. It should be available by opening IP address of Main Deco in Web browser. There will be login screen that looks like this:

 

 

You'll have to enter same password you use to login to Deco app.

 

Example from Web interface:

 

 

In this example, all three Satellite Deco connected to Main Deco.

2
2
#2
Options
Re:Deco M9 - Slow Speed Help
2022-05-16 13:58:49

  @Alexandre. 

 

Thanks very much for the reply, but I cannot seem to see what you are suggesting.

 

  1. I open Deco app
  2. Touch the Globe
  3. I see the list of all Deco nodes in the Deco mesh
  4. I touch the Deco node in list that I want to get info about
  5. A new page opens
  6. All the is on that page, is 'Deco Health Check --> Deco is working well'

 

Is there something I'm doing wrong?

 

 

0
0
#3
Options
Re:Deco M9 - Slow Speed Help
2022-05-16 14:33:25

  @JamesSolomon 

 

It is possible you have older version of Deco firmware. With previous versions of Deco firmware, you may see 'Deco Health Check --> Deco is working well' when no devices are connected to that Deco. When there is at least one device connected to that Deco node, you'll see detailed info. 

The workaround is to connect something to that Deco node, wirelessly or wired to Ethernet port.

 

I would suggest you check if your Deco nodes firmware can be upgraded to newer version. In Deco app, open More/Update Deco and see what version of Deco M9 Plus is there and also if updates are available. 

0
0
#5
Options
Re:Deco M9 - Slow Speed Help
2022-05-16 21:18:09

  @JamesSolomon 

 

One more thing:  try http://192.168.68.1/

2
2
#6
Options
Re:Deco M9 - Slow Speed Help-Solution
2022-05-17 03:46:22 - last edited 2022-05-18 10:28:35

Hi Alexandre. thank you very much for your advicelaugh

  @JamesSolomon, I guess your current firmware might be the problem.

the firmware below 1.4.0 does not have web UI and you could refer to this link to get your firmware updated to the latest one first:

How to update Deco M9 plus from firmware 1.2.12 Build 20191014 Rel. 42025

The latest firmware for Deco M9 Plus V2 is Deco M9 Plus(EU)_V2&V2.2_1.5.6_211018

 

Thank you very much.

best regards.

 

--------------------------

Deco X50-PoE is ready for your advice. Please spare a moment and help us complete the following survey.

Deco X50-POE Survey

Please leave me a message if I haven't seen your post and your issue is quite urgent!
Recommended Solution
0
0
#7
Options
Re:Deco M9 - Slow Speed Help
2022-05-17 17:09:28

  @David-TP 

 

Thanks for this. I downloaded the software and .bin on my laptop, and deployed the new firmware. So far so good and I csn see which other access pointsthey are routing through.. Except two of my access points still seem to be on the 'old' firmware. Is there a way to update these manually? 

 

I can't seem to connect to http://192.168.68.1 or .100 or .101 .. not sure if there is a another way to view this information?

 

Also, I updated my Operation Mode from 'Wireless Router' to 'Access Point'.. Do you think that is wise?

 

 

Thanks for all the help so far, everyone!

0
0
#10
Options
Re:Deco M9 - Slow Speed Help
2022-05-18 10:27:27

Ok

I reinstalled the firmware on all the devices (installed the firmware twice) using the upgrade tool, and now all the devices are on the same (latest) firmware, and the network looks good.

 

Holding thumbs that this allows me to diagnose (if still a problem) any network speed issues.

 

Thanks for all the help, everyone!

0
0
#14
Options