Port Forwarding not working; Ports still closed

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

Port Forwarding not working; Ports still closed

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Port Forwarding not working; Ports still closed
Port Forwarding not working; Ports still closed
2022-06-24 14:38:57
Model: Archer C6  
Hardware Version: V2
Firmware Version: 1.3.6

I have a home server (Ubuntu Server) running on 192.168.0.069. I have set up port forwarding as follows:

 

 

My network status is also as follows (IP address blurred for privacy):

 

 

I checked on Portchecker and none of the ports (e.g. 1337, 80, 22) are open on that external ip address starting with 58.177. Am I configuring something wrong? Is my ISP filtering some port activity? Is there a way for me to debug this further?

 

Thanks for your help!

  0      
  0      
#1
Options
3 Reply
Re:Port Forwarding not working; Ports still closed
2022-06-24 17:24:05

  @Ollie_ 

 

Hi,

 

Don't trust those online portcheckers too much. I have seen them reporting ports as "closed" while external access to the service running on that port worked just fine.

 

First verify that you can access the service on port 22 (normally SSH) of client 192.168.0.69 from another device within the same network.

 

If that works fine, then verify there is no firewall on the Ubuntu Server blocking access from external IP addresses.

 

Also, I recommend you don't add extra zeros in front of numbers when you enter IP addresses (like 069). It may work fine on the Archer C6, but in general this is like asking for trouble.

  0  
  0  
#2
Options
Re:Port Forwarding not working; Ports still closed
2022-06-24 18:15:11

  @woozle 

 

Thanks for the response!

 

  • I can connect fine to the server from devices on the internal network
  • There is no firewall setup; the output of ``sudo ufw status`` is ``Status: inactive``
  • I think this is more a problem with the router or the ISP as even traceroute isn't working on the router's external address; when I run traceroute <<external IP>>, it hangs after about 7 hops.
  0  
  0  
#3
Options
Re:Port Forwarding not working; Ports still closed
2022-06-24 19:08:31

  @Ollie_ 

 

To rule out some parts of the chain from the Internet to your Ubuntu Server maybe try if you can at least get as far as the C6 itself.

Either setup a VPN Server on the C6 and then connect to it via a VPN client device from the Internet or enable "Remote Management" (can be enabled under "Advanced" -> "Administration") and then connect to the C6's webGUI from another device on the Internet via a web browser.

 

If even that doesn't work, then it would indeed point to a problem with the ISP.

 

  0  
  0  
#4
Options

Information

Helpful: 0

Views: 1527

Replies: 3

Related Articles