Carrier Aggregation not working after updating to Firmware 1.7.0

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

Carrier Aggregation not working after updating to Firmware 1.7.0

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Carrier Aggregation not working after updating to Firmware 1.7.0
Carrier Aggregation not working after updating to Firmware 1.7.0
2023-06-02 14:27:19 - last edited 2023-06-03 17:57:12
Model: Archer MR600  
Hardware Version: V2
Firmware Version: 1.7.0 0.9.1 v0001.0 Build 220826 Rel.58057n

Greetings,

 

After updating to Version 1.7.0 yesterday, carrier aggregation is no longer working. 

Logs showing these in a loop:

2023-06-02 19:42:56 [6] 4G: USER: Network type is LTE.

2023-06-02 19:42:58 [6] 4G: USER: Network type is LTE PLUS.

 

I wanted to downgrade my Firmware to 1.6.0 for which i have the firmware but the official page of MR600 no longer has this firmware so i don't know if i should flash it or not, because after reading some threads it seems like the device cannot be unbricked.

 

I have attached the logfile also. I wanted to know if downgrading should resolve the issue or if it is safe to do so or even if downgrading will do something because ISP cannot be downgraded.

 

[EDIT] I have also performed a factory reset after upgrade.

[EDIT 2] Downgrading to 1.6.0 instantly fixed Carrier Aggregation issue. I don't need to access my router from the cloud so i think i will not upgrade back.

[EDIT 3] Before the update my router was sometimes appearing offline on tether app, but after the update my router appears online everytime i try to access it using cloud.

 

File:
c_log.zipDownload
  2      
  2      
#1
Options
9 Reply
Re:Carrier Aggregation not working after updating to Firmware 1.7.0
2023-06-05 11:25:11

  @SweenWolf 

 

May I know your current firmware version? and if it shows 4G+ now after the downgrade, please also check the band on Advanced->Status page to see if it works on one band or two bands.

If you found the post or response helpful, please click Helpful. If an answer solves your problem, click "Recommended Solution" so that others can benefit from it.
  0  
  0  
#2
Options
Re:Carrier Aggregation not working after updating to Firmware 1.7.0
2023-06-05 12:08:18 - last edited 2023-06-05 12:11:18

  @Sunshine 

My current Firmware Version is :

1.6.0 0.9.1 v0001.0 Build 220105 Rel.58321n

 

It is now showing 4G+

Its currently on bands 3,40

 

 

When the router was on 1.7.0 then 4G+ indicator kept blinking in 2 seconds interval.

  1  
  1  
#3
Options
Re:Carrier Aggregation not working after updating to Firmware 1.7.0
2023-06-05 14:54:47 - last edited 2023-06-05 14:58:13

  @SweenWolf 

Hi everyone,
I also have the same problem with the new firmware....unfortunately I can't reset the modem, I was wondering if it was possible to downgrade the firmware to the previous version without resetting the modem:
I downloaded the old firmware 1.6.0 from the official tp-link site if I try to install it, does it succeed or does it freeze because it understands that it is older than the one currently installed?
  0  
  0  
#4
Options
Re:Carrier Aggregation not working after updating to Firmware 1.7.0
2023-06-05 15:48:24

  @Feda1980 

If your device can be downgraded then it will be downgraded, otherwise the device will just give you an error (In my case, i can downgrade to 1.6.0 but not to 1.5.0).

You will lose your settings if you downgrade. In most cases downgrading is allowed, only exception is if the update contains some CVE patches then downgrading isn't allowed.

  1  
  1  
#5
Options
Re:Carrier Aggregation not working after updating to Firmware 1.7.0
2023-06-12 05:31:14

  @SweenWolf 

yeah i have the same problem in new 1.7.0 0.9.1 firmware update in mr600 v2 

4G+ LED light on router blinking many time when start using internet or surfing the web but when i want to download a file it was stable and don't seems to blink

the problem begins when i update my router firmware automatically in the router panel from firmware upgrade page

now my question is this can be dangerous for my router or cause damage?and may i need to downgrade to previous version?

please help.

 

  0  
  0  
#6
Options
Re:Carrier Aggregation not working after updating to Firmware 1.7.0
2023-06-14 13:47:42

  @mmd3532 

Blinking 4G+ means band are not locking.

The router is continuously switching between 4G and 4G+.

Downgrading will not cause any issue.

But make sure there's no power cut during downgrade. I have a ups attached to the router so i had no problem with it.

  0  
  0  
#7
Options
Re:Carrier Aggregation not working after updating to Firmware 1.7.0
2023-06-15 13:28:14

  @SweenWolf 

Hi everyone,
in the end I downgraded to the previous firmware ... by downgrading, however, the router returned to the initial settings, luckily having made a backup I was able to restore the settings as I wanted.
The question now is:
When will TP-LINK issue a new firmware that will fix this problem on firmware 1.7??
I did the downgrade to recover the 4G+ but I have the problem of the previous firmware, i.e. that from the App Tether even if the router is actually connected to the internet from the app it is inaccessible...
Remove a problem and find another ... when a firmware finally done well and not with the feet???

  0  
  0  
#8
Options
Re:Carrier Aggregation not working after updating to Firmware 1.7.0
2023-07-04 02:08:28

  @Feda1980 @mmd3532 @SweenWolf 

 

Hi,since we are unable to reproduce the issue on our end, may I know if you would like to debug the issue with our senior engineer? If so, we will follow up your case via email for further testing and analysis.

 

In addition, may I know the model no. of your smartphone? and if you insert the same SIM card into your smartphone, does it show 4G+ all the time?

If you found the post or response helpful, please click Helpful. If an answer solves your problem, click "Recommended Solution" so that others can benefit from it.
  0  
  0  
#9
Options
Re:Carrier Aggregation not working after updating to Firmware 1.7.0
2023-07-06 07:38:17

  @Sunshine 

Hi, I would love to help out.

 

My phone is Samsung Galaxy A73 5G (SM-A736B/DS), it shows 4G+ most of the time, i lose 4g+ when raining heavily, otherwise its consistent 4g+.

 

The router also always has 4G+ when its on 1.6.0 (i have manually selected band), the issue only arises when i upgrade it to 1.7.0

  1  
  1  
#10
Options

Information

Helpful: 2

Views: 938

Replies: 9

Related Articles