Archer AX55 remote management with HTTP port 80 non available

Archer AX55 remote management with HTTP port 80 non available

Archer AX55 remote management with HTTP port 80 non available
Archer AX55 remote management with HTTP port 80 non available
2023-08-27 12:15:20 - last edited 2023-08-31 00:53:45
Model: Archer AX55  
Hardware Version: V1
Firmware Version: Archer AX55(EU)_V1_1.2.3 Build 20230603

I recently bought an archer AX55 to substitute my old Archer D5 but I have some problems with the remote functionality.

My goal is to see my old IPwebcams, the AX55 is a client in a local lan connected to a modem which is connected to internet via a optical device.
I 've done all of this already with my old Archer D5 with a ddns service and the forwarded ports fot he webcams and works perfectly.
Now I swapped the D5 with the new AX55 replicating all the configuration from the D5, and everything works fine except the access to the ipwebcams from internet (I can see and move them in the local LAN).
My guess is that I must open the remote management http port 80, but this option DOES NOT APPEAR IN MY ROUTER, even if is present in the manual and in the TP link emulator, only the HTTPS 443 is avaible and anyway even enabling it does not work.
Is it a bug or tplink decided to remove the http 80 option?
Any advice is welcome to overcome the issue
Thank you very much in advance

  0      
  0      
#1
Options
1 Accepted Solution
Re:Archer AX55 remote management with HTTP port 80 non available-Solution
2023-08-29 16:24:17 - last edited 2023-08-31 00:53:45

  @woozle 

Finally it seems that I managed everything to work.
First of all, to answer your question, yes my network was exactly like your drawing, but with the AX55 it wouldn't work.
To make it work I had to switch off the DyDNS on the AX55 and switch it on the ISP modem router, then I forwarded the Ipwebcam ports also on the ISP modem router
I activated remote management on AX55 on port 443, and forwarded it on the ISP modem as well and now it works, but it gives a warning in the browser that the connection is not private...
The situation was very different with the old D5, because no dynDNS or port forwarding was necessary to do on the ISP modem (only the DMZ), but anyway it seems to work now.

I have tried this configuration before writing in this forum but it didn't worked at first,
that time probably because I didn't bother to reboot the ISP modem and keeping the same ip adress for the AX55 maybe it did not match the MAC adress, anyway i'm not sure.
To be honest even with the current configuration, after the first time it worked, I rebooted everything to be sure and after that it did not work agin,
then I logged in the AX55, logged in its dynDNS page ticking the "WAN IP binding" option, then I logged out the AX55 DynDNS, and only after this operationa and a reboot it worked again and seems to keep working.
Everything seems ok now, I only have low ID on emule, for that program the uPNP is not working (anyway it seems to work with other programs i.e the printer)
Thank you again for your help, if you have any further advice please be my guest.

Recommended Solution
  0  
  0  
#5
Options
6 Reply
Re:Archer AX55 remote management with HTTP port 80 non available
2023-08-27 14:43:10

  @Punkettaro 

 

Hi,

 

The purpose of the remote management options is to allow the user to access the configuration GUI of the AX55 directly via the Internet.

So, if you were to configure your fiber modem to forward port 443 TCP to the LAN IP address of your AX55, then you would be able see your AX55's login screen if you browse to the link https://[YourDomainName] from the Internet.
The same would apply for remote management port 80 (HTTP) if it existed. My guess is that TP-Link has removed HTTP access from the firmware, because nowadays it is no more considered appropriate to send something over the Internet completely unencrypted.

 

When you swapped the two routers with each other you made sure the WAN IP address of the Archer AX55 is the same one the Archer D5 used, right? 

 

  0  
  0  
#2
Options
Re:Archer AX55 remote management with HTTP port 80 non available
2023-08-27 15:56:53

  @woozle 

 

Thank you for your answer.

"When you swapped the two routers with each other you made sure the WAN IP address of the Archer AX55 is the same one the Archer D5 used, right?"

Yes I copied everything , of course the IP addresses,subnet , the gateways, DNS server etc.


I tried to forward the 443 port too but it didn't work, no matter what I do I can't see the AX55, it works only via tp link tether app.

The real issue, I think, is that the AX55 is in a sub LAN and not directly connected to internet.
The topology is the following:
internet->fiber device->ISP modem router (192.168.1.1)->AX55(192.168.1.2  with gateway 192.168.1.1)->AX55 LAN (AX55 itself IP for LAN 192.168.2.1 with gateway for its DHCP server 192.168.2.1)-> ALL MY local devices IPs 192.168.2.xx
This topology works even with Dyn DNS and port forwarding with the old Archer D5,

but I was ever been able to reach the AX55 from internet in this way (except using their app).
I also DMZ the AX55 in the ISP modem router config (is was necessary for the D5 to work)

Thank you in advance

  0  
  0  
#3
Options
Re:Archer AX55 remote management with HTTP port 80 non available
2023-08-27 16:54:22

  @Punkettaro 

 

Ok, so the network setup looks like the drawing below? (of courese the IP addresses and ports of the IP webcams are made up by me and just for illustration)

 

What bothers me is that not even the AX55's remote management works. I mean, if you can't even get to the router itself, then there is no way of reaching something that is still behind that router.

Can you please test the following?
To check if the ISP router isn't maybe using port 443 for its own purposes (and hence doesn't forward it to the DMZ host) please change the HTTPS remote management port of the AX55 from 443 to something else, like 7777. Then test if you can reach the AX55 via the link https://[YourDomainName]:7777
 

  0  
  0  
#4
Options
Re:Archer AX55 remote management with HTTP port 80 non available-Solution
2023-08-29 16:24:17 - last edited 2023-08-31 00:53:45

  @woozle 

Finally it seems that I managed everything to work.
First of all, to answer your question, yes my network was exactly like your drawing, but with the AX55 it wouldn't work.
To make it work I had to switch off the DyDNS on the AX55 and switch it on the ISP modem router, then I forwarded the Ipwebcam ports also on the ISP modem router
I activated remote management on AX55 on port 443, and forwarded it on the ISP modem as well and now it works, but it gives a warning in the browser that the connection is not private...
The situation was very different with the old D5, because no dynDNS or port forwarding was necessary to do on the ISP modem (only the DMZ), but anyway it seems to work now.

I have tried this configuration before writing in this forum but it didn't worked at first,
that time probably because I didn't bother to reboot the ISP modem and keeping the same ip adress for the AX55 maybe it did not match the MAC adress, anyway i'm not sure.
To be honest even with the current configuration, after the first time it worked, I rebooted everything to be sure and after that it did not work agin,
then I logged in the AX55, logged in its dynDNS page ticking the "WAN IP binding" option, then I logged out the AX55 DynDNS, and only after this operationa and a reboot it worked again and seems to keep working.
Everything seems ok now, I only have low ID on emule, for that program the uPNP is not working (anyway it seems to work with other programs i.e the printer)
Thank you again for your help, if you have any further advice please be my guest.

Recommended Solution
  0  
  0  
#5
Options
Re:Archer AX55 remote management with HTTP port 80 non available
2023-08-29 18:52:35

Punkettaro wrote

 
... that time probably because I didn't bother to reboot the ISP modem and keeping the same ip adress for the AX55 maybe it did not match the MAC adress, anyway i'm not sure.
 

  @Punkettaro 

 

Actually, now I am wondering if the ISP modem router might be internally linking the IP address you choose for the DMZ with the MAC address of the device that was connected at the time DMZ was activated.

 

When you did all your testing previously did you also try the method -> first deactivate DMZ, then connect the AX55 to the ISP modem router and then re-activate DMZ again?

 

 

  0  
  0  
#6
Options
Re:Archer AX55 remote management with HTTP port 80 non available
2023-08-30 17:42:24

  @woozle 

 

  @Punkettaro 

 

Actually, now I am wondering if the ISP modem router might be internally linking the IP address you choose for the DMZ with the MAC address of the device that was connected at the time DMZ was activated.

 

When you did all your testing previously did you also try the method -> first deactivate DMZ, then connect the AX55 to the ISP modem router and then re-activate DMZ again?

 

 

 No I did not, and infact it didn't work the first time.

Anyway my ISP modem router shows a mac address under the field for the DMZ IP, and when i put the IP for the DMZ and I noticed that the mac address below did not changed but after the reboot it finally showed the AX55 mac adress when I put its IP adress.

Anyway I'm monitoring the network behaviour because sometimes if I reboot everything (optical device, ISP and AX55) I cannot reach the Ip webcams (but I can reach the remote management AX55 on port 443), if I reboot again only the AX55 or the ISP modem seems that I can reach the Ipwebcams again...but I'm not so sure because it also happened that I reboorted everything and it worked.

  0  
  0  
#7
Options

Information

Helpful: 0

Views: 292

Replies: 6