2
Votes

Deco x50-5G no 5G only option / no 5G SA

 
2
Votes

Deco x50-5G no 5G only option / no 5G SA

Deco x50-5G no 5G only option / no 5G SA
Deco x50-5G no 5G only option / no 5G SA
2024-03-18 11:42:00 - last edited 2024-03-19 06:50:13

Hey,

I just received my Deco x50-5G and started the setup process.

I noticed, that the ISP O2 isn't mentioned in the pre-configured profile-list, but anyway, I put in the APN there by hand.

Now I do get an Connection, but in the App the Option "5G only" doesn't show up.

My contract is indeed capable of 5G SA (5G+ as O2 calls it) as I booked the option some time ago.

Is there anything else to do to finally get the 5G only - option running?

 

Thanks a lot in advance.

 

 

 

 

#1
Options
7 Reply
Re:Deco x50-5G no 5G only option / no 5G SA
2024-03-19 06:53:46

  @tiKS23 

Hi, Thank you very much for the feedback.

When Deco X50-5G is on "5G preferred", would it often switch between 4G and 5G?

There is a workaround to achieve the "5G only" mode, please refer to the private message for more details.

Best regards.

 

#2
Options
Re:Deco x50-5G no 5G only option / no 5G SA
2024-05-28 04:10:50

  @David-TP Hi.

 

I'm also looking for the work around. Could you please also share with me?

#3
Options
Re:Deco x50-5G no 5G only option / no 5G SA
2024-05-28 06:04:41 - last edited 2024-05-28 06:08:05

Hi, these are the information that was shared with me (must be read vom buttom to top) t

iKS23: anyway. I found out, that when chosing a single band e.g. N28 I some kind got 5G-SA working, in the setting it is mentioned as NR5G-SA. Thats all I wanted to achieve. Thanks a lot for your support! 2024-03-22 11:45:20

 

tiKS23: I now tried it several times and didn't get it to work. I followed the guide precisely and after the LED flashes two times green, it instantly turns red. So the connection to 192.168.0.1 isn't possible. I'm slowly running out of ideas.... 2024-03-22 11:24:49

 

David-TP: Hi Kevin, Do you mean after installing the 1.0.0 beta firmware, there is still no "5G Only" under the working mode on the Deco APP? Actually, I'm not sure whether it was removed before. Personally, I think maybe the 5G NSA is still mainstream. The LED status on the Deco X50-5G: https://static.tp-link.com/upload/manual/2023/202308/20230803/1910013273_Deco%20X50-5G(EU)1.0_UG_V1.pdf Pulse Green: Deco is upgrading firmware. Solid Green: Deco is all set up and connected to 4G / WAN. Solid White: Deco is all setup and connected to 5G. Best regards. 2024-03-22 02:15:45

 

tiKS23: another question: In what color does the LED in my case need to glow? As mentioned I tried it already and the LED went from green, to flashing green, to red. Although I followed the guide precisely. 2024-03-21 19:28:42

 

tiKS23: Alright, understand. I tried it already but didn't get it working. I asume the sim-card has to be in the x50-5G to connect? Sorry for the dumb question, but I'm not familiar with changing these settings. For the interests sake: Why was the "5G only" option removed in future Firmwares? I often read people complaining about it, is it planned to be implemented again to upcoming Firmwares? Thanks a lot! Kevin 2024-03-21 19:23:31

 

David-TP: Hi, thanks for the message. The beta firmware is 1.0.0. The firmware downgrade needs to be performed via firmware recovery/HTTP Uboot Method and the instructions are on the link here: https://www.tp-link.com/en/support/faq/2958/ Best regards. 2024-03-20 01:51:47

 

tiKS23: I already made it to downgrade to 1.1.0 since this is the oldes firmware available on your website. Can you provide me the FW 1.0.0. to downgrade properly? 2024-03-19 10:49:30

 

David-TP: Hi, thank you very much for your attention. I saw there was an older beta firmware that had added "5G only" mode on the Deco APP. Here is the beta firmware if you want to have a test: https://static.tp-link.com/upload/beta/2023/202304/20230424/x50-5g-V1_20230423_5G_only_need_reset.zip PS: since your current version is 1.1.1 or 1.1.3, you might be unable to install the beta firmware directly. The firmware downgrade from 1.1.3/1.1.1 to 1.0.0 might need to be implemented via firmware recovery: https://www.tp-link.com/en/support/faq/2958/ Best regards. 2024-03-19 07:57:01

#4
Options
Re:Deco x50-5G no 5G only option / no 5G SA
2024-05-28 15:58:46

  @tiKS23 Thanks mate. I will try it out.

#5
Options
Re:Deco x50-5G no 5G only option / no 5G SA
a week ago

  @David-TP Hello David 

Just bought Deco x50G to replace another mobile router in my complete 6 decos mesh network.

The firmware version is 1.1.4 and i don't see 5G only option and network all time is on 4G

Can You please advise for me with private message how to fix this.

Second, on my previous setup with 6 decos + mobile router, there was besides Guest network, also IOT option

Part of my homekit devices were connected to Guest 2.4ghz and part to IOT 2.4ghz

Now there is no option on main x50G router. Is there some workaround for my setup? If i make another Deco x50 as main will i be able to setup IOT network?

Thanks in advance

David-TP wrote

  @tiKS23 

Hi, Thank you very much for the feedback.

When Deco X50-5G is on "5G preferred", would it often switch between 4G and 5G?

There is a workaround to achieve the "5G only" mode, please refer to the private message for more details.

Best regards.

 

 

#6
Options
Re:Deco x50-5G no 5G only option / no 5G SA
a week ago

  @nixuspix 

Hi, Nice to see you again.

The current firmware of Deco X50-5G doesn't support an IOT network yet so when it works as the main Deco, there will be no "IOT Network" appearing on the Deco APP.

For your case, maybe you could refer to the following workaround.

1. Install the 1.1.5 firmware on Deco X50-5G and set Deco X50-5G to "Bridge mode".

https://community.tp-link.com/en/home/forum/topic/668514

2. Create another Mesh network with your previous 6*Deco X50 decos mesh network.

How to Create a New Network in the Deco App

Thank you very much and best regards.

 

#7
Options
Re:Deco x50-5G no 5G only option / no 5G SA
a week ago

David-TP wrote

  @nixuspix 

Hi, Nice to see you again.

The current firmware of Deco X50-5G doesn't support an IOT network yet so when it works as the main Deco, there will be no "IOT Network" appearing on the Deco APP.

For your case, maybe you could refer to the following workaround.

1. Install the 1.1.5 firmware on Deco X50-5G and set Deco X50-5G to "Bridge mode".

https://community.tp-link.com/en/home/forum/topic/668514

2. Create another Mesh network with your previous 6*Deco X50 decos mesh network.

How to Create a New Network in the Deco App

Thank you very much and best regards.

 

  @David-TP 

Thank You so much David!

For now i am using your proposal 2. But Proposal 1 looks very attractive for me due a supported Cell Lock.

Now can i install this 1.1.5 firmware on my Deco x50-5G version EU 1.20?

This 1.1.5 is not offered just like and update for now. Will it come later? Or can install directly without waiting?

#8
Options

Information

Helpful: 2

Views: 489

Replies: 7

Voters 2

voter's avatar
voter's avatar