Archer D7 - Problems with WiFi speed on 2.4GHz band

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Archer D7 - Problems with WiFi speed on 2.4GHz band
Archer D7 - Problems with WiFi speed on 2.4GHz band
2014-11-25 03:37:27
Region : UnitedKingdom

Model : TD-W8980

Hardware Version : V1

Firmware Version : 0.9.1 0.7 v002d.0 Build 140624 Rel.55965n

ISP : Plusnet (up to 17Mb)


I've just installed an Archer D7 AC1750 Dual band gigabit ADSL2+ Modem Router (not TD-W8980 as stated above as no option for Archer D7).

I'm having problems with broadband speeds over WiFi but only on the 2.4GHz band. My broadband speeds over LAN and the 5GHz band are fine (usually about 10Mb/sec) but devices that connect using the 2.4Ghz band get seriously slow speeds (it generally fluctuates a bit but often sub 1Mb).

WiFi signal is excellent and I have updated to the latest firmware but again no improvement so not sure what could be causing the problem. I am planning to upgrade my broadband to fibre so purchased this in advance. The stock Technicolor 582n router that Plusnet provided that I was using before had good speeds over the 2.4GHz band so do not believe it is an interference problem and I have tried various different channels and the problem seems to persist no matter what channel I select. I also use inSSIDer to find the optimal channel for each band which at the moment is channel 6.

Maybe there is a setting that needs configuring that I am unaware of?

Any assistance with this will be gratefully accepted.

Thanks
0
0
#1
Options
7 Reply
Re:Archer D7 - Problems with WiFi speed on 2.4GHz band
2014-11-25 11:30:52
Did you try channel width 40MHz? Besides, did you secure the network with WPA2-PSK, AES?
0
0
#2
Options
Re:Archer D7 - Problems with WiFi speed on 2.4GHz band
2014-11-26 03:02:57
Hi Yes,

I tried both of these after speaking with technical support. At first this seemed to help but only for about a minute and then I had the same problem. TP-Link support suggested I return it to the retailer but I would rather try to find a fix if I can.

I wondered if it could be some kind of incompatibility with my network adaptors as both the PC's that I have been running the speed tests from use the Broadcom 802.11ac network adapter so I have also tried disabling the adapter and using a Netgear A6200 USB WiFi adaptor instead but this still had the same problem too.
0
0
#3
Options
Re:Archer D7 - Problems with WiFi speed on 2.4GHz band
2014-11-26 11:26:58
Take tp-link technician's advice to replace it. If the problem continues, they can further look into it. How do u think?
0
0
#4
Options
Return
2014-11-27 01:57:36

Ada wrote

Take tp-link technician's advice to replace it. If the problem continues, they can further look into it. How do u think?


Hi,

I will take it back to the retailer this weekend. I haven't yet decided if I will replace with the same or choose a different router altogether.

I will post my findings either way.

Thanks for the replies.
0
0
#5
Options
Re:Archer D7 - Problems with WiFi speed on 2.4GHz band
2014-12-06 02:37:48
I'm interested if you managed to solve it.. I have the same problem but a replacement only temporarily fixed it.
0
0
#6
Options
Re:Archer D7 - Problems with WiFi speed on 2.4GHz band
2014-12-09 15:09:11
Yours is D7 as well?
Did you contact TP-LINK support team before you replace it? You'd better feed it back to them directly. http://www.tp-link.com/en/Support/contact/.
0
0
#7
Options
Re:Archer D7 - Problems with WiFi speed on 2.4GHz band
2015-12-01 17:24:31
I had the same issues so I factory reset the modem and it is working now since about 30 minutes without dropping out.

5GHz was working fine the whole time, 2.4GHz kept losing internet connection every 5-10 minutes. Powering off the modem and back on would fix it but then it would drop out again after 5-10 minutes, so now with the factory reset it's been going fine, hopefully it stays that way.
0
0
#8
Options