Interface Setup -> LAN -> DNS settings not saved

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Interface Setup -> LAN -> DNS settings not saved
Interface Setup -> LAN -> DNS settings not saved
2015-01-22 05:11:38
Region : UnitedStates

Model : TD-W8151N

Hardware Version : V4

Firmware Version : 3.0.0 Build 140313 Rel.26165

ISP : Hondutel


I am trying to configure Primary DNS Server and Secondary DNS Server using
Interface Setup -> LAN -> DNS Relay -> Use User Discovered DNS Server Only
(see attached screenshot)
but the configuration will not save
There are no error messages when clicking on the SAVE button, unless both DNS Servers are configured as 0.0.0.0
in which case the error message is a pop-up "Input one DNS IP at least!"

I also notice that the Web browser (Firefox v35.0 on Windows XP Pro SP3) does not appear to be exchanging data with the Router when the SAVE Button is being pressed.
It is almost as if the Web Browser Javascript for the Router configuration screen is not detecting any changes and therefore is not sending data to the Router.

with this same device I previously been able to configure it with;
DNS Relay = Use User Discovered DNS Server Only
Primary DNS Server = 8.8.8.8
Secondary DNS Server = 8.8.4.4

But (I think) it was after I did a Factory Reset and reconfigured, I could no longer configure User Discovered DNS Server values.

Status -> System Log shows entries of the form
1/21/2015 14:16:41> netMakeChannDial: err=-3000 rn_p=804cf718
I have no idea what these mean.

My ISP is pretty unreliable and has almost zero Customer Support Service.
Apart from being unable to configure DNS Servers, everything else appears to be working OK.

Any ideas?

Regards - Mark
File:
Problem-(1).jpgDownload
0
0
#1
Options
2 Reply
Re:Interface Setup -> LAN -> DNS settings not saved
2015-01-22 11:27:42
Mark, it should a browser issue.
0
0
#2
Options
[SOLVED] Interface Setup -> LAN -> DNS settings not saved
2015-01-22 12:53:58

Vivian wrote

Mark, it should a browser issue.


Vivian,

Thanks.
It was a Browser issue.

After I wrote "It is almost as if the Web Browser Javascript for the Router configuration screen is not detecting any changes and therefore is not sending data to the Router." I began thinking the problem may have been caused by a Firefox version update and that all my Router Factory resets and re-configurations were because I could not configure a Primary DNS Server and Secondary DNS Server via Firefox.

My ISP DHCP server often provides an invalid or very slow DNS IP address.
As the TD-W8151n router was essentially working for my Windows PC (where I had previously configured Preferred and Alternate DNS servers as 8.8.8.8 & 8.8.4.4) solving this configuration of Primary DNS Server and Secondary DNS Server was not a real problem (for me) until my wife & kids began complaining about their tablets and mobile devices connecting to the internet via the TD-W8151n wireless router.

To cut a long story short,
Firefox v35.0 & Google Chrome v 39.x would not save the changes to
DNS Relay = Use User Discovered DNS Server Only
Primary DNS Server = 8.8.8.8
Secondary DNS Server = 8.8.4.4
but an old version of Microsoft Internet Explorer 8 did save the changes.

Hmm.. I don't understand why.
Maybe a Javascript issue?

Thanks again.

Mark
0
0
#3
Options