Cannot get port forwarding to work on Deco M5

Cannot get port forwarding to work on Deco M5
Cannot get port forwarding to work on Deco M5
2017-09-27 05:07:36
Model :

Hardware Version :

Firmware Version :

ISP :

Am new user of Deco M5 and first post. I have U-Verse 50mb service with Arris NVG599 router. Received my Deco M5 2 days ago and it solved my slow wireless problems.
I Plugged it into my Arris (no changes to the Arris) and the setup was easy. Much faster. I have the first Deco M5 in the basement connected by Ethernet to the Arris router. The second and third are on the desk of two desktops wired to the desktops w/ethernet cable. Increased my speed 2 1/2 times!
I am running Linux Mint on my desktops with Apache server software also for two lightly used genealogy web sites used by a few family members accessed by IP address (no domain name). It is accessed by the WAN IP of 99.xx.xxx.xx:8082 and 8083. This has worked well.
At first I thought my web sites still worked with the Deco M5 but after renaming the Deco M5 wireless it was not working. Not sure it ever did?
Anyhow I have attempted to set up port forwarding on my Deco M5.
Used the same Service name for the two ports as with the Arris. Selected my desktop and the app displayed the internal IP address for my desktop. I added the external port numbers, two separate entries each with a separate service name.
This is not working with my WAN IP.
I can access the web site from a device on the LAN using the LAN IP. This worked before & after attempting port forwarding.
1. I cannot display what I set up in port forwarding to verify it is what I intended. Is there a way to display Port forwarding settings? Or to delete so I can retry?
2. Do I need to set up bridge mode in the Arris 599? I have a writeup but don't quite understand if I need this setup.
3. Do I need AP mode? Not sure what this is. Don't think so. Also port forwarding may not work with AP.
Any suggestions would be appreciated.
Thanks for your patience
Rich
0
0
#1
Options
7 Reply
Re:Cannot get port forwarding to work on Deco M5
2017-09-27 11:15:51
Hello Rich,

Please find the FAQ link below:
http://www.tp-link.com/en/faq-1797.html

In your setup, it seems that you have created two port forwarding rules on the Arris router for your desktop. However, when you plug Deco into your Arris modem, a scenario called double-NAT has come into being. In this case, you need to set up port forwarding rules on both Deco and the Arris router.
For example, suppose the main Deco router obtains a WAN IP address (you can check that on the IPv4 page in the Deco app) of 192.168.1.100 from the Arris router, and your desktop obtains an IP address of 192.168.0.100 from Deco. In this case, the Arris modem has a WAN IP of 99.xx.xxx.xx.
Port Forwarding rules on Arris router:
















IP Address Internal Port External Port
192.168.1.100 8082 8082
192.168.1.100 8083 8083


Port Forwarding rules on Deco router:
















IP Address Internal Port External Port
192.168.0.100 8082 8082
192.168.0.100 8083 8083


After that, will create two mappings as below:
99.xx.xxx.xx:8082 <--> 192.168.1.100:8082 <--> 192.168.0.100:8082
99.xx.xxx.xx:8083 <--> 192.168.1.100:8083 <--> 192.168.0.100:8083
And you should be able to access your desktop from internet.
0
0
#2
Options
Re:Cannot get port forwarding to work on Deco M5
2017-09-27 16:42:54
If the main deco works in router mode, desktop gets IP address from Deco. Then you need to open ports for the desktop on deco first, then open ports for deco on your main router.
But if you set up main deco as AP mode, desktop gets IP address from your main router. Then you can passthrough deco and access the desktop directly, and you just need to open the same port for the server as before on your main router, no need to open port on the deco unit.
You can have a try, just switch the main deco to AP mode on the deco app, then open the 8082 and 8083 port for your desktop on the main router. Then it should be good. And that will not effect the speed you have got now.
0
0
#3
Options
Re:Cannot get port forwarding to work on Deco M5
2017-09-27 23:22:43
Thanks for your reply.
If I understand correctly, I set up the Deco_M5 correctly, Two entries, both for Desktop2 (IP 192.168.0.106 ports 8082 and 8083). But on the Arris the port forwarding entries point to Desktop2 as when the desktop was on the Arris wireless. I need to change those entries to point to the Deco_M5
Arris
192.168.1.103 8082 points to the deco_M5 connected by ethernet to the Arris

deco M5
192.168.0.106 8082

test from my phone enter in firefox 99.98.xxx.xx:8082

Still does not work.
I can see what I set up in the Arris from its more detailed web UI. I cannot display if I have my deco M5 port forwarding set up correctly. Hope they get a web UI some day with more detail than can be displayed on a phone. But anyway, is there a way to display what I have set up on the deco? Maybe I made a typo. Or to reset the PF and redo.

Ok I reviewed and found the last step at the link you sent says to check the IPv4 entry for the WAN address, add :8082 to it. This does not work, but I expected it to be 99.98.xxx.xx but it is the LAN address my deco_M5 is connected to the Arris, 192.168.1.103 That cannot be my WAN address as if I go to the web and ask my IPv4 address it is 99.98.xxx.xx

If my phone is on the deco_M5 wireless I can enter the LAN address, 192.168.0.106:8082 and it works. So I am guessing I have the port forwarding set up correctly for the deco_M5
Problem may be related to the deco app showing the wrong WAN address. Still wondering if I need bridge mode from the Arris?

Rich
0
0
#4
Options
Re:Cannot get port forwarding to work on Deco M5
2017-09-28 10:57:15
Seems strange.
Since you have setup the Arris router as your root router, the Deco app could only get a private IP address from Arris router as its WAN IP address.
Could you help provide several screenshots about your settings, including the IPv4 page of Deco APP, the Port Forwarding page of the Deco APP and the Port Forwarding rules on your Arris modem.

In addition, please try to test the port forwarding rule via a telnet command:
telnet 99.98.xxx.xx 8082
0
0
#5
Options
Re:Cannot get port forwarding to work on Deco M5
2017-09-28 21:57:07








The Arris screenshot and the IPV4 screenshot look ok to me. But the Port Forwarding screenshot only shows me a description of what port forwarding is and not what my settings are. The plus in the lower right gives me the screen to enter port forwarding settings but doesn't display any that may be there.
The Telnet command I am not familiar with. I believe it only works for windows computers and mine is Linux. I do have a Windows 7 laptop. Can I do the Telnet from it to the Linux desktop/server?
0
0
#6
Options
Re:Cannot get port forwarding to work on Deco M5
2017-09-29 09:01:01
That's the issue. Port Forwarding rules are not set up successfully on the Deco router, thus you cannot remote access your desktop server.
When you tap the plus icon to add a rule, please pay attention that you have type in all the necessary parameters (tap Select from Device and choose your Desktop server in the device list), after that, remember to click Done.


0
0
#7
Options
Re:Cannot get port forwarding to work on Deco M5
2017-09-30 06:51:01
Life is Good! I probably failed to hit done. Wouldn't be the first time. Thankyou, all is well.
0
0
#8
Options