Archer C50 Power Cord issue

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

Archer C50 Power Cord issue

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Archer C50 Power Cord issue
Archer C50 Power Cord issue
2017-12-14 01:37:35
Model :

Hardware Version :

Firmware Version :

ISP :

I purchased an Archer C50 a few weeks ago and it has been working perfectly up till this morning. Without warning it simply turned off. I checked the power button which was still in the On position, unplugged and plugged in the power brick at which time the router came back up and was working. After about 5 minutes the unit powered off again. I repeated the unplug and plug back in procedure which again worked for a few minutes. I have since replaced the power brick with a variable power supply unit I have and the router has been stable for the last 4 hours. I expect that the power cord (Model T120200-2B1) has failed and needs to be replaced.
Is it possible to replace it without sending the entire unit in as I do not have another router to use in it's absence. Unfortunately I no longer have the receipt nor the box to just exchange it.

Thank you,

Matthew.
  0      
  0      
#1
Options
1 Reply
Re:Archer C50 Power Cord issue
2017-12-14 11:33:10
Maybe you can contact the retailer to get a replacement of it. Or contact the tplink technical support for RMA.
  0  
  0  
#2
Options

Information

Helpful: 0

Views: 575

Replies: 1

Related Articles