Infuriating problem with Archer A2300 and USB printer function with TP-Link printer connection utility

Infuriating problem with Archer A2300 and USB printer function with TP-Link printer connection utility
Infuriating problem with Archer A2300 and USB printer function with TP-Link printer connection utility
2017-12-31 06:20:12
Model :

Hardware Version :

Firmware Version :

ISP :

We have three PCs (HP, Acer, Lenovo) all running Windows 10. We used to have a Netgear router with a USB port into which we plugged our old but still functional HP LaserJet 1020 printer. It worked well. Then the router died and we replaced it with a TP-Link Archer A2300 router. The new router also has a USB port, and when we set up the LaserJet with the new router, everything worked fine.

Recently it was necessary to take the LaserJet off line for a couple of weeks. I then reconnected it. The printer was no longer in the printer list of the HP computer. I checked the router web page and under "configure printer," there was no printer. I reinstalled the TP-Link printer utility (repaired, did not uninstall and reinstall). The HP printer was still not in the computer's list of printers. I reinstalled the printer driver, the last step of which necessitated connecting the printer directly to the computer. Everything then worked as before. However, we then discovered that the HP printer had disappeared from the other two PCs, the Acer and the Lenovo. I repeated the reinstallation process with the Acer computer, and everything worked as before. However, the printer had disappeared again from the HP computer and was also not on the Lenovo. I tried to repeat the process with the Lenovo, but after I reinstalled the TP-Link printer utility, every time I tried to run the program, it said the computer needed to be rebooted. I rebooted the computer three times. No change: A dialogue box to reboot popped up. Instead of "repairing" the printer utility, I then uninstalled and reinstalled it on the Lenovo. No improvement.

So to summarize - and leaving out most of the complications - the problem is that when I get the printer set up through the router on one computer, it disappears from the other two, and my attempts to try various maneuvers to get it installed on the other two just make everything worse.

This is driving me crazy. I cannot figure out why this is happening. Everything worked fine in the beginning and now it's all screwed up. I am seeking information on how to solve this. Thank you.
0
0
#1
Options