Archer C7 V2, 5ghz WiFi looses internet connection while the 2.4ghz is fine.

Archer C7 V2, 5ghz WiFi looses internet connection while the 2.4ghz is fine.
Archer C7 V2, 5ghz WiFi looses internet connection while the 2.4ghz is fine.
2018-03-08 04:14:32
Model :

Hardware Version :

Firmware Version :

ISP :

Archer C7 V2, 5ghz WiFi looses internet connection while the 2.4ghz is always fine. If i browse for WiFi signal, the 5ghz still shows up but without an internet connection. My Samsung Note 8, Samsung TabA, Microsoft Surface Pro4 & iPhone 7s all experience the same issue. The latest Firmware update from 1/18 is installed on the Archer C7. If I reboot C7 it works for a few hours and then looses internet connection again.
0
0
#1
Options
9 Replies
Re:Archer C7 V2, 5ghz WiFi looses internet connection while the 2.4ghz is fine.
2018-03-08 10:12:10
What's your firmware version? On the website, it says the 170525 has fixed the 5GHz issue. Did you change any wireless settings, like channel? I would say change 5GHz security type, SSID and channel. If it used to work fine, you may also factory reset the router.
0
0
#2
Options
Re:Archer C7 V2, 5ghz WiFi looses internet connection while the 2.4ghz is fine.
2018-03-09 06:48:15
I did that update and the latest 3.15.3 Build 180114 firmware update also. Never took the channel out of the Auto setting. Left every at its default except for the name. SSID is enabled. It is not a new problem for me. It has always had a tendency to drop the internet connection.
0
0
#3
Options
Re:Archer C7 V2, 5ghz WiFi looses internet connection while the 2.4ghz is fine.
2018-03-09 11:28:46
Hi, you can have a try to change channel width to 20MHz for 5GHz, and reboot the router, then see if it helps.

BowmanC7 wrote

I did that update and the latest 3.15.3 Build 180114 firmware update also. Never took the channel out of the Auto setting. Left every at its default except for the name. SSID is enabled. It is not a new problem for me. It has always had a tendency to drop the internet connection.
0
0
#4
Options
Re:Archer C7 V2, 5ghz WiFi looses internet connection while the 2.4ghz is fine.
2018-03-10 05:23:25
Hi Flying Snow, There isn't a bandwidth adjustment for the 5Ghz wireless. We can only select a channel in the 5Ghz settings. There is only a bandwidth adjustment in the 2.4Ghz wireless. Thanks for trying though!
0
0
#5
Options
Re:Archer C7 V2, 5ghz WiFi looses internet connection while the 2.4ghz is fine.
2018-03-13 08:18:06
not sure where you are US? your OP is not filled in.....but for me CDN Version 17 Beta fixed that and CDN version 18 beta is working too , though Version 17 is Better....

http://forum.tp-link.com/showthread.php?104053-Archer-C7-V2-Request-for-Firmware-Update&p=233658&viewfull=1#post233658

KB
0
0
#6
Options
Re:Archer C7 V2, 5ghz WiFi looses internet connection while the 2.4ghz is fine.
2018-03-13 19:06:40
Hi, sorry for not stating my location. I'm in the USA. Optimum/Cablevision is my provider. I've already installed the latest 2018-01-17 firmware update and all proceeding updates as they came out to try and resolve this issue. I don't see any Beta firmware version versions coming out for the USA at this time. Thanks for the effort though. How do I get TP LINK support to chime in and offer some help? Or do I just switch to another manufacturer?
0
0
#7
Options
Re:Archer C7 V2, 5ghz WiFi looses internet connection while the 2.4ghz is fine.
2018-03-14 03:26:21
The V17 Betas work for me .... Version 18 Beta (CDN) is stalling after about 24hrs and I need to reboot my Router , Version 17 is the "FIX" FW for "Devices (Laptops) with Killer (Branded) NICs " installed issue .....it 's the top sticky thread of this Forum but the FWs are in post# 43 here :

http://forum.tp-link.com/showthread.php?94180-Archer-C7-router-crashed-by-Dell-laptop-with-Killer-adapter&p=195886&viewfull=1#post195886


As for TP Support , there wseem to drop in ocassionaly but only for Major Issues (like above) they don't provide everyday support for Issues , they expect people to Read the FAQs on their Product's Page...... they certainly produce enough FAQs :)
0
0
#8
Options
Re:Archer C7 V2, 5ghz WiFi looses internet connection while the 2.4ghz is fine.
2018-03-16 13:39:17
0
0
#9
Options
Re:Archer C7 V2, 5ghz WiFi looses internet connection while the 2.4ghz is fine.
2019-09-09 15:26:23

I took a look at the source code and found a work around for this. I tried it las night. works like a charm

The rule that applies protection against using 5G in restricted countries happens in a part of the code where NO RULES LIKE THIS SHOULD EXIST! These are SIMPLE SOFTWARE DESIGN PARADIGMS.

The error happens when the wireless transmitter SWITCHES CHANNELS, but a specific scenario pushses your router into "Malaysia Mode" (what kind of crap country isn't allowed to have 5G)

SOLUTION:
 

0.5) if you havent already MANUALLY flash your firmware to latest through here https://www.tp-link.com/us/support/download/archer-c5400/v2/#Firmware

  1. Flash/Factory reset your router with the reset pinhole button back to factory 
  2. Plug in ethernet cable directly to the router and the device you will manage it from (very important, we are going to disable wireless from the get-go to get the router in the correct state)
  3. After your router boots up after factory reset, go to tplinkwifi.net to follow the setup wizard
  4. Go through this like normal, EXCEPT
    1. SET YOUR TIME ZONE TO CENTRAL (we'll correct this later if it's not your timezone) 
    2. When you get to the part where you specify your internet connection, there's an "advanced" section button. In that section there is a drop down to specify a country mode. 
      1. SELECT MALAYSIA FIRST, THEN SELECT NONE. this is just to ensure that this drop down wasn't accidently triggered
    3. When You get to the screen to name your Access points and give them passwords. !!!DISABLE ALL OF THE ACCESS POINTS. WE DO NOT WANT WIRELESS ACCESS POINTS ON UNTIL THE VERY LAST PART !!!
  5. The setup wizard should be complete at this point and you should have no wifi
  6. Go to Advanced > System Tools > Time 
    1. Set/replace The NTP Servers to the following below:
      1. 0.north-america.pool.ntp.org
      2. 1.north-america.pool.ntp.org
    2. Select your CORRECT TIME ZONE
    3. Click "Obtain" and let your router (assuming it has access to the internet) obtain the correct time from those new NTP servers 
    4. As soon as it resolves the correct time, click SAVE
  7. REBOOT THE ROUTER USING THE TOP RIGHT BUTTON
  8. Log back in after reboot, go back to time and confirm the CORRECT TIME IS NOW SET EVEN AFTER THE REBOOT
    1. If correct time is not set, redo everything until it can hold the time after a reboot
  9. Go to Advanced > Wireless and let's setup the wifi access points
    1. The main goal of this part is to eliminate any thing that says "AUTO", we want to manually select every option, if we let the router auto select, it will just go back into country restricted mode
    2. On Each access point (2G, 5G1, 5G2), select the LARGEST WIDTH (i think it's 40Mhz for 2G and 80Mhz for 5G... whatever the largest number is)
    3. On Each access point (2G, 5G1, 5G2) select the LAST CHANNEL NUMBER AVAIABLE (I think 2G is 11, 5G1 is 80, 5G2 is 160... whatever the highest number is in those drop downs, use those)
    4. On Each access point (2G, 5G1, 5G2) select AES encryption (probably doesnt matter, but we DO NOT WANT THIS ROUTER TO EVER AUTO SELECT ANYTHING)
    5. On Each access point (2G, 5G1, 5G2) Select an authentication method that suits your password needs (WPA2 non-enterprise is usually the standard)
    6. DONT FORGET TO CHECK THE BOX TO ENABLE EACH ACCESS POINT
  10. Save, Save, Save
  11. REBOOT THE ROUTER USING THE TOP RIGHT BUTTON
  12. Log back in, go to advanced, go to "internet" (i forgot the name of the drop down, writing all of this from memory at work) nd make sure you unselect the checkbox that says "igmp proxying"... we want to disable that
  13. SAVE. 
  14. Make any other changes youd like... (i disable the firewall and anti virus nonsense because its a piece of crap and uses too much of the available memory and CPU)
  15. Save... reboot... enjoy

 

Working without issues last 6 hours. 
If anyone can post screen shots while they do this to help make it easier for more novice users, that would be a..

TREMENDOUS HELP THAT TP-LINK WON'T PROVIDE

Let me know if it works out for you guys as it did for me. 

0
0
#10
Options